PDA

View Full Version : Need a lot of help! (HDD, Network, Sound...)



NerdIII
03-21-2004, 08:43 PM
Hi everyone. I'm new to this board and basically to Linux.
I tried SuSE before, but the network never worked. So I hunted down my Knoppix 3.2 CD in my CD stack and started it up. Internet was working, FAT32 partitions, too. I searched the internet for HDD installation with Knoppix and found the hdinstall script. First I accidently made hdc bootable and LiLo got into it's MBR. As I only boot from hda I ran the script again, but it seems it still read from the existing config file on my Linux partition, because nothing happened.
Bare with me... I'm a Windows user, I don't like this console stuff. Anyway I opened this big scaring black screen with the console prompt blinking.... waiting for my next unwanted command to reformat my system.
No. I found this lilo.conf, install-mbr, etc. and got it to install correctly. At least I can start Windows again to write this text :D
Because in Debian I have neither FAT32 access nor a working network.
Mount says there would be no entry in fstab for dev/hda
and Ip.whats-the-name says the device can not be found. Though it knows that a network adapter exists. And it works, usually.

Has anyone encountered similar problems or could help me otherwise?
I would like to use Linux for cross platform coding with Delphi/Kylix. :roll:

P.S.: I've also a bug with my gfx card. It is hard set to 60Hz after a Linux session and can't be reset until I unplug the card!
I have an AthlonXP, Radeon 8500 LE and a mainboard with VIA chip set.
But that surely belongs to another thread :wink:

OErjan
03-22-2004, 03:41 AM
if you post your /etc/fstab it will help wit the mount part.
you could probably mount the hdd manually.
what you do is type (as root) mount -t vfat /dev/hdXY /mnt/c
for this to work you need to have the directory /mnt/c first (mkdir /mnt/c).
the XY are driveletter and partition number.
to see your /etc/fstab might help. and together with that the output from fdisk -l.

NerdIII
03-25-2004, 12:30 AM
Er, well it's ok. The drives are not a problem anymore. I already made my system more unstable, by switching from 'testing' to 'stable' to 'unstable' to 'stable' and now make xconfig wont work on the kernel 2.6.4. But hey, last time it compiled I got the latest ALSA sources into it that now support my Aureal AU8830 chip. (There aren't even drivers for WinXP for it!)
The scirpts spit out all sorts of Q... errors. Seems as if I got a wrong version of the QT libs or a wrong version of the kernel or... I don't know.
Did I mention how much I hate this 'dselect' program? I want to install one package and it suggests me to uninstall vsysinit and other stuff freeing 200 MB on my hard disk :twisted: . I didn't do it though... because I already uninstalled too much. Sorry to annoy you with all my begginner's faults, but I would be really happy if I I could get xconfig to work again (and all few other programs.)

P.S.: When I type "apt-get install --reinstall *" it tells me that the package 'bin' can not be found. This is no package name if I'm not mistaken. Should I look into some files throw out this entry and try the command again in hope that it will autocorrect all of my problems? :D