View Full Version : X works from CD - won't start when installed

03-23-2004, 06:58 AM
Installing on Emachine 384mb ram 1.8ghz
graphic mode works fine from Knoppix CD.
Installed system cannot startx altho selected to start graphic mode when dong the install. (have successfully installed on an older machine).
When using startx, message is "fatal server errror no screens found"
Tried xf86cfg
Message "fatal server error. XFree86 has found a valid card configuration
Unfortunately the appropriate data has not been added to xf86PciInfo.h"

Any ideas appreciated.

03-23-2004, 03:23 PM
Boot up with the CD. After Knoppix has fully booted, mount your hard drive and make a backup copy of your XF86Config-4 (found in /mnt/hdax/etc/X11/). Then copy the verson of /etc/X11/XF86Config-4 from the CD to /etc/X11/ on your hard drive. You'll be overwriting the old XF86Config-4 on your HD with the one from the CD This may do the trick. For some reason I find that this sometimes doesn't get moved over correctly to the HD during an install.

03-23-2004, 09:55 PM
Thank you for the reply.
Suggestion worked.
I had to change permissions of the file on the installed system:
chmod 666 /etc/X11/XF86Config-4

:) :) :) :) :) :) :) :) :)