PDA

View Full Version : Newbie: Problems customizing knoppix lite



freeballer
02-24-2003, 08:23 PM
I'm away from the effected pc, and since shut it down, but I will try to sum this up the best way possible. and please remember that I'm a newbie to linux altogether, and a total newbie with debian (my first experience). I would also like to point out that I tried knoppix lite and would still like to customize it further, by adding mozilla for one and kmail, with some konsole tools such as bitchx, pine and that I'm looking for a distro with kde not icewm so most of the other mini CDs are great and all but aren't what I'm looking for.

I used the guide @ http://gnubox.dyndns.org:8080/~sunil/knoppix.php
I did everything I was told to until I got to customizing the packages inside of it, instead of using the "kicklist" file I chose to use "synaptic" cause I stupidly used the full knoppix CD to remaster instead of the knoppix lite (which I had tried previously and got fed up when I made the
stupid mistake of entering the wrong DNS server when setting it up), I wanted to get rid of that many packages so I could fit one on a 80mm CD @ 200MB. I had troubles starting "synaptic" and used the su, cause I wasn't sure I'd had the appropriate permissions and played with the
display=[ip address]:0.0 cause I wasn't sure it it was suppost to work with my ip on the net, my private ip address, or the loopback. After a few minutes online talking on irc to one of the channels on knoppix for help. the problem seemed to fix itself and "synaptic" started just fine.

I removed and added various packages including all those international settings and all of the games. I also included some like gftp, bitchx, pine, jpilot/pilot-link. When I was done I used the "proceed" button and it started the process, but at the end there was a message displaying
that there had been an error, the error was unknown to me but i did however recognize that it didn't remove some directories for some packages for whatever reason + the rest was trunciated. I took at look inside "synaptic" and it seemed like half of the packages had not installed/removed. I preceeded to re-remove them again and add them and hit proceed, this time with no error. I went on with the rest of the steps and then attempted to create the KNOPPIX file for my cd.
When I came back the the pc, it seemed stuck on a bunch of "0","2", "1", ":" stuff and when I hit a key it kept repeating "bash [something] not found", which obviously I had no idea what the heck it was telling me. I had been curious also and I took a look and the size of the knoppix directory it uncompressed the "KNOPPIX" file into and the size was somewhere near 1.6GB so it seemed to me that no packages
were actually removed because i'm under the impression that the un-edited, uncompressed version was somewhere near 1.7GB and I had supposedly deleted 400MB of the size when ininstalling/removing
packages.

I'd appreciate any help, or suggestions at all. and if you need more information, some that I either left out or did not think significant, please email me, or reply on this message board. I'd also entertain suggestions on an alternate guide for this, or programs, files.

P.S. I'd also tried to use a couple of scripts to automate the process that were posted on the message board of knoppix.net but they also gave me the above mentioned "bash" error.

P.P.S. sorry for being so wordy, but I thought any and all information would be help to anybody who had answered this post.