View Full Version : Help please!!! Kernel panic: Attempted to kill init

04-01-2004, 06:16 PM
I think that *I*'m panicing more than my kernel!

I'm in serious trouble. PLEASE, someone, help me!

Let me preface by saying that I'm a complete and total newbie, so I need you to please be specific about how exactly I need to go about doing whatever needs to be done.

I have a dell latitude computer. It had winXP on it. Recently I reformatted the hard drive, repartitioned it, and made it dual boot - winXP and Debian unstable (which I installed off of the Knoppix disc). Since then, I've been using linux mostly, and grown to like it very much.

My hard disk is partitioned as follows:
hda1 is a dell thingy that I never use, only a few MBs big. In windows, I never knew it even existed.
hda2 is NTFS with the windows system on it.
hda3 is ext3 with the linux system on it.
hda4 is an extended partition, with:
hda5 - a 400MB swap partition for linux, and
hda6 - a fat32 partition for storing data files that I'd use both in windows and in linux.

My linux partition became full, so I decided to move some empty space (2 gigs) from my windows partition to the linux one.

First I used qtparted to shrink my windows partition. Everything appeared to work fine. Then I logged into windows. I figured I shouldn't be playing around with my linux partition while linux was running from it. So, inside windows, I used Partition Magic to expand my linux partition.

A few minutes into the procedure, the computer crashed with a "blue screen of death". How scary.

When I tried to reboot, my lilo was gone. completely gone. Instead, when I booted up, it just gave me a screen with one L and a whole bunch of 9's afterwards, and got stuck there. I was only able to boot up with the Knoppix CD.

I used Lilo -r to fix the lilo thingy. After that, I was able to get to the lilo menu, but not past that - if I chose linux, I got horrible error messages that scrolled by so quickly that I couldn't see what they said, and they never stopped until I manually powered down the computer, which of course also shut off the monitor. If I tried logging into windows nothing happened - immediately after the lilo menu I just got a blank black screen, and it stayed there forever.

Back in Knoppix, I did a bit of websurfing, tried getting some advice from a friend, and ended up running fsck on the linux partition. I ran it with fsck -f -y /dev/hda3 and it found tons of errors, and fixed them all.

After that, I tried rebooting again. This time, linux appears to be starting correctly, it goes through all the text stuff it usually does when I boot up, until all-of-a-sudden I get a horribly scary error message:

kernel panic: Attempted to kill init

And the computer freezes there, with the caps, num and scroll lights flashing.

trying to log into windows, the same thing happens - just a blank screen.

At the moment, it's more important for me to get linux working than it is to get windows working.

Inside knoppix, I'm able to mount and read all my hard disks - it appears that all the data is still there.

I'll just add that Partition Magic was intending to do two things - first MOVE the linux partition to an earlier position on the disk, and secondly expand it, since the 2 Gigs of free space were before the partition, not after it. (They were freed up from my windows partition, which is hda2.) The blue screen of death happened during the moving stage, about a third way through.

I have no idea what this 'attempting to kill init' means, or what I can do about it.

PLEASE HELP ME - I'm freaking out here!

Thanks in advance,