PDA

View Full Version : via8233, anyone?



fingers99
02-25-2003, 11:06 PM
Has anyone managed to get sound in Knoppix with the via8233 onboard sound card? If so, please, please, tell me how! (I'm talking of a HD install, here, with 3.1)

Driving me nuts!

Tapsa
02-25-2003, 11:18 PM
You need alsa driver instead oss one that knoppix uses. Havent tryed it yet in knoppix but in my gentoo it works perfectly.

fingers99
02-26-2003, 06:24 PM
Trying that: so far no joy with rc.6 so I'll try rc7.

fingers99
02-28-2003, 12:41 AM
I tried rc7 and still no joy: I get the same old "no /dev/dsp" messages and unable to load messages from that godaweful sndconfig "tool".

Has anyone managed to get _anything_ needing the alsa drivers to work in Gentoo? If so, please tell.......... :roll:

pankepasa
03-08-2003, 10:56 AM
Hi, at the moment you have to use the rc5, rc6 and rc7 do not work :-( I
hope they will work in the rc8 or in the next version of alsa.

There are some users of the via8233 reporting the bug:
http://sourceforge.net/tracker/index.php?func=detail&aid=688172&group_id=27464&atid=390601
http://sourceforge.net/tracker/index.php?func=detail&aid=683528&group_id=27464&atid=390601
http://sourceforge.net/tracker/index.php?func=detail&aid=661110&group_id=27464&atid=390601

Try rc5 or wait for the next release.

Cheers,

Ramon Acedo

tjudycki
03-21-2003, 11:33 AM
Have you managed to handle ethernet card at via motherboard? I'm trying with via epia v800a and while booting it says:

/lib/modules/2.4.19-xfs/kernel/drivers/net/via-rhine.o: init_module: No such device
/lib/modules/2.4.19-xfs/kernel/drivers/net/via-rhine.o: insmod /lib/modules/2.4.19-xfs/kernel/drivers/net/via-rhine.o: failed
/lib/modules/2.4.19-xfs/kernel/drivers/net/via-rhine.o: insmod via-rhine failed

Output from "lspci -v"

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (ver 51)
Flags: bus master, medium devsel, latency 32, IRQ 15
I/O ports at e800 [size=256]
Memory at eb000000 (32-bit, non-prefetchable) [size=256]
Capabilities: <available only to root>

I'm using Knoppix 3.1 from January 2003.

Maddy
03-23-2003, 07:00 PM
Hello there,


I am using knoppix 3.2 and I'm having the same sound problems with the via 8233 chipset, does anybody can help me with this, I'm using this from cd, is there any option to use my sound ?

Maddy
03-23-2003, 07:33 PM
OK I found something else but still no solution.


When I try to configure my soundcard (the via 8233 chipset onboard) sndconfig finds it but seems to be unable to load the modules from the knoppix cd although they are there, however I found somewhere on the cd another place with modules who are packed and there is a via8233 module available BUT and here comes my question.

Since the knoppix cd is write protected :-) I am unable to place the via8233 module there, so I placed it in my /home/knoppix directory and now I want to add this directory ( yes ADD) to the /lib/modules/2.4.40-xfs/dirvers/sound directory where the other modules are.

How do I do this

Dirk

RockMumbles
03-23-2003, 09:24 PM
Try this, as root cd to where the module is located, and then:

insmod ./via82cxxx_audio.o
(or whatever the knoppix module is named, just make sure to put the ./ dot-slash in front of the name)

Note: from what I've read there is not just ONE via8233 audio setup, it depends on the implementation (support chips etc.) on the motherboard.

rock

thewalkingman
03-25-2003, 03:00 PM
sigh

So now I sit waiting for a release that fixes this error

Samsara
03-26-2003, 10:40 AM
sigh

So now I sit waiting for a release that fixes this error

Yeah, me too. At least you got company :roll:

Edulix
06-05-2003, 07:43 PM
Hey dudes, there is someone with a via8233a onboard sound card trying to use it or using it knoppix ? It does not function in my knoppix 3.2. There is a litlle explanation in the bugzilla: http://knoppix.net/bugs/show_bug.cgi?id=162#c2.

//
Thanks you all knoppix!!

www.rzr.online.fr
10-02-2003, 05:19 PM
has this been fixed on 1st of release 3.3

Because I managed to add alsa driver w/ debian woody on a MSI K7T board

later

www.rzr.online.fr
10-10-2003, 02:22 AM
It seems to be fixed

the via82cXXX is laoded and works

nice


BUT : the DRI (3D) is not working with my card @ http://Rzr.online.fr/n/ati.htm