View Full Version : Knoppix 3.3 Kernel to 2.6.5 problems with initrd-tools ver.

04-12-2004, 05:22 AM
Hello there I am trying to install the 2.6.5 Kernel onto my out the box Knoppix 3.3 (Kernel 2.4.24) using apt-get (KPackage) since 1. Im a lazy bastard and 2. am not quite at the pint to build my own kernel (tried earlier today...) anyways, I get the following error:

<pt-get install --yes 'kernel-image-2.6.5-1-k7' ;echo RESULT=$?
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kernel-image-2.6.5-1-k7: Depends: initrd-tools (>= 0.1.63) but 0.1.62 is to be installed
E: Broken packages

Now, I know that there is already a 0.1.64 version of intrd-tools out there (long story how I found out) but Kpackage wont install it and vehemently isists that my 0.1.62 version is current and I dont know where else to find the .64 version to dl...
Ive tried update and upgrade but it still won't work...
Anyone know anything about this issue?