PDA

View Full Version : Can't get my MA401 wifi card working on Knoppix



charlie126
04-13-2004, 11:32 PM
I have installed Knoppix onto my hard disk (laptop M700) as i liked it very much. But my wireless network just does not seem to work. I am very new to Linux so i donít really know where to start diagnosing.

I know that the card works fines with my Netgear FM114p router because I used to use it with Windows XP.I have no problems connecting to my laptop, to the Internet via router when I am using cables with my 3com PCMCIA network card.

Is there any chance someone can guide me through the process of getting this card working? Please

I have taken off all encryption; I have the router set as a DHCP. (Where would I need to go in Knoppix to give the card a static IP?

The green light at present on the card just keeps on flashing.

The Knoppix kernel version I am using is 2.4.24 I have also tried to configure it though Wavelan Configuration, looks like I am configuring it wrong somewhere.

I have also been on the Netgear website and followed the instructions on installing there driver. But it refuses to install. Kernel error?? (driver name: ma401_redhat73_driver)

I can provide you any information necessary

Thank you in advance

Charlie

charlie126
04-14-2004, 12:06 AM
I have just managed to get it working......not exactly sure how. I viewed a few setting using the following commands: - 'dmesg', 'lspci' and the when i entered 'iwconfig' the green LED stopped flashing indicating connectivity.

Next thing is that i want to setup encryption. How and where would i do this??

Any suggestions ??

aay
04-14-2004, 03:46 AM
If you run netcardconfig as root, a dialog will walk you through all the settings for your card.

Durand Hicks
04-14-2004, 04:49 AM
How do you want to do this, the easy way or the hard way?
The easy way: open console as root and type: netcardconfig and enter your parameters as necessary.

The hard way: open console as root and type: iwconfig eth1 essid "router name" key 12345678901234567890123 and press enter. Next type: ifconfig eth1 192.168.1.x netmask 255.255.255.0 and press enter. Finally type: route add gateway 192.168.1.1 and press enter.

Notes:
router name is your essid name for your wireless router, key is your 26 character alphanumerical string generated by your router for wep. gateway is your router's lan ip address.

To keep a static ip, you'll have to edit a file, /etc/pcmcia/network.opts and enter your parameters there. If that doesn't do it, edit /etc/network/interfaces and that should do it. I had both edited so I don't know if it'll work one without the other but in my case both needed to be edited to force it to remain static ip, instead of using dhcp.

charlie126
04-16-2004, 12:29 AM
Thanks guyz you have been a great help!!!!! :D

mzilikazi
04-16-2004, 12:40 AM
Next thing is that i want to setup encryption. How and where would i do this??

Any suggestions ??

man iwconfig