View Full Version : "Can't find KNOPPIX filesystem, sorry.

04-16-2004, 10:37 AM
what do i do if i get this error when booting knoppix all I know is it is something to with the hardrive because it dosen't do it when the hardrive is unplugged

"Can't find KNOPPIX filesystem, sorry.
dropping you to a very limited shell."

05-07-2004, 09:44 AM
I got the same message on my 3.4 CD. I thought this should be easy and for non-Linux people to explore Linux without to much hassle. I have seen on other threads about "remastering", but I don't even know what that means... I just want my CD to work :cry:

05-07-2004, 06:28 PM
unplugging the hardrive works but nothing else i've tried it's brilliant other than that

05-08-2004, 09:36 PM

I've been searching the FAQs for days now and can't find an answer to my problem. I am receiving the same error message and the closest answer I could find was that my download was corrupted or failed to burn properly. I have downloaded 'Knoppix 3.3' 6 times from various sources and used 2 different burning programs. I always get the exact same error message:

Can't find KNOPPIX file system, sorry.
Dropping you to a (very limited) shell
Press reset button to quit.

I have tried the discs on 2 different PCs, a desktop P3 533 and an old IBM Thinkpad P2 333 and get the same message with both. The downloads seem fine, checksum works etc..

I am new to the Linux community,although I did have Red Hat Linux on the laptop for a while. I mostly want to learn more about Linux (and get away from Micro$oft) but need the MS functionality until I am more comfortable with Linux and can accomplish the tasks I need on a daily basis. Knoppix would be perfect for me because I can play around and familiarize myself with it and still do my work without disruption. Any help much appreciated.

Dave Lewis

05-09-2004, 07:05 AM
First off: what versions of knoppix are you using?

Second off:
have all of you tried A: cleaning you CD rom laser (they do need some compressed air/ head cleaning every once in a while, especially if in a dusty environment
B: verifing that there are no scratches/smudges/fuzzies/etc. on the disk
C: booting with the testcd boot option
D: trying a buddies burned copy and/or in a different computer
E: (least preferable step) reburning at a 1X speed (preferably on a different manufacture's media i.e. some froma better dye maker *best is Taiyoda Yoden [or something similar to that name, but I am to lazy to double check it online]*, and if you belive that all media is the same, then please go and buy all CDs in the future. There is a difference, but not for most systems, some are very finiky though) (some computer's cd-rom drives don't really like CD-Rs, that can be an issue on older systems especially)

P.s. sorry for spelling/runons, I am very tired in the head but not in the body.

05-26-2004, 01:01 PM
I've got some hardware that is failing with this error message.

Viglen Genie P3 450.
hda is "Maxtor 6E040L0"
hdc is "SAMSUNG CD-ROM SCR-3231"

It runs Knoppix 3.1 fine but two different customisations of 3.4 (2004-05-17) , each of which works fine on other machines completely fail.

dmesg on the booted 3.1 machine shows some errors such as:
"FAT: Did not find valid FSINFO signature. "

The testcd option has does not improve the situation.

05-27-2004, 09:31 AM
Here is the hardware as indicated by the older knoppix 3.1 that does boot:

knoppix@ttyp0[knoppix]$ lspci -v
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
Flags: bus master, medium devsel, latency 64
Memory at f8000000 (32-bit, prefetchable) [size=64M]
Capabilities: <available only to root>

00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03) (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, medium devsel, latency 128
Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
I/O behind bridge: 00009000-00009fff
Memory behind bridge: f4200000-f5ffffff

00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
Flags: bus master, medium devsel, latency 0

00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80 [Master])
Flags: bus master, medium devsel, latency 64
I/O ports at 1040 [size=16]

00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00 [UHCI])
Flags: bus master, medium devsel, latency 64, IRQ 9
I/O ports at 1060 [size=32]

00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
Flags: medium devsel, IRQ 9

00:0c.0 Multimedia audio controller: Yamaha Corporation YMF-740C [DS-1L Audio Controller] (rev 03)
Subsystem: Intel Corp.: Unknown device 5332
Flags: bus master, medium devsel, latency 64, IRQ 10
Memory at f4108000 (32-bit, non-prefetchable) [size=32K]
Capabilities: <available only to root>

00:0d.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
Subsystem: Intel Corp. EtherExpress PRO/100+ Management Adapter
Flags: bus master, medium devsel, latency 66, IRQ 11
Memory at f4100000 (32-bit, non-prefetchable) [size=4K]
I/O ports at 1000 [size=64]
Memory at f4000000 (32-bit, non-prefetchable) [size=1M]
Expansion ROM at <unassigned> [disabled] [size=1M]
Capabilities: <available only to root>

01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c) (prog-if 00 [VGA])
Subsystem: ATI Technologies Inc Rage Pro Turbo AGP 2X
Flags: bus master, stepping, medium devsel, latency 66, IRQ 11
Memory at f5000000 (32-bit, non-prefetchable) [size=16M]
I/O ports at 9000 [size=256]
Memory at f4200000 (32-bit, non-prefetchable) [size=4K]
Expansion ROM at <unassigned> [disabled] [size=128K]
Capabilities: <available only to root>

06-02-2004, 02:43 PM
I've just verified that this error also happens, on the same machines, with a commercially produced Knoppix 3.4 CD, so the problem is not the CD burner used the cut the CDs.

06-03-2004, 11:46 PM
I have a IBM Thinkpad R40E that I'm trying to get Knoppix to start on.

The same error happened to me, but using "nodma" seems to have fixed it.

06-04-2004, 12:26 PM
I was having the same problem, but after I deleted and recreated my partitions using another Linux disk I was able to boot to Knoppix and do a HDD install.

For some reason when trying to use my swap partition at the beginning of the HDD it was giving me this error.

If at all possible I would try recreating partitions on the HDD and see if that fixes it.

06-04-2004, 12:52 PM
The "nodma" option fixed the problem for me on the hardware listed above and one other machine.

Thanks houdini.