If you use the Knoppix 7.2.0 DVD you have already libgtk-3-dev. Look inside the list of packages at http://ftp.uni-kl.de/pub/linux/knoppix-dvd/dpkg-l-dvd-720.txt

If you have got the Knoppix 7.2.0...