I too would be interested in knowing whether the default version of Orca/At-spi in 7.3 works with Firefox/Iceweasel. Having to source an older version of these from Debian Squeeze has been my biggest...