Results 1 to 6 of 6

Thread: 3.4 not booting on my laptop (Toshiba Satellite 4010cds)

  1. #1
    Member registered user
    Join Date
    Feb 2004
    Posts
    72

    3.4 not booting on my laptop (Toshiba Satellite 4010cds)

    This laptop is from 99 or so but the bios isn't seeing the disk on boot.
    Tried Smart Boot Manager, and still no luck.
    Get error code 0x0C when trying it with Smart Boot Manager (which is a different error code than the 'disk not ready' error code if you try to boot when the CD isn't scanned by the drive yet.

  2. #2
    Member registered user
    Join Date
    Feb 2004
    Posts
    72
    I should add that this is a laptop that I can easily run 3.2 on , and can run 3.3 on with the use of a
    knoppix screen=800x600 noddc
    command.
    And i've been able to get live cd's such as clusterknoppix to boot using Smart Boot Manager.

    Something's different about 3.4's booting.
    Any suggestions?

  3. #3
    Junior Member
    Join Date
    May 2004
    Location
    Berlin
    Posts
    4
    hi there, i have a similar problem: toshiba satellite 2770. didn't have any problems with version 3.3, but with 3.4 the laptop hangs after this message: "
    ACPI Bios found, activatin modules, ac battery button fan processor thermal"

    can anyone help?

  4. #4
    Member registered user
    Join Date
    Feb 2004
    Posts
    72
    I got past my booting problem by reburning the CD. (even though the old cd booted fine on two other computers, I guess it didn't like the way it was burned the first time)

    Yes, I had that same hangup after it detected the powerbutton apci stuff.

    Booting another system indicated that the USB detection comes after that.
    so..
    I did a
    knoppix screen=800x600 noddc nousb
    and it booted.

    the nousb got past the error. the noddc is because knoppix doesn't like my 'tosh' monitor.
    Maybe the new USB scanning doesn't like toshiba's USB hardware.


    - fixed typo in the word 'knoppix'...

  5. #5
    Member registered user
    Join Date
    Feb 2004
    Posts
    72
    update..

    I've tried booting with linux26 instead of knoppix

    linux26 noscsi noddc screen=800x600

    at this point, I put in my usb drive.. the light cam on.. now the system is running very slow.....

  6. #6
    Member registered user
    Join Date
    Feb 2004
    Posts
    72
    here's the results of a lspci -v
    in case anyone's interested.


    0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) (rev 02)
    Subsystem: Toshiba America Info Systems: Unknown device 0001
    Flags: bus master, medium devsel, latency 64
    Memory at e0000000 (32-bit, prefetchable)

    0000:00:02.0 CardBus bridge: Toshiba America Info Systems ToPIC97 (rev 05)
    Subsystem: Toshiba America Info Systems: Unknown device 0001
    Flags: bus master, slow devsel, latency 0, IRQ 255
    Memory at 10000000 (32-bit, non-prefetchable)
    Bus: primary=00, secondary=01, subordinate=04, sec-latency=0
    Memory window 0: 10400000-107ff000 (prefetchable)
    Memory window 1: 10800000-10bff000
    I/O window 0: 00004000-000040ff
    I/O window 1: 00004400-000044ff
    16-bit legacy interface ports at 0001

    0000:00:02.1 CardBus bridge: Toshiba America Info Systems ToPIC97 (rev 05)
    Subsystem: Toshiba America Info Systems: Unknown device 0001
    Flags: bus master, slow devsel, latency 0, IRQ 255
    Memory at 10001000 (32-bit, non-prefetchable)
    Bus: primary=00, secondary=05, subordinate=08, sec-latency=0
    Memory window 0: 10c00000-10fff000 (prefetchable)
    Memory window 1: 11000000-113ff000
    I/O window 0: 00004800-000048ff
    I/O window 1: 00004c00-00004cff
    16-bit legacy interface ports at 0001

    0000:00:04.0 VGA compatible controller: Chips and Technologies F65555 HiQVPro (rev c6) (prog-if 00 [VGA])
    Subsystem: Toshiba America Info Systems: Unknown device 0001
    Flags: stepping, medium devsel
    Memory at fe000000 (32-bit, non-prefetchable)

    0000:00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
    Flags: bus master, medium devsel, latency 0

    0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80 [Master])
    Flags: bus master, medium devsel, latency 64
    I/O ports at 1000 [size=16]

    0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00 [UHCI])
    Flags: bus master, medium devsel, latency 64, IRQ 11
    I/O ports at ffe0 [size=32]

    0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
    Flags: medium devsel, IRQ 9

    0000:00:0a.0 Communication controller: Toshiba America Info Systems FIR Port (rev 23)
    Subsystem: Toshiba America Info Systems: Unknown device 0001
    Flags: bus master, slow devsel, latency 64, IRQ 11
    I/O ports at ff80



    I can post a dmesg output if anyone thinks that will help.

Similar Threads

  1. Replies: 8
    Last Post: 07-25-2004, 02:32 AM
  2. Hibernation on Toshiba Satellite
    By chrisjrn in forum Laptops
    Replies: 0
    Last Post: 05-04-2004, 03:30 AM
  3. Replies: 3
    Last Post: 03-18-2004, 04:08 PM
  4. Toshiba Satellite 335CDS
    By moorer2k in forum Laptops
    Replies: 1
    Last Post: 03-17-2004, 02:53 PM
  5. Replies: 14
    Last Post: 08-08-2003, 07:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •