Results 1 to 7 of 7

Thread: Boot problem: Empty / Zero length initrd.img-2.6.5 file

  1. #1
    Junior Member registered user
    Join Date
    Apr 2004
    Location
    Buenos Aires, Argentina
    Posts
    23

    Boot problem: Empty / Zero length initrd.img-2.6.5 file

    Hello all:

    As I have not been able to get an answer to this in my previous post (maybe because it is part of a post with other problems) I'll ask again, this time by itself.

    I have a Knoppix HDD (10/05/04) install which has these three LiLO Linux boot options, besides a fourth one for W2K at sda1:

    Linux
    Linux (2.4)-1
    Linux (2.6)-2

    The first and the second options boot into kernel 2.4 albeit with an error message regarding devfs. (the reason for another separate post).

    The third option does not boot and gives the following error message:
    pnp: unable to assign resources to device 01:01.01.
    Kernel panic: VFS:unable to mount root fs on unknown block(8.33)
    From there, only a hard reset gets me out. ;-/

    I've been able to trace the problem to the existence of a zero-length initrd.img-2.6.5 file, apparently the reason why it won't boot with the 2.6.5 kernel.

    I tried a suggestion posted by FabianX, with this result:

    root@Groucho-lnx:~#

    root@Groucho-lnx:~# mkinitrd -o /boot/initrd.img-2.6.5 2.6.5
    /usr/sbin/mkinitrd: add_modules_dep_2_5: modprobe failed
    FATAL: Module sd_mod not found.

    root@Groucho-lnx:~#

    Stumped, I googled "FATAL: Module sd_mod not found." and found a few references in the Gentoo forum relating to module-init-tools-3.0.

    Quote:
    module-init-tools-3.0_pre6, 7, 8, and 9 are buggy
    SOLUTION: downgrade to pre5

    This problem is over my head at this moment, so if anyone has any ideas as to how to fix it, I'd be very grateful if they were posted.

    Thanks in advance,

    CIV

  2. #2
    Junior Member
    Join Date
    Apr 2004
    Posts
    8

    Re: Boot problem: Empty / Zero length initrd.img-2.6.5 file

    Hi,

    I even have an 0 Byte initrd-image for kernel 2.6, but it works for me. I think your error message has something to do with your scsi-disks (sda). May be your scsi-controller is not detected by your kernel 2.6 and therefore there is no access to your hard-disk.

    Are you able to boot from cd with the kernel 2.6? Then you can try to hdinstall with kernel 2.6 booted from cdrom. This is what I do everytime when I do a hdinstall. The other option is to build your own kernel out of the sources.

    Good Luck,

    AlBorland

  3. #3
    Junior Member registered user
    Join Date
    Apr 2004
    Location
    Buenos Aires, Argentina
    Posts
    23
    Hello:

    I even have an 0 Byte initrd-image for kernel 2.6, but it works for me.
    Interesting ...

    I think your error message has something to do with your scsi-disks (sda).
    Could be ...

    May be your scsi-controller is not detected by your kernel 2.6 and therefore there is no access to your hard-disk.
    That would be strange ...
    This Adaptec AHA-29139 Ultra works with the previous kernel and boots perfectly well with the CD.

    Are you able to boot from cd with the kernel 2.6?
    Yes, it works quite well.

    Then you can try to hdinstall with kernel 2.6 booted from cdrom.
    This is what I do everytime when I do a hdinstall. The other option is to build your own kernel out of the sources.
    If I recall correctly, I think that's how I installed.
    I wonder if there's a small quirk in the layout of the Knoppix CD or the install script. (Any ideas Fabian F.?)

    Thanks for the input.

    Best regards,

    CIV

  4. #4
    Junior Member
    Join Date
    Mar 2004
    Location
    Salt Lake UT
    Posts
    9
    I have the same problem. I have tried the 5/4 and 5/10 build of version 3.4 and niether will work.

    When I use the knoppix-installer it gets through the whole process and gives a fatal error at the end saying the modprobe failed and it creates the 0 length initrd.img-2.6.5 file. Now when rebooting to the hard drive I get the same problems you are. I am wondering if there is anyone out there who has installed the knoppix 3.4 with the 2.6 kernel to the harddrive and got it to work!!!!!!!

  5. #5
    Junior Member registered user
    Join Date
    Apr 2004
    Location
    Buenos Aires, Argentina
    Posts
    23
    Hello:

    Thanks for the input.

    I was beginning to wonder if this was something that was only happening to 'me and my rig', so to speak.

    I am wondering if there is anyone out there who has installed the knoppix 3.4 with the 2.6 kernel to the harddrive and got it to work!!!!!!!
    Maybe not ...
    At least 2.4 works well.

    I have just downloaded the last Knoppix (2004-05-17-EN 7ee0382655abf194aa300a98100cacde) and will probably be reinstalling the whole thing this weekend.

    Knoppix Forum News says it has these updates:

    - Kernel 2.6.6
    - Harddisk installer (Fabian Franz) update
    - Live installer (Fabian Franz) update
    - fixed knoppix-terminalserver boot-graphics
    - Removed ipw2100 support in Kernel 2.6.6 because it does not work there (gcc incompatibilities, changed Kernel api)

    Maybe whatever is not working (is it the installer?) has been fixed.

    Who knows ...
    Eventually I may just get the hang of it all ...
    Cheers,

    CIV

  6. #6
    Junior Member
    Join Date
    Mar 2004
    Location
    Salt Lake UT
    Posts
    9
    I have tried the knoppix-installer version 3.11 and still no worky. In the Knoppix 3.4 5/10 release knoppix-installer 3.6 is installed. So who knows if there is an actuall fix in the 5/17 release!

  7. #7
    Junior Member registered user
    Join Date
    Apr 2004
    Location
    Buenos Aires, Argentina
    Posts
    23
    Hello jdtommy:

    In all, I have three Knoppix 3.4 CDs.:

    04/05/2004
    10/05/2004
    and
    17/05/2004 ....

    Only the first one (first 3.4 version?) can boot into kernel 2.6 (using cheat code [knoppix26]).

    The other two (which are newer versions of the CD) will refuse to boot into kernel 2.6, ending with this error message:

    -------
    Can't find KNOPPIX filesystem, sorry.
    Dropping you to a (very limited) shell.
    Press reset button to quit.
    -------

    Whatever was changed from the first 04/05/2004 version to the other two probably has to do with the problems we are experiencing.

    I have a feeling that the problem is related to the SCSI drivers used at boot time.

    Knoppix 3.4 (04/05/2004) apparently loads aic7xxx.o, megaraid.o and a100u2w.o and is able to boot the 2.6 kernel.

    I'll put up a new post with just this item to see if we can get some insight on the matter from the maintainer of the installer.

    Cheers,

    CIV

Similar Threads

  1. i want reiserfs as boot fs? initrd? .knofig?
    By jobuli in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 04-09-2005, 01:01 PM
  2. How do Kanotix boot with initrd=noinitrd.img?
    By rrfish72 in forum General Support
    Replies: 0
    Last Post: 12-11-2004, 04:18 PM
  3. fixing initrd boot screen?
    By popcorn in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 06-06-2004, 11:08 AM
  4. What is this initrd=/boot/initrd.gz
    By alex52 in forum Hdd Install / Debian / Apt
    Replies: 4
    Last Post: 02-01-2004, 06:08 AM
  5. cannot boot: initrd extends beyond end of memory error
    By sanjay in forum General Support
    Replies: 8
    Last Post: 11-01-2003, 11:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •