Results 1 to 5 of 5

Thread: partition modif and mounting prob

  1. #1
    Member registered user
    Join Date
    Apr 2004
    Posts
    34

    partition modif and mounting prob

    hi all

    i use knoppix as my main os now on my laptop

    as i already had a win2K partition (i don't use but i don't want to delete), i have installed knoppix on a 5go partition
    then i gave more 5go

    now i feel the need to give a new partition for giving a good issue to /tmp

    then i have taken + 2go from a fat partition i had made to share linux and win

    so i have upgraded the swap from 500 mo to 1200 mo
    and i have created a new linux partition to mount it as /tmp
    --------------------------------------------------------------------
    now i have several small probs
    --------------------------------------------------------------------
    root@sony_vaio:~# df
    Sys. de fich. 1K-blocs Occupé Disponible Capacité Monté sur
    /dev/hda3 4383520 3966240 417280 91% /
    /dev/root.old 2182 851 1331 40% /initrd
    --------------------------------------------------------------------
    # /etc/fstab: filesystem table.
    #
    # filesystem mountpoint type options dump pass
    /dev/hda3 / xfs defaults 0 1
    /dev/hda9 none swap sw 0 0
    proc /proc proc defaults 0 0
    # /dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
    /dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
    /dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
    /dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
    # Added by KNOPPIX
    /dev/sda1 /mnt/sda1 vfat noauto,users,exec,rw,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda1 /mnt/hda1 ntfs noauto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda5 /mnt/hda5 ntfs noauto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda6 /mnt/hda6 ntfs noauto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda7 /mnt/hda7 ntfs noauto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    #/dev/hda8 /mnt/hda8 vfat noauto,users,exec,rw,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda10 /tmp reiserfs rw,users,exec 0 0
    # olivier disk usb
    # /dev/sda1 /mnt/sda1 ntfs noauto,users,exec,ro,umask=000 0 0

    # Added by KNOPPIX
    /dev/hda8 /mnt/hda8 vfat auto noauto,users,exec 0 0
    # Added by KNOPPIX
    /dev/hda11 /var/www reiserfs noauto,users,exec 0 0
    --------------------------------------------------------------------
    /dev/hda3 / xfs rw 0 0
    /dev/root.old /initrd ext2 rw 0 0
    none /proc proc rw 0 0
    devpts /dev/pts devpts rw,gid=5,mode=620 0 0

    "/etc/mtab" 4L, 125C
    --------------------------------------------------------------------

    so
    /dev/hda11 doesn't mount at start up (but i can do it manually)
    /dev/hda10 doesn't mount at start up (neither manually of course)

    i can't get the correct the correct syntax to write on the /dev/hda8

    as i use my laptop to work, it's not very cool

    lol

    any help is welcome

    regard

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Posts
    555
    Not too sure I see what your actual problem is, but it seems likely that since you created a new partition, some of the existing hdaN partitions have shifted to (N+1). Check carefully your fstab against the output of "fdisk -l /dev/hda"

  3. #3
    Member registered user
    Join Date
    Apr 2004
    Posts
    34

    lol

    thanks for the interest badyeti

    the list was up to hda10
    now it s up to hda11 as i have created one more partition

    as i have messed up the disk at the middle disk
    hda10 become hda11
    the new created is hda10

    but my prob is :

    - how to automount hda10 on /tmp (i need it)
    - how to automount hda11 on /var/www

    coz fstab seems not to work

    - what is the syntax for mounting the fat partition read & write
    - what is /dev/root.old /initrd ext2 rw 0 0 ==> can i delete it ?

    lol

  4. #4
    Senior Member registered user
    Join Date
    Mar 2003
    Posts
    555

    Re: lol

    - how to automount hda10 on /tmp (i need it)
    - how to automount hda11 on /var/www

    Try
    /dev/hda10 /tmp reiserfs auto,defaults 0 2
    /dev/hda11 /var/www reiserfs auto,defaults 0 2

    Assuming the FS type (reiser) is correct (you're using xfs for root...),
    and that you have created one such FS on your newly created partition...


    - what is the syntax for mounting the fat partition read & write

    Which partition do you mean? Your vfat entries look right (rw),
    and your NTFS partitions are rightfully flaged read-only...


    - what is /dev/root.old /initrd ext2 rw 0 0 ==> can i delete it ?

    Yes. I'd simply comment it out, though -
    just in case you ever want to have a look at what your mini-root contains.

  5. #5
    Member registered user
    Join Date
    Apr 2004
    Posts
    34

    lol

    lol
    after a very hard batttle, god is great

    the reiserfsk found a prob on hda10 (superblock)
    after some mess up on the partition table (i have a win installed at the hd begin and knoppix at the end so i can mess up the disk at the middle)

    now all is mounted fine
    #########################################
    # /etc/fstab: filesystem table.
    #
    # filesystem mountpoint type options dump pass
    /dev/hda3 / xfs defaults 0 1
    /dev/hda9 none swap sw 0 0
    proc /proc proc defaults 0 0
    # /dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
    /dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
    /dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
    /dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
    # Added by KNOPPIX
    /dev/sda1 /mnt/sda1 vfat noauto,users,exec,rw,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda1 /mnt/hda1 ntfs noauto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda5 /mnt/hda5 ntfs noauto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda6 /mnt/hda6 ntfs noauto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda7 /mnt/hda7 ntfs noauto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda8 /tmp reiserfs auto,users,defaults 0 2
    # Added by KNOPPIX
    /dev/hda10 /mnt/hda10 vfat auto,users,exec,rw,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda11 /var/www reiserfs auto,users,defaults 0 2
    #######################################
    but as i have made the modif under root user, i can't open xsession under knoppix user

    lol

Similar Threads

  1. mounting writable fat32 partition at startup
    By laughingboy in forum General Support
    Replies: 2
    Last Post: 05-13-2005, 02:08 AM
  2. Mounting a Raided NTFS Partition.
    By sd5867 in forum MS Windows & New to Linux
    Replies: 4
    Last Post: 04-13-2005, 07:33 AM
  3. Mounting Debian Partition Error
    By downdogWoof in forum General Support
    Replies: 1
    Last Post: 02-24-2005, 03:01 PM
  4. mounting windows partition problem
    By pcorajr in forum General Support
    Replies: 4
    Last Post: 04-12-2004, 07:42 PM
  5. partition not mounting....
    By Arishon in forum Hardware & Booting
    Replies: 1
    Last Post: 12-19-2003, 05:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •