Page 12 of 71 FirstFirst ... 210111213142262 ... LastLast
Results 111 to 120 of 708

Thread: ISO boot from FAT/NTFS/USB (GRUB.exe, grldr from boot.ini)

  1. #111
    Moderator Moderator
    Join Date
    Mar 2004
    Location
    Menlo Park, California
    Posts
    668
    Quote Originally Posted by wslkevin
    ... What is the driver within the ramdisk? How can I verify that the drivers are compatible with my ISO file? If they are not compatible, how can I make it compatible? ...
    Here are the links to the gzipped tar (tgz) of the content of the ramdisks I am using at boot time:
    http://s94592085.onlinehome.us/grub/minirt24_ntfs.tgz
    http://s94592085.onlinehome.us/grub/minirt26_ntfs.tgz
    And hopefully you will verify that the /modules files from these tgz match the ones you have in your system after having booted from your ISO file. You can do that by comparing their md5 or just by looking at the file length and date. If the drivers are different you may need to make your own boot ramdisk ... What distribution or ISO file are you using ?
    Good luck, Gilles

  2. #112
    Junior Member registered user
    Join Date
    Sep 2004
    Posts
    29
    Quote Originally Posted by ruymbeke
    Quote Originally Posted by wslkevin
    ... What is the driver within the ramdisk? How can I verify that the drivers are compatible with my ISO file? If they are not compatible, how can I make it compatible? ...
    Here are the links to the gzipped tar (tgz) of the content of the ramdisks I am using at boot time:
    http://s94592085.onlinehome.us/grub/minirt24_ntfs.tgz
    http://s94592085.onlinehome.us/grub/minirt26_ntfs.tgz
    And hopefully you will verify that the /modules files from these tgz match the ones you have in your system after having booted from your ISO file. You can do that by comparing their md5 or just by looking at the file length and date. If the drivers are different you may need to make your own boot ramdisk ... What distribution or ISO file are you using ?
    Good luck, Gilles
    I am using KNOPPIX34pureKDE20040720m3.iso which is downloaded from ftp://ftp3.tnc.edu.tw/KNOPPIX/health, and it's a Traditional Chinese version of KNOPPIX.

    After I boot it up using CD-Rom, I foudn that there are two folders name 2.4.27 and 2.6.5 under /lib/modules. I am already using the files you provided.

    Could you specify which two folder should I compare to each other?

    I tried three config in menu.lst

    ###
    ### The kernel file linux24 and ramdisk (minirt24_ntfs.gz) are from ruymbeke, it can't boot up KNOPPIX K2, and said "Inconsistent Filesystem Structure" when running the line "kernel ..."
    ###
    title KNOPPIX pureKDE (ISO)(kernel 2.4.26, Tranditional Chinese,normal, pureKDE, short)
    root (hd0,0)
    kernel /knoppix/linux24 bootfrom=/dev/hda1/KNOPPIX*.iso knoppix_name=KNOPPIX ramdisk_size=100000 init=/etc/init ro lang=tw vga=791 noprompt noapm lcd ttf2ram
    initrd /knoppix/minirt24_ntfs.gz

    ###
    ### The kernel linux26 and ramdisk miniroot_ntfs.gz is from the Japanese one, it can boot up KNOPPIX K2, but said "can't find the file /lib/modules/2.6.7/modules.dep", and some devices, i.e. NIC, doesn't work
    ###
    title KNOPPIX pureKDE (ISO)(kernel 2.6.7, Tranditional Chinese,normal, pureKDE, short)
    root (hd0,0)
    kernel /knoppix/linux26 bootfrom=/dev/hda1/KNOPPIX*.iso knoppix_name=KNOPPIX ramdisk_size=100000 init=/etc/init ro lang=tw vga=791 noprompt noapm lcd ttf2ram
    initrd /knoppix/miniroot_ntfs.gz

    ###
    ### The kernel file linux265 is from the CD of KNOPPIX K2, and I rename it to linux265, and the ramdisk miniroot_ntfs.gz is from Japanese one , it can't boot up KNOPPIX K2, and said "Inconsistent Filesystem Structure" when running the line "kernel ..."
    ###
    title KNOPPIX pureKDE (ISO)(kernel 2.6.5, Tranditional Chinese,normal, pureKDE, short)
    root (hd0,0)
    kernel /knoppix/linux265 bootfrom=/dev/hda1/KNOPPIX*.iso knoppix_name=KNOPPIX ramdisk_size=100000 init=/etc/init ro lang=tw vga=791 noprompt noapm lcd ttf2ram
    initrd /knoppix/miniroot_ntfs.gz

    Thank you very much in advance.

  3. #113
    Junior Member registered user
    Join Date
    Sep 2004
    Posts
    13
    ruymbeke - thank you *VERY* much for the work you have put in on this. I am posting from a laptop I've just booted from a USB flash disk with the ISO on an NTFS partition - no CD required in the drive. This is what I wanted. I need to hone some of the boot 'cheatcodes' and create a permanent home on the second partition of the flash disk - but it looks to be mostly there.

    Many, many thanks again. I echo the request to make this part of Knoppix' standard functionality.

    Regards,

    semreh

  4. #114
    Moderator Moderator
    Join Date
    Mar 2004
    Location
    Menlo Park, California
    Posts
    668
    Quote Originally Posted by j.drake
    Just wanted to suggest appending the cheatcode "noprompt" in the GRUB stanzas. At shutdown or restart, Knoppix won't prompt you to remove the CD and push Enter, Given that this method doesn't use a CD, it seemed appropriate, and saves a little time and annoyance.jd
    Done in http://s94592085.onlinehome.us/grub/grub9.zip
    Quote Originally Posted by wslkevin
    ... I am using KNOPPIX34pureKDE20040720m3.iso ...
    Just by looking at the filename, is this file a knoppix 3.4 flavor ?
    The files I provided are for knoppix 3.6 and are not compatible with 3.4.
    You may try the miniroot_ntfs.gz of the japanese 3.4 release...
    Cheers, Gilles

  5. #115
    Senior Member registered user
    Join Date
    Jul 2004
    Posts
    143

    Trying this method with Windows 98

    I have been using the approach outlined in this thread to boot Knoppix 3.6 from My Windows 98 PC which has a FAT 32 partition. My menu.1st, based on what Eco2Geek suggested on Page 8 is as follows:

    title Knoppix 3.6 kernel 2.4 from FAT32 hda1 cloop scan
    kernel (hd0,0)/boot/knoppix.36/linux24 ramdisk_size=100000 knoppix_dir=/boot/knoppix.36 knoppix_name=KNOPPIX init=/etc/init lang=uk nomce
    initrd (hd0,0)/boot/knoppix.36/minirt24_ntfs.gz


    title Memory test
    kernel (hd0,0)/boot/knoppix.36/memtest

    I have got it to work but there are two problems.

    First - As Knoppix boots up it still looks to the CDROM for the cloop file before eventually giving up and then, after appearing to search every device imaginable, starts off from where I put it in \boot\knoppix.36 directory. Is there any way to stop it searching for the CD-ROM and start the boot instantly from \boot\knoppix.36?

    The second problem is that I have to use a floppy formatted as a system disk with Windows 98 and a simple autoexec.bat file which says:

    c:
    cd \
    grub

    This is OK, but I would much prefer to have it boot up from the hard drive, like has been done with the NTFS system. Ruymbeke suggested 3 approaches; start grub from the command prompt, the autoexec.bat or config.sys with device=grub.exe.

    From the command prompt I got the message:

    Must run in real mode or ring 0 of protected mode. Cannot run in vm86 mode.

    I guessed this meant that starting Windows 98 put things into the wrong mode so decided to modify my config.sys to give a menu system as follows:

    [menu]
    menuitem=WINDOWS, Start Windows
    menuitem=KNOPPIX, Start Knoppix
    menudefault=WINDOWS,30
    menucolor=7,0

    [KNOPPIX]
    device=grub.exe

    [WINDOWS]
    device=c:\realmode\oakcdrom.sys /D:mscd001
    dos=high,umb
    buffers=40
    DEVICE=C:\WINDOWS\EMM386.EXE
    device=c:\windows\himem.sys /testmemff
    device=c:\windows\COMMAND\display.sys con=(ega,,1)
    Country=044,850,c:\windows\COMMAND\country.sys

    I figured this would boot Knoppix before Windows took hold.

    When I rebooted and chose Knoppix I still got the same error message and then a break into what looked like a short memory dump. Does anybody have any idea what I am doing wrong?

    ICPUG

  6. #116
    Moderator Moderator
    Join Date
    Mar 2004
    Location
    Menlo Park, California
    Posts
    668

    Re: Trying this method with Windows 98

    Quote Originally Posted by ICPUG
    ... Is there any way to stop it searching for the CD-ROM and start the boot instantly from \boot\knoppix.36 ?
    If you use the bootfrom= cheatcode it should not search for the cdrom, but as far as i know, it will still look for all the disk/devices

    Quote Originally Posted by ICPUG
    ... The second problem is that I have to use a floppy formatted as a system disk with Windows 98 and a simple autoexec.bat file ... This is OK, but I would much prefer to have it boot up from the hard drive, like has been done with the NTFS system. Ruymbeke suggested 3 approaches; start grub from the command prompt, the autoexec.bat or config.sys with device=grub.exe.
    You do not need to have a boot floppy, you can do it all from the HD. I have it working on my 98 machine. If during the 98 boot you press shift-F5 and force the boot into a prompt, just type grub.exe. You can also add a menu into the config.sys as you have done and start grub from the autoexec.bat using the %config% environment variable to recognize the linux boot selection and then run c:\your_path\grub.exe. But be sure to not have emm386.exe loaded (that would explain your error message) and not run it from a 98 dos box ! You can verify that from the prompt by typing mem/c/p. Hope this will help, Gilles

    PS: it looks like that the minirtxx_ntfs.tgz are also working with knoppix 3.7...

  7. #117
    Junior Member
    Join Date
    Oct 2004
    Posts
    2
    improbably missing something obvious but...I can't get this to work! (and I want to :P)

    ok, so I've wanted for a little while to get Knoppix running off of the HD, and I found this handy article: http://www.knoppix.net/docs/index.php/WinPartition. I've followed that to the letter, and when I reboot, I get the option between the two OSes, and I select the GRUB. however, all it does is flash the little _ cursor at me and does nothing.

    I'm not quite sure what I'm doing wrong, as I've tried multiple times (with multiple formats! -_-

    I'm running Win2k Pro NTFS (obviously), and I modified the boot.ini accordingly, since it was set to WinXPpro.

    my boot.ini contains :

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microso ft Windows 2000 Professional" /fastdetect
    c:\grldr="Start Grub"

    and my menu.lst contains:

    ################################################## ####
    # GvR Sept 24th 2004
    color black/cyan yellow/cyan
    timeout=15
    default=0

    title Default Boot on HD 0
    rootnoverify (hd0,0)
    chainloader +1
    boot

    # Knoppix Boot from a single NTFS partition hda1:
    # All the files within the directory "Root_Of_NTFS" of the grub7.zip
    # have to be copied into the root of the NTFS hda1 partition c:\
    # but the boot.ini file (which is just here as an example,
    # the line "c:\grldr="Start Grub" has been added at the end of the boot.ini)
    # Copy the also the 700MB knoppix ISO file into c:\boot\knoppix.36\ directory

    title Knoppix 3.6 kernel 2.6 from NTFS hda1 ISO scan ramdisk=32MB
    kernel (hd0,0)/boot/knoppix.36/linux26 ramdisk_size=100000 init=/etc/init lang=us apm=power-off vga=791 nomce quiet bootfrom=/dev/hda1/boot/knoppix.36/knoppix.iso config=scan home=scan ramdisk=32768
    initrd (hd0,0)/boot/knoppix.36/minirt26_ntfs.gz
    boot

    title Knoppix 3.6 kernel 2.4 from NTFS hda1 ISO scan ramdisk=32MB
    kernel (hd0,0)/boot/knoppix.36/linux24 ramdisk_size=100000 init=/etc/init lang=us apm=power-off vga=791 nomce quiet bootfrom=/dev/hda1/boot/knoppix.36/knoppix.iso config=scan home=scan ramdisk=32768
    initrd (hd0,0)/boot/knoppix.36/minirt24_ntfs.gz
    boot

    title Memory test
    kernel (hd0,0)/boot/knoppix.36/memtest

    title Win311 from Dos from Floppy image 1.44Mb, just for fun...
    kernel (hd0,0)/boot/memdisk
    initrd (hd0,0)/boot/win311.img
    boot

    ################################################## ####

    title Knoppix 3.6 kernel 2.6 from NTFS hda1 ISO scan (original japanese miniroot_ntfs.gz)
    kernel (hd0,0)/boot/knoppix.36/linux26 ramdisk_size=100000 init=/etc/init lang=us apm=power-off vga=791 nomce quiet bootfrom=/dev/hda1/boot/knoppix.36/knoppix.iso config=scan home=scan
    initrd (hd0,0)/boot/knoppix.36/miniroot_ntfs.gz
    boot

    ################################################## ####



    thanks in advance for any help! If you need more info, plz ask
    I'm gonna keep working on it some more :P

    -PyroFox

  8. #118
    Moderator Moderator
    Join Date
    Mar 2004
    Location
    Menlo Park, California
    Posts
    668
    Quote Originally Posted by PyroFox
    ... when I reboot, I get the option between the two OSes, and I select the GRUB. however, all it does is flash the little _ cursor at me and does nothing... I'm running Win2k Pro NTFS (obviously), and I modified the boot.ini accordingly, since it was set to WinXPpro...
    You may want to try to add an other line in your boot.ini as follow:
    c:\bootgrub="Start Grub (old method)" (after c:\grldr="Start Grub")
    and copy the file c:\bootgrub from the GRUB.BIN directory of grub9.zip.
    Let me know, cheers, Gilles

  9. #119
    Junior Member
    Join Date
    Oct 2004
    Posts
    2
    yup, that did the trick!

    I guess an old computer needs a old method to work....

    thanks you very much for your help. excellent work too :P

    -PyroFox

  10. #120
    Senior Member registered user
    Join Date
    Jul 2004
    Posts
    143
    I have today been playing with this PMI on a friend's Windows XP machine. This is the first time I have had the chance to try the procedure on an XP machine.

    I have a major problem with it!

    Ruymbeke stated, and J. Drake put in the procedure, that you modify the boot.ini to add the line:

    C:\bootgrub="Knoppix Submenu"

    I did not see how this would start grldr but did as instructed.

    The result was to come up with an error message saying Windows was missing a dll (whose name I did not note), and then start Windows.

    I then followed my own lead and used the following as the last line of the boot.ini:

    C:\grldr="Knoppix Submenu"

    This seemed to work and display the Knoppix Submenu defined by menu.1st.

    Could someone explain how C:\bootgrub is supposed to call up grldr? There is no file or directory called bootgrub??? Alternatively, if I got it right with my last line the instructions need changing.

    <Seeing the reply to Pyrofox after I prepared this post, maybe you missed the bootgrub file from grub8.zip which I am using??>

    I am still having problems using bootfrom be it on my friend's machine or my own Windows 98.

    Please bear in mind I am trying to boot the cloop file NOT an iso.

    Can it be done on Windows XP at all? If so - what is the menu.1st to use?

    Can it be done on Windows 98, without a delay while it searches unsuccessfully the CD-ROM drive. If so, what is the menu.1st to use?

    ICPUG

Page 12 of 71 FirstFirst ... 210111213142262 ... LastLast

Similar Threads

  1. Boot Knoppix 3.3 from HDD using Grub for NTFS
    By sandricionut in forum Hardware & Booting
    Replies: 2
    Last Post: 08-11-2005, 03:28 PM
  2. grub boot loader read the boot file from a windows partition
    By cli168 in forum Hdd Install / Debian / Apt
    Replies: 3
    Last Post: 06-20-2005, 03:57 AM
  3. Hdd-install and grub boot??
    By Ish Rattan in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 06-25-2004, 10:31 PM
  4. Grub/lilo boot problems
    By madape in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 02-03-2004, 10:07 AM
  5. Boot cd with lilo or grub boot disk
    By keava in forum General Support
    Replies: 3
    Last Post: 10-20-2003, 05:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •