Page 62 of 71 FirstFirst ... 12526061626364 ... LastLast
Results 611 to 620 of 708

Thread: ISO boot from FAT/NTFS/USB (GRUB.exe, grldr from boot.ini)

  1. #611
    Junior Member registered user
    Join Date
    Oct 2007
    Posts
    29
    Hello PlayWithKnoppix,

    I tried changing my exports to (async,ro) from (ro,no_root_squash,async) but I still get the "rpcbind" error.
    I am not sure why yours worked after a delay, did you also have a knoppix CD in the drive as well?

    Still stuck really do need help.

    Regards,

    Will

  2. #612
    Member registered user
    Join Date
    Feb 2008
    Posts
    31

    how to employ ruymbeke knx620l.zip

    Quote Originally Posted by ruymbeke View Post
    Hello,
    Please find below an update for the Koppix 6.2.0 ISO boot including an option for the large memory kernel (>4GB)
    http://s94002264.onlinehome.us/grub/knx620l.zip
    Thanks for providing this tool. To save having to read all 62 pages of this thread, can you cite instructions for how to install or use the contents of the zipfile? Also, I would be grateful for a pointer to the corresponding file for Knoppix 5.3.1.
    Last edited by carolus; 04-07-2010 at 05:54 PM.

  3. #613
    Junior Member registered user
    Join Date
    Oct 2007
    Posts
    29

    Cannot Pxe load knoppix 6.2.1 from nfs share.rpcbind: server localhost not responding

    Hello,

    I am hoping this may be a clue. I found that from a knoppix V6.2.1. booted PC I could not access my NFS shares but I could from the same PC but booted from my knoppix V5.3.1. build. I would get a
    Code:
    mount.nfs: operation not permitted
    After some googling I found I needed to add "ver=3" to my script:
    Code:
    mount.nfs 192.168.xxx.xxx:/nfsroot /nfs1 -o 'vers=3' -o nolock
    If the files generated by the knoppix Terminal services & thus ruymbeke files as well, use the same approach then this would explain my problem. Although what the resolution is remains, got to identify a problem first to fix it. Either I need to look at the configuration of my nfs share or minirt.gz requires modification.

    Ruymbeke would you be prepared and do you have time to give some thought to this?
    Any help would be much appreciated ( or I should say any further help would be much appreciated ).

    Regards,

    Will

  4. #614
    Junior Member registered user
    Join Date
    Oct 2007
    Posts
    29

    pxe Knoppix 6.2.1 from nfs share - Now working & Bigmem

    Hello,

    Here is a quick update.

    Built a new debian server based on 504-i386 to replace the sme server and now I can PXE from a nfs share.

    In line with V5.3.1 I could not PXE my laptop which has a Broadcom 4401 nic, using b44.ko.
    By strace insmod b44.ko & trial and error I found that adding ssb.ko and pcmcia.ko to /modules in the expanded minirt.gz file ( and re-compressing of course etc) fixed it.
    It appears b44.ko is dependent on ssb.ko, which in turn is dependent on pcmcia.ko. Although the pcmcia.ko surprised me it is definitly working and I have now used the technique to pxe from V5.3.1. as well.

    Could anyone perhaps help with a better dependency check than the one I have used?

    ruymbeke, if you agree with my findings would you be prepared to add them to your customised minirt.gz files? Plus, I have the bigmem version working as well now, so a BIG thankyou to ruymbeke.

    Finally, I now find that machines using a bnx2.ko freeze on v6.2.1. Again they work fine on V5.3.1 and again this is on PXE only. From cd both versions work fine. I have the firmware files in my build. How does this work if there are no firmware files in the minirt.gz? Does anyone have any ideas on this?
    It locks up here:
    Code:
    Probing network device(s) handled by bnx2.ko
    I tried adding a intel nic adapter & pxe'd from that but it still locked up at the bnx2.ko stage. The broadcom is on board & cannot be disabled.

    Regards,

    Will

  5. #615
    Senior Member registered user
    Join Date
    Sep 2006
    Posts
    148

    While I was away...

    The forums have changed. Links are broken now. Gilles, your VMWare links that point here are running into a "not found" error here, as well as, the links you have managed at the first post of this thread.

    What genius decided to improve the forums?
    What a Great Improvement!

    Well, I decided to toy around with VMware, and since I could not find the vmware tools for linux guests, I thought I'd look over at VMware.com for one of your Virtual appliances featuring Knoppix 5.3.1.


    Well I do have one working... but without the tools for linux guests.... it sucks.
    Gilles... I am running vmware player 3.1 on XP host. Do you know where I can get the tools for linux? Even downloaded Workstation and it didn't seem to have any iso's in it... just a 300+ MB script... that after I ran, didn't have any iso's in /var Or your knoppix 5.3.1 appliance would be great too.

    Best,
    johnrw

  6. #616
    Senior Member registered user
    Join Date
    Sep 2006
    Posts
    148
    This worked.
    # ./VMware-Workstation-Full-7.1.0-261024.i386.bundle --help
    {...}
    # ./VMware-Workstation-Full-7.1.0-261024.i386.bundle --extract=/media/sda1/vmware

    produced the needed linux.iso file under /media/sda1/vmware/vmware-tools-linux/

    Gilles, I'd still like to get my hands on your already made vmware appliance for knoppix 5.3.1. I'll promise to review it even...

  7. #617
    Senior Member registered user
    Join Date
    Jul 2004
    Posts
    142
    In the news section some time ago Ruymbeke investigated the version 6.3 DVD and deemed that the minirt_621c would work with it.

    I have finally got my laptop to work with this Knoppix version and found I could not get it to work with minirt_621c. I never actually tried Knoppix 6.2.1 so that may not have worked either. The last working Poor man's Install I had was 6.2.0.

    With 6.3 I, initially, could not get the live CD to boot. Goes into a black screen of death when X is started. I have now found that this is due to Kernel Mode Setting in the latest kernels and the fact my laptop uses an 855 Intel Graphics chip. It happens with the latest Ubuntu and Puppy as well. The solution is fairly straightforward - add a cheatcode:

    i915.modeset=1

    If you like your terminal to be a standard VGA the use of the following cheatcode is also recommended:

    video=640x480

    This was all fine and dandy when using the Knoppix 6.3 Live DVD. However, when using a Poor Man's Install with minirt_621c.gz and adding the cheatcodes to the kernel line of my menu.lst I still get the black screen of death.

    Ruymbeke - Can you think of a reason and a possible solution as to why this is happening? All my other cheatcodes seem to be working OK.
    Last edited by ICPUG; 07-19-2010 at 06:01 PM.

  8. #618
    Moderator Moderator
    Join Date
    Mar 2004
    Location
    Menlo Park, California
    Posts
    668
    Hello John and ICPUG,
    Sorry for the long delay in my response, I have been swamped at work...
    Please find below a couple links to my latest 531 and 630 Knoppix vm and
    the minirt + grub I use for Knoppix 630 (which also work for Knoppix 621)
    http://s94002264.onlinehome.us/grub/vmk531_203739.zip
    http://s94002264.onlinehome.us/grub/vmk630_261024.zip
    http://s94002264.onlinehome.us/grub/knx630a.zip
    Hope this helps,
    Gilles

    PS: One the few hours of spare time I have, I am trying to put together a 64 bit kernel and initrd for a dual boot config
    still using the official Knoppix DVD (as of today the kernel boots up but the init script still hang probably because of
    trying to load some 32bits libraries) So there is still quite some more work to be done there...

    PS2: I also need some time to contact /respond to Clinton and find a way to restore a snapshot of the old forum
    and publish it as as read only, so we can at least recover the broken links and progressively move to the new forum.
    As you can see, there not much activity on the forum since the upgrade because it is almost useless with broken links
    (at least for me...)

  9. #619
    Senior Member registered user
    Join Date
    Jul 2004
    Posts
    142
    The minirt in knx630a.zip is the same as that for Knoppix 6.2.1 that I have already tried and found not to work.

    I guess the answer to my original question is that you don't know why this should fail when the cheatcode i915.modeset=1 is required.

  10. #620
    Moderator Moderator
    Join Date
    Mar 2004
    Location
    Menlo Park, California
    Posts
    668
    ICPUG,
    Correct. It works on all the systems I have tried so far and I do not have your setup.
    Did you try both boot modes (default Knoppix official and extended memory model + Core2) ?
    Best Regards,
    Gilles

Page 62 of 71 FirstFirst ... 12526061626364 ... LastLast

Similar Threads

  1. Boot Knoppix 3.3 from HDD using Grub for NTFS
    By sandricionut in forum Hardware & Booting
    Replies: 2
    Last Post: 08-11-2005, 03:28 PM
  2. grub boot loader read the boot file from a windows partition
    By cli168 in forum Hdd Install / Debian / Apt
    Replies: 3
    Last Post: 06-20-2005, 03:57 AM
  3. Hdd-install and grub boot??
    By Ish Rattan in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 06-25-2004, 10:31 PM
  4. Grub/lilo boot problems
    By madape in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 02-03-2004, 10:07 AM
  5. Boot cd with lilo or grub boot disk
    By keava in forum General Support
    Replies: 3
    Last Post: 10-20-2003, 05:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •