Results 1 to 10 of 10

Thread: dpkg-deb: subprocess paste killed by signal (Broken pipe)

  1. #1
    Member registered user
    Join Date
    Dec 2002
    Location
    The Hague, The Netherlands
    Posts
    93

    dpkg-deb: subprocess paste killed by signal (Broken pipe)

    I am getting the following error message:

    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Errors were encountered while processing:
    /var/cache/apt/archives/libsm6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxi6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxv1_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxt6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxmu6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxmuu1_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxp6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxpm4_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxrandr2_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxtrap6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxtst6_4.3.0.dfsg.1-4_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  2. #2
    Senior Member registered user
    Join Date
    Mar 2004
    Posts
    900
    Are you out of disc space?

    df -h

    If you still have room left try this:

    apt-get -f install

  3. #3
    Member registered user
    Join Date
    Dec 2002
    Location
    The Hague, The Netherlands
    Posts
    93
    Filesystem Size Used Avail Use% Mounted on
    /dev/hda1 36G 2.3G 32G 7% /
    /dev/root.old 2.2M 341K 1.8M 16% /initrd

    Already tried apt-get -f install

    Thanks.

  4. #4
    Member registered user
    Join Date
    Dec 2002
    Location
    The Hague, The Netherlands
    Posts
    93
    This is the result of an apt-get -f install:

    root@reno:/home/caro# apt-get -f install
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    libsm6 libx11-6 libxext6 libxi6 libxmu6 libxmuu1 libxp6 libxpm4 libxrandr2
    libxt6 libxtrap6 libxtst6 libxv1
    The following NEW packages will be installed:
    libsm6 libx11-6 libxext6 libxi6 libxmu6 libxmuu1 libxp6 libxpm4 libxrandr2
    libxt6 libxtrap6 libxtst6 libxv1
    0 upgraded, 13 newly installed, 0 to remove and 813 not upgraded.
    17 not fully installed or removed.
    Need to get 0B/2639kB of archives.
    After unpacking 5571kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    (Reading database ... 114040 files and directories currently installed.)
    Unpacking libsm6 (from .../libsm6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libsm6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libSM.so.6.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libx11-6 (from .../libx11-6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxext6 (from .../libxext6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXext.so.6.4', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxi6 (from .../libxi6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxi6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXi.so.6.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxv1 (from .../libxv1_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxv1_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXv.so.1.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxt6 (from .../libxt6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxt6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXt.so.6.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxmu6 (from .../libxmu6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxmu6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXmu.so.6.2', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxmuu1 (from .../libxmuu1_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxmuu1_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXmuu.so.1.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxp6 (from .../libxp6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxp6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXp.so.6.2', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxpm4 (from .../libxpm4_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxpm4_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXpm.so.4.11', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxrandr2 (from .../libxrandr2_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxrandr2_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXrandr.so.2.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxtrap6 (from .../libxtrap6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxtrap6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXTrap.so.6.4', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxtst6 (from .../libxtst6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxtst6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXtst.so.6.1', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Errors were encountered while processing:
    /var/cache/apt/archives/libsm6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxi6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxv1_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxt6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxmu6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxmuu1_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxp6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxpm4_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxrandr2_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxtrap6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxtst6_4.3.0.dfsg.1-4_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  5. #5
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479
    Quote Originally Posted by FelixDzerzhinsky
    This is the result of an apt-get -f install:

    root@reno:/home/caro# apt-get -f install
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    libsm6 libx11-6 libxext6 libxi6 libxmu6 libxmuu1 libxp6 libxpm4 libxrandr2
    libxt6 libxtrap6 libxtst6 libxv1
    The following NEW packages will be installed:
    libsm6 libx11-6 libxext6 libxi6 libxmu6 libxmuu1 libxp6 libxpm4 libxrandr2
    libxt6 libxtrap6 libxtst6 libxv1
    0 upgraded, 13 newly installed, 0 to remove and 813 not upgraded.
    17 not fully installed or removed.
    Need to get 0B/2639kB of archives.
    After unpacking 5571kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    (Reading database ... 114040 files and directories currently installed.)
    Unpacking libsm6 (from .../libsm6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libsm6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libSM.so.6.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libx11-6 (from .../libx11-6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxext6 (from .../libxext6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXext.so.6.4', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxi6 (from .../libxi6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxi6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXi.so.6.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxv1 (from .../libxv1_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxv1_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXv.so.1.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxt6 (from .../libxt6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxt6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXt.so.6.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxmu6 (from .../libxmu6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxmu6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXmu.so.6.2', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxmuu1 (from .../libxmuu1_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxmuu1_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXmuu.so.1.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxp6 (from .../libxp6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxp6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXp.so.6.2', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxpm4 (from .../libxpm4_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxpm4_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXpm.so.4.11', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxrandr2 (from .../libxrandr2_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxrandr2_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXrandr.so.2.0', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxtrap6 (from .../libxtrap6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxtrap6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXTrap.so.6.4', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Unpacking libxtst6 (from .../libxtst6_4.3.0.dfsg.1-4_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libxtst6_4.3.0.dfsg.1-4_i386.deb (--unpack):
    trying to overwrite `/usr/X11R6/lib/libXtst.so.6.1', which is also in package xlibs
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Errors were encountered while processing:
    /var/cache/apt/archives/libsm6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxi6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxv1_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxt6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxmu6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxmuu1_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxp6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxpm4_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxrandr2_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxtrap6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxtst6_4.3.0.dfsg.1-4_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Use cd /var/cache/apt/archives then dpkg -i --force-overwrite libsm6_4.3.0.dfsg.1-4_i386.deb libx11-6_4.3.0.dfsg.1-4_i386.deb libxext6_4.3.0.dfsg.1-4_i386.deb ... with every package listed at the bottom of the output above on the line then dpkg --configure -a to configure all the packages that were missed when the error occurred.

  6. #6
    Member registered user
    Join Date
    Dec 2002
    Location
    The Hague, The Netherlands
    Posts
    93
    I may have found a solution:

    dpkg -i --force-overwrite /var/cache/apt/archives/libxmuu1_4.3.0.dfsg.1-4_i386.deb

    and so on for all of:

    /var/cache/apt/archives/libsm6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxi6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxv1_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxt6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxmu6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxmuu1_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxp6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxpm4_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxrandr2_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxtrap6_4.3.0.dfsg.1-4_i386.deb
    /var/cache/apt/archives/libxtst6_4.3.0.dfsg.1-4_i386.deb

    If that doesn't work I'll try Stephen's solution.

  7. #7
    Member registered user
    Join Date
    Dec 2002
    Location
    The Hague, The Netherlands
    Posts
    93
    My method worked. But thanks Stephen and the others. Apt-get is working normally now.

    I did have one problem. When I restarted later that day after the upgrade ypbind was stuck on. There is a separate Message for that in the forum.

    The KDM would not log me or my girlfreind on our user accounts as default. It just kept bouncing back to the kdm login screen. If this happens to you try clicking on kde3 or (your favourite window manager. That worked for us.

  8. #8
    Senior Member registered user
    Join Date
    Mar 2004
    Posts
    900
    Quote Originally Posted by FelixDzerzhinsky
    My method worked. But thanks Stephen and the others. Apt-get is working normally now.
    Your method was the same as Stephens. It is a very common use of apt.

  9. #9
    Member registered user
    Join Date
    Dec 2002
    Location
    The Hague, The Netherlands
    Posts
    93
    So it was. I need glasses!

  10. #10
    Senior Member registered user
    Join Date
    Mar 2004
    Posts
    900
    Quote Originally Posted by FelixDzerzhinsky
    So it was. I need glasses!
    You and me both.

Similar Threads

  1. apt-get / dpkg error: unable to access dpkg status area
    By Nitromethane1261 in forum General Support
    Replies: 2
    Last Post: 09-15-2004, 01:09 AM
  2. dpkg-deb: subprocess paste killed by signal (Broken pipe)
    By FelixDzerzhinsky in forum Networking
    Replies: 0
    Last Post: 07-08-2004, 02:06 PM
  3. Removing broken packages in dselect/dpkg
    By leecming in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 06-29-2004, 07:42 AM
  4. broken pipe with alsa-utils
    By fingers99 in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 01-17-2004, 03:05 AM
  5. apt-get/dpkg broken, will not install programs, dead-locked
    By lavaman094 in forum Hdd Install / Debian / Apt
    Replies: 14
    Last Post: 09-13-2003, 01:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
DELL POWEREDGE 1600SC SERVER TOWER DUAL XEON 3.06GHz 2x146GB RAID 1
$268.0
DELL POWEREDGE 1600SC SERVER TOWER DUAL XEON 3.06GHz 2x146GB RAID 1   picturePCI SATA eSATA 4CH 4 PORT CONTROLLER NON RAID CARD WORK WINDOWS 7 32/64 / LINUX
$27.0
PCI SATA eSATA 4CH 4 PORT CONTROLLER NON RAID CARD WORK WINDOWS 7 32/64 / LINUX pictureAdaptec 2405 4 PORT SATA/SAS RAID CARD
$60.0
Adaptec 2405 4 PORT SATA/SAS RAID CARD pictureAdaptec 6445 8-Port SAS RAID Card
$85.97
Adaptec 6445 8-Port SAS RAID Card pictureGigaRAID IT8212 REV A PCI / 2 x IDE EXPANSION ATA 133 WITH RAID SUPPORT CARD
$26.01
GigaRAID IT8212 REV A PCI / 2 x IDE EXPANSION ATA 133 WITH RAID SUPPORT CARD picture