Results 1 to 5 of 5

Thread: poor mans install won't boot (fromhd broken?)

  1. #1
    Junior Member
    Join Date
    Jul 2004
    Posts
    2

    poor mans install won't boot (fromhd broken?)

    Hello all,

    I've been messing around with knoppix for a while now, where I use it on this little computer I irc from.. I used knoppix because it was complete, handy and this machine didn't have an HD.

    Well, I have a small HD for this computer now, but its not really big enough to put much on -- certainly not as much as knoppix has! (1.2 gig). So I figure the poor mans install is perfect -- I get better speed, and keep knoppix's great selection of stuff.

    tohd worked and booted fine... it ran off the HD without a hitch... but now I won't boot from it using fromhd! I have a persistant home directory as an image (home=/dev/hda1), configuration stuff (myconf=/dev/hda1) .. but fromhd=/dev/hda1 doesn't find the cd. I went and pointed it to the actual iso (?) with "fromhd=/dev/hda1/KNOPPIX/KNOPPIX" or "fromhd=/dev/hda1/KNOPPIX" it all says the same error message:

    Code:
    Can't find KNOPPIX filesystem, sorry.
    Dropping you to a (very limited) shell.
    Press reset button to quit.
    They aren't kidding about very limited, incidently, its 100% useless. It doesn't even have ls.

    Anyway, anyone know why knoppix can't find the image it made?

    This is all with 3.4, 2004-05-17

    --SD

  2. #2
    Senior Member registered user
    Join Date
    Jul 2004
    Posts
    142

    Poor Mans Install Won't Boot

    You don't say what file system you are using.

    I had exactly this problem from a Windows NT machine using NTFS. Eventually someone posted a message which gave me the answer.

    You still need the CD to access the image. However, the boot carries on from hard drive when you start with Kernel 2.6 and use the bootfrom option:

    knoppix26 bootfrom=/dev/hd??

    Apparently the same poster said that to use Kernel 2.4 one needed to put the iso file on the hard drive. Not having the iso file I cannot verify that.

    Hope that helps. It worked for me.

  3. #3
    Junior Member
    Join Date
    Jul 2004
    Posts
    2
    Ha! Using Knoppix26 worked like a charm, the whole thing works great. Only... my mouse wheel doesn't work anymore. Huh, thats a strange one. I actually have had this problem before, I fixed it by change from a ps2 interface to a usb one... however, this just an actual PS2 mouse, I don't have any more usb mice.

    Its identified as a "Generic PS/2 Wheel Mouse at /dev/psaux" which is correct. Just.. no mouse wheel.

    Wierd.

    Well, thanks for the help

  4. #4
    Junior Member
    Join Date
    Jul 2004
    Posts
    1
    I've got the same problem, how to solve?

  5. #5
    Senior Member registered user
    Join Date
    Jul 2004
    Posts
    142
    Have you tried the wheelmouse cheatcode?

    i.e. bootup with

    knoppix26 bootfrom=/dev/hda?? wheelmouse

Similar Threads

  1. poor mans install for knoppix 3.3
    By metavoid in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 09-07-2005, 08:40 AM
  2. 3.7 Poor mans install using floppy boot
    By Kumagoro in forum Hdd Install / Debian / Apt
    Replies: 4
    Last Post: 02-11-2005, 07:37 AM
  3. Poor Mans Install WinPartition
    By guyana in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 10-15-2004, 02:10 AM
  4. Questions about a poor mans install
    By 00zero in forum General Support
    Replies: 4
    Last Post: 09-20-2004, 09:33 AM
  5. 3.4/2.6.6 Poor Man's (to/fromhd) install; boot with USB?
    By j.drake in forum Hdd Install / Debian / Apt
    Replies: 6
    Last Post: 08-29-2004, 07:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •