Results 1 to 3 of 3

Thread: Keyboard German QWERTZ in system terminals,Want US QWERTY

  1. #1
    Junior Member
    Join Date
    Aug 2004
    Location
    St Petersburg, FL
    Posts
    2

    Keyboard German QWERTZ in system terminals,Want US QWERTY

    I've found a couple of threads discussing this problem, but mine is slightly different. I chose the first of the three install options (beginner?) and it's mostly working very well. I had to change the keyboard and language for KDE and Mozilla. They're fine now.

    But when I use a system terminal (ctrl-alt F1, for example), the keyboard is German. The other discussions I've read had several suggestions, and I think i've tried them all. I was sure that editing /etc/sysconfig/i18n would do the trick. Unfortunately, every time I boot, this gets changed back to the de_DE... stuff. When I tryto reconfigure locales, I get this:

    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = "de",
    LC_ALL = (unset),
    LANG = "de_DE@euro"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    /usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
    /usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    /usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
    Generating locales...
    en_US.ISO-8859-1... done

    Trying to purge locales gives much the same.

    I suspect that the difference in whether a particular "fix" works depends on which type of install was done. I hope someone has a fix or workaround for this.

    Patrick

  2. #2
    Senior Member registered user
    Join Date
    May 2003
    Posts
    981
    Try edit /etc/init.d/knoppix-autoconfig. There is a setting for default lang in it. I'm not sure if beginner install uses this autoconfig or not; if not, somebody please post what it does use.

    PS: I'm assuming you have lang=en or lang=us added as a bootcode in lilo.conf. bootcodes are in the 'append=' line but check also the rest of the file, sometimes if you repeat them in the append line it will generate an error.

  3. #3
    Junior Member
    Join Date
    Aug 2004
    Location
    St Petersburg, FL
    Posts
    2
    Quote Originally Posted by CrashedAgain
    Try edit /etc/init.d/knoppix-autoconfig. There is a setting for default lang in it. I'm not sure if beginner install uses this autoconfig or not; if not, somebody please post what it does use.

    PS: I'm assuming you have lang=en or lang=us added as a bootcode in lilo.conf. bootcodes are in the 'append=' line but check also the rest of the file, sometimes if you repeat them in the append line it will generate an error.
    Thanks, CrashedAgain In knoppix-autoconfig in the first (non-comment) line after ### localization I changed LANGUAGE="de" to LANGUAGE="en" and now have the correct keyboard after rebooting.

    I'm using GRUB instead of lilo, and haven't yet researched entering command lines for the boot process. So much to learn!

Similar Threads

  1. Knoppix-STD - only comes with german keyboard? (german.kbd)
    By chaosnine in forum Customising & Remastering
    Replies: 5
    Last Post: 01-03-2017, 08:53 PM
  2. Change the keyboard language to swiss german?
    By Josh83 in forum General Support
    Replies: 3
    Last Post: 03-04-2005, 01:00 PM
  3. How to select default keyboard as German for login manger?
    By majo in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 01-31-2005, 01:32 PM
  4. Germany keyboard layout without german language?
    By CSY in forum General Support
    Replies: 4
    Last Post: 04-10-2004, 08:10 PM
  5. Great install, German Keyboard?
    By GREGC in forum Hdd Install / Debian / Apt
    Replies: 4
    Last Post: 03-08-2003, 06:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •