Results 1 to 4 of 4

Thread: Startup Config ?

  1. #1
    Junior Member registered user
    Join Date
    Jun 2004
    Posts
    10

    Startup Config ?

    My Soundcard isnīt working with the standard Knoppix 3.3 running. When Iīm booting from CD and inputting "Knoppix alsa" at startup, the sound works. But when I start Knoppix from HD there is no possibility to input this command at startup - Knoppix boots directly. How can I input the ALSA command at startup, or is there an file like the windows "boot.ini" where I can type the command to execute everytime at Knoppix startup ?

  2. #2
    Senior Member registered user
    Join Date
    Mar 2004
    Posts
    1,516
    there is a line in /etc/lilo.conf that says
    Code:
    append=whatever
    ad the cheatcode there (or add the line in lilo.conf) then run lilo (all as root).

  3. #3
    Senior Member registered user
    Join Date
    Feb 2004
    Posts
    237

    cheatcode for optical mouse?!

    Hi OErjan......is there a cheat code I can put in append=_______ in LILO to get my USB optical mouse to work? I have tried everything but it just wont work.....I am not sure if i edited the /etc/x11/xf86config-4 file correctly....i think i added "USB Mouse" and commented out "ps/2 mouse" Not sure what do do with that. bob :P

  4. #4
    Senior Member registered user
    Join Date
    Mar 2004
    Posts
    1,516
    i use Xorg on this can of chips/wires, but mostly the same settings should work.

    i use
    Code:
            Identifier  "Mouse1"
            Driver      "mouse"
            Option      "Protocol" "IMPS/2"
            Option      "Device" "/dev/mouse"
            Option      "ZAxisMapping" "4 5"
    EndSection
    but i guess /dev/mouse might have to be changed to /dev/input/mice or /dev/psaux.
    my laptop has this (from memory so...)
    first
    Code:
    Section "ServerLayout"
            Identifier     "XFree86 Configured"
            Screen      0  "Screen0" 0 0
            InputDevice    "Mouse0" "CorePointer"
            InputDevice    "Mouse1" "AlwaysCore"
            InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    then further down
    Code:
    Section "InputDevice"
            Identifier  "Mouse0"
            Driver      "mouse"
            Option      "Device" "/dev/psaux"
            Option      "Protocol" "PS/2"
            Option      "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
            Identifier  "Mouse1"
            Driver      "mouse"
            Option      "Device" "/dev/input/mice"
            Option      "Protocol" "IMPS/2"
            Option      "ZAxisMapping" "4 5"
    EndSection
    this alows me to use both the "mousedevice" (peg on the kbd) and the MX500 usb/ps2 mouse i have.
    both will move the same cursor (used as a ps/2 mouse as p1 laptops rarely have USB)

Similar Threads

  1. WLAN Config, Netcard-Config etc.
    By killozap in forum Networking
    Replies: 0
    Last Post: 09-29-2005, 08:41 AM
  2. default config scans on startup
    By Harry Kuhman in forum Ideas
    Replies: 13
    Last Post: 02-24-2005, 05:16 PM
  3. Konqueror startup
    By medwards67 in forum Customising & Remastering
    Replies: 0
    Last Post: 10-20-2004, 03:36 PM
  4. Please Post a Simple CONFIG file for Kernel Config
    By bongski55 in forum Hdd Install / Debian / Apt
    Replies: 6
    Last Post: 09-06-2003, 05:58 AM
  5. Startup
    By manghat in forum Customising & Remastering
    Replies: 2
    Last Post: 05-15-2003, 11:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •