Results 1 to 6 of 6

Thread: Enable DMA after Knoppix 3.4 Install

  1. #1
    Junior Member
    Join Date
    Aug 2004
    Posts
    6

    Enable DMA after Knoppix 3.4 Install

    I had no problems booting knoppix 3.3, but when i tried 3.4 it would get stuck at the dma acceleration part. So I booted 3.4 with the no dma option. I also installed this version to the harddrive. Everything works fine except it take alot longer to boot, I was told because DMA was not enabled. How do I enable dma at boot time?

    thanks

  2. #2
    Senior Member registered user
    Join Date
    Jun 2004
    Posts
    788
    Check your /etc/lilo.conf

    There should be a line (append=...........) that says nodma. Remove just that nodma, not the whole line. Save and then run lilo (on root konsole).

    Don't blame me if you can't boot later on.

  3. #3
    Junior Member
    Join Date
    Aug 2004
    Posts
    6
    Here is what i have in lilo.conf

    image=/boot/vmlinuz
    label="Linux"
    initrd=/boot/initrd.img
    append="ramdisk_size=100000 init=/etc/init lang=us apm=power-off nomce
    quiet nodma"
    read-only
    image=/boot/vmlinuz-2.4.26
    label="Linux(2.4)-1"
    initrd=/boot/initrd.img-2.4.26
    append="ramdisk_size=100000 init=/etc/init lang=us apm=power-off nomce
    quiet nodma"
    read-only

    image=/boot/vmlinuz-2.6.6
    label="Linux(2.6)-2"
    initrd=/boot/initrd.img-2.6.6
    append="ramdisk_size=100000 init=/etc/init lang=us apm=power-off nomce
    quiet nodma"
    read-only

  4. #4
    Senior Member registered user
    Join Date
    Jun 2004
    Posts
    788
    First thing to do is backup you /etc/lilo.conf.
    Then edit your /etc/lilo.conf, remove that "quite nodma" from kernel 2.4 first. Save.
    Open konsole:
    su
    lio

    Lilo will be updated.
    Reboot your system

    When boot option appear (lilo), choose boot from kernel 2.4. If you can boot flawlessly, then you can start edit your lilo again and remove "nodma" from other kernel.

    If you cannot boot properly, use unedited kernel (kernel2.6) to boot into system to restore your lilo.conf.

  5. #5
    Senior Member registered user
    Join Date
    Jun 2004
    Posts
    788
    Open konsole:
    su
    lio
    Sorry, typo, not lio but lilo.

  6. #6
    Junior Member
    Join Date
    Aug 2004
    Posts
    6
    Thanks a bunch shah
    Everything worked out well, I didnt have to use the backup lilo.conf.
    It does boot quciker now.

Similar Threads

  1. How to enable knoppix-dma by default?
    By tr in forum Customising & Remastering
    Replies: 2
    Last Post: 09-12-2005, 09:40 AM
  2. how to enable tulip while starting knoppix
    By rtsm in forum General Support
    Replies: 0
    Last Post: 12-12-2004, 08:59 AM
  3. How to enable telnet daemon on Knoppix ?
    By markraem in forum Networking
    Replies: 8
    Last Post: 11-07-2004, 03:11 PM
  4. how to enable login screen in KNOPPIX for authentication
    By pankajgadhari in forum Customising & Remastering
    Replies: 2
    Last Post: 02-02-2004, 01:24 AM
  5. how to enable login screen in KNOPPIX for authentication
    By pankajgadhari in forum Customising & Remastering
    Replies: 5
    Last Post: 01-23-2004, 08:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •