Results 1 to 9 of 9

Thread: Captive-ntfs 1.1.5 in Knoppix 3.6 hangs when mounting drive

  1. #1
    Junior Member registered user
    Join Date
    Jan 2004
    Posts
    15

    Captive-ntfs 1.1.5 in Knoppix 3.6 hangs when mounting drive

    The captive-ntfs installer script from the menu item works fine, but a subsequent attempt to mount the drive
    # mkdir /mnt/c
    # mount -t captive-ntfs /dev/hda1 /mnt/c
    hangs without completing. The /var/lib/captive/tmp directory gets created,
    but the other temp directory /var/lib/captive/S-* seems not to be made.

    Maybe it's a knoppix 3.6 permissions thing? There's no "captive" user or group created,
    which is the owner of the S-* temp directory in knx V3.4.
    This worked easily with captive 1.1.4 in Knoppix_V3.4-2004-05-17-EN,
    but does not work with captive 1.1.5 Knoppix_V3.6-2004-08-16-EN.

    Author has mailing list here:
    http://www.jankratochvil.net/pipermail/captive-list/
    but I didn't see anything definitive that worked for me.

    Anyone else get it working from CD?

    Thanks,
    Pete

  2. #2
    Junior Member
    Join Date
    Sep 2004
    Posts
    1
    pbs,
    I've also had the same problem when attempting to mount /dev/hda1 using captive-ntfs on knoppix 3.6. I used the following procedure.

    1. Open Console
    2. su
    3. mount -t ntfs /dev/hda1 /mnt/hda1
    4. captive-install-acquire --scan-disks=/mnt/hda1/WINDOWS/system32/drivers
    5. umount /mnt/hda1
    6. mount -t captive-ntfs /dev/hda1 /mnt/hda1

    I think you are probably right in that it might be something permission related. Anyone???

  3. #3
    Junior Member
    Join Date
    Apr 2004
    Posts
    4
    AFAIK, Captive NTFS wont work with WINDOWS XP.

  4. #4
    Junior Member
    Join Date
    Sep 2004
    Posts
    2
    Captive not working on XP? BS
    I have it working with Bit Defender's LinuxDefender Live! 1.5.6
    just not with knoppix 3.4 but since LDL! is bsed on knoppix I don't know why it wouldn't work

  5. #5
    Junior Member registered user
    Join Date
    Jan 2004
    Posts
    15
    Quote Originally Posted by johnson25
    AFAIK, Captive NTFS wont work with WINDOWS XP.
    Captive-ntfs on Knx_V3.4-2004-05-17-EN works with Windows XP Home and an unencrypted file system; I've done it.

  6. #6
    Junior Member registered user
    Join Date
    Jan 2004
    Posts
    15
    Solution! for V3.6-2004-08-16

    The problem is that the user "captive" and group "captive" have been removed accidentally in V3.6. One has to recreate them; I copied settings from KnxV3.4-2004-05-17-EN for use in procedure below.

    Penguin Menu:Root Shell
    passwd
    (set to your choice)

    KDE Menu:System:KUser
    (enter passwd)
    OK
    Adduser Button: captive
    userID: 108 (same as v3.4)
    login shell: /bin/false
    home folder: /var/lib/captive
    uncheck all three boxes (in reverse order to avoid greying out)
    Groups Tab
    Primary Group: nogroup
    OK
    AddGroup Button:
    Group name: captive
    Group number: 116 (not same as V3.4, but close by.)
    SAVE
    Dialog 'no shadow entry for captive': OK

    Penguin Menu: Utilities:Captive NTFS
    Follow menu directions; get XP drivers from your hard drive, or download them; Win 2k drivers won't work.

    Penguin Menu:Root Shell
    mkdir /mnt/hda1 (or whatever you like)
    mount -t /dev/hda1 /mnt/hda1

    Lastly, there's couple in's and out's for accessing the drive:
    I edited the lines in /etc/fstab to look like: (changed ntfs to captive-ntfs and ro to rw)

    # Added by KNOPPIX
    /dev/hda1 /mnt/hda1 captive-ntfs noauto,users,exec,rw,umask=000,uid=knoppix,gid=kno ppix 0 0

    Next, right clik on kde desktop icon:Propertiesevice:uncheck Read Only
    Now you can open the drive by clicking this icon in Konqueror and read/write as you like.

    Lastly, REMEMBER to unmount the drive before quitting or your changes may be lost and not copied from the sandbox data area to be written to the hard drive.


    Good Luck,
    Pete

  7. #7
    Junior Member
    Join Date
    Feb 2005
    Posts
    1

    3.4 and captive ntfs

    I tired the 3.7 distro and kept striking out. I went back to 3.4 and had simular issues. I was trying to do this on a win2k laptop. I had the ntfs.sys and ntoskrnl.exe files from the win2k system but captive would not see them. I took copies of them from my XP Pro laptop and had better luck. I did have to chown to captive the files before they were found. I was not able to add captive as a user on 3.7 per earlier suggestions. 3.4 did the trick after I copied over the XP drivers. I was wanting to rename a dll on a 2kpro so some spyware/evilness would quit when safe mode let me down. Here is my sequence of events:

    1. Copied ntfs.sys and ntoskrnl.exe to /var/lib/captive
    2. Chown captive.captive files in /var/lib/captive
    3. Run captive from the pengiun and let is search.
    4. Mount hda1 then set to read/write.
    5. Run wild in the windows ntfs patition.

    Now that I have done this on a win2k box, I want to try on a NT4.0.

  8. #8
    Junior Member registered user
    Join Date
    Jan 2004
    Location
    Tacoma, WA
    Posts
    29

    Symple script to run captive-ntfs

    Captive-ntfs

    Each time to access ntfs from knoppix running from cd, I run simple script without using any other programs. If your settings are saved on hd, you need to run this script once, and only mount ntfs next.

    Detailed and updated instruction how to write to ntfs posted here:

    http://www.knoppix.net/forum/viewtopic.php?t=17024

    >>>>>>>>>>>>>>>>

  9. #9
    Junior Member
    Join Date
    Mar 2005
    Location
    Munich
    Posts
    1
    Hi,

    I had bad luck with captive-ntfs as well. I'm not quite shure why, but it stopped working. I use knoppix 3.7, and I tried to write on a Windows 2000 Server SP 4 ntfs partition, using the drivers that came with that.

    I had to delete /var/lib/captive/*.sys bevore using the captive utility. Otherwise the scanning of the harddisk stopped and the necessary files were not found. I then mounted the harddisk as discribed in the captive utility and could restore files.

    Meanwhile things changed. I updated the Windows 2000 Server. Scanning for the drivers with the tool does not work any more. If I copied them manually, and try to mount with filesystem type captive-ntfs, the mount command will hang.

    Both Knoppix and Windows 2000 are German versions.

    Does anyone have a suggestion?

Similar Threads

  1. Can't find Captive-Ntfs on Knoppix 3.8
    By heizy in forum General Support
    Replies: 2
    Last Post: 04-01-2005, 12:42 PM
  2. unable to write to NTFS with captive-ntfs
    By harry66 in forum General Support
    Replies: 1
    Last Post: 03-30-2005, 05:03 PM
  3. Captive NTFS on Knoppix 3.6 and WInXP / NTFS hard drive
    By itaydagani in forum MS Windows & New to Linux
    Replies: 3
    Last Post: 02-02-2005, 12:53 AM
  4. captive ntfs - mount ntfs (reade/write) through icon
    By terminator in forum General Support
    Replies: 0
    Last Post: 05-12-2004, 10:52 PM
  5. Knoppix 3.4 'ct, captive ntfs, and konqueror
    By Pixnoob in forum General Support
    Replies: 5
    Last Post: 03-08-2004, 03:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •