Results 1 to 7 of 7

Thread: Can't Get Internet to Work--3.6 Live CD

  1. #1
    Junior Member
    Join Date
    Sep 2004
    Posts
    4

    Can't Get Internet to Work--3.6 Live CD

    Warning: Complete Linux newbie here!

    I am trying to use Knoppix 3.6 live CD. I found the equivalent of the Internet Connection Wizard (KPPP), set it up, then tried to connect. The dialog box got stuck on Initializing Modem... When I go to Configure > Modem tab > Query Modem button. It recognizes the modem (I think it says Modem is Ready), then goes through whatever process it's doing, then shows a screen with labels like ATI1, ATI2, etc. and all the boxes are blank.

    Then when I hit the Terminal button (on the same box as the Query Modem button), it says Modem is Ready.

    Did I set something up incorrectly? Without any changes, the modem and internet connection works fine in Windows. If you need more info, I can provide it! Thanks in advance for any help and thanks for this great resource for us newbies!

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    Portland, OR USA
    Posts
    568
    Quote Originally Posted by dylan000
    all the boxes are blank.
    That means it didn't "find" your modem (what kind do you have?). Try going to the "Device" tab and clicking on the box next to "Modem Device" and cycling through them (/dev/ttyS0, /dev/ttyS1, etc.), then going back and trying "Query Modem" on the "Modem" tab after each change.

    When you've got the right device selected, those empty boxes will be filled up with the output from where it queryed your modem.

  3. #3
    Junior Member
    Join Date
    Sep 2004
    Posts
    4
    Thanks for your easy-to-follow response! My internal laptop modem is listed as ESS ES56CVM-PI Data Fax Voice Modem. I tried what you said, and when I ran the Query Modem on /dev/ttyS0, it was the only one where I got a Modem Ready, then it ran through it's process, but I got blank AT strings. On any other setting (/dev/ttyS1, /dev/ttyS2, etc.), I either got Modem is Busy or Unable to Open Modem.

    Any other instructions you can offer?

  4. #4
    Junior Member
    Join Date
    Sep 2004
    Posts
    4
    I should point out that I went through the Knoppix Help menu that detailed what to check/fill in on each tab of the setup boxes. Also, if it helps, I have discovered that in Windows, the modem is listed as being on COM3.

  5. #5
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    Portland, OR USA
    Posts
    568
    I spent some time googling, and as best I can tell, you have an Agere (formerly Lucent) based Winmodem (link to Windows drivers which you probably don't need).

    No, I don't know how to tell you get it working from the Knoppix Live CD. I doubt you can.

    You could try Kanotix instead, it's a good Knoppix based distro, and apparently has the modules for that modem, plus a script to install them, on the Kanotix Live CD.

    I say "apparently," since I don't have one to test.

    See this thread on the Kanotix forum.

  6. #6
    Junior Member
    Join Date
    Sep 2004
    Posts
    4
    Thanks for the info! I'll check it out! I was warned that Knoppix might not recognize my modem, so thank you for clarifying that that's probably the issue, and not my setup. Maybe I'll try to find an external modem. Thanks again!

  7. #7
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    Portland, OR USA
    Posts
    568
    Kanotix doesn't have a script to install them, upon further inspection, but does have modules named "ltmodem" and "ltserial" that might work.

    Sorry I couldn't help you to get it working!

Similar Threads

  1. No sound & No internet Live DVD
    By nlyric in forum General Support
    Replies: 0
    Last Post: 08-26-2005, 05:57 AM
  2. Enter Internet Trough Knoppix Live CD ( HOW ??? )
    By Maistro in forum General Support
    Replies: 1
    Last Post: 03-23-2005, 11:03 PM
  3. Internet fast on Live CD but SLOW on HD install
    By azucar151 in forum Networking
    Replies: 1
    Last Post: 12-04-2004, 11:46 AM
  4. Replies: 6
    Last Post: 10-01-2004, 05:12 AM
  5. A Live CD script for Auto Internet Login? (DSL)
    By bonecrusher in forum General Support
    Replies: 1
    Last Post: 03-05-2004, 11:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •