Results 1 to 5 of 5

Thread: agppart module..

  1. #1
    Junior Member
    Join Date
    Oct 2004
    Posts
    2

    agppart module..

    hi..
    i use knoppix3.3 ..after booting ..when it stats Starting X11..it gives following error:
    Starting X11 [drm:drm_init] *ERROR * Cannot initialize the agppart module
    /lib/modules/2.4.24-xfs/kernel/drivers/char/drm/i810.o: init_modules: Cannot allocate memory.
    Hint: insmod erroe=rs can be caused by incorrect modules parameters.
    You may find more info. In syslog or the output from dmesg.
    /lib/modules/2.4.24-xfs/kernel/drivers/char/drm/i810.o: insmod /lib/modules/2.4.24-xfs/kernel/drivers/char/drm/i810.o: failed.

    wht is mean by this & why this error occured?
    though X server starts after that & everything works fine.

    thankx.

  2. #2
    Senior Member registered user
    Join Date
    May 2003
    Posts
    981
    I also was getting this error with knoppix 3.3 & with 3.4 using the 2.4 kernel (also i810 vid card). Switching to 3.4 / 2.6 kernel fixed it.
    Agpgart has to do with video card acceleration, I could not use graphics-intensive applications like tuxracer until it was working.

  3. #3
    Senior Member
    Join Date
    Nov 2003
    Posts
    1,323
    IIRC I had the same memory problem with Knoppix 3.3 and i810, and solved it by adding a line for more video memory in /etc/X11/XF86config-4 :
    Code:
    Section "Device"
            ### Available Driver options are:-
    # sw_cursor is needed for some ati and radeon cards
            #Option     "sw_cursor"
            #Option     "hw_cursor"
            #Option     "NoAccel"
            #Option     "ShowCache"
            #Option     "ShadowFB"
            #Option     "UseFBDev"
            #Option     "Rotate"
            Identifier  "Card0"
    # The following line is auto-generated by KNOPPIX mkxf86config
            Driver      "i810"
            VendorName  "All"
            BoardName   "All"
    #       BusID       "PCI:1:0:0"
            VideoRam    16384
    EndSection

  4. #4
    Senior Member registered user
    Join Date
    May 2003
    Posts
    981
    I have also added video memory but still the agpgart module will not initialize unless I use the 2.6 kernel.

  5. #5
    Senior Member
    Join Date
    Nov 2003
    Posts
    1,323
    Hmm, makes me wish I'd remember what I did to make tuxracer run on 3.3. Wasn't there 3 different i810 display adapters to choose from, but only one worked (after adding memory). Easier to try a newer version of knoppix though.

Similar Threads

  1. perl module
    By madmadmod in forum Customising & Remastering
    Replies: 0
    Last Post: 01-15-2005, 05:14 PM
  2. Is module/Driver installation possible?
    By Jansi in forum General Support
    Replies: 0
    Last Post: 08-06-2004, 02:45 PM
  3. How to add a modem module to kernel ?
    By MrAhmad in forum Customising & Remastering
    Replies: 1
    Last Post: 09-06-2003, 11:45 AM
  4. usb module loading help
    By corwinspyre in forum Hardware & Booting
    Replies: 1
    Last Post: 08-15-2003, 08:38 PM
  5. problem with cloop module...
    By Myrdhin in forum Customising & Remastering
    Replies: 2
    Last Post: 08-01-2003, 02:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •