Results 1 to 5 of 5

Thread: HOW-TO: get read/write access to HD?

  1. #1
    Junior Member registered user
    Join Date
    Nov 2004
    Posts
    25

    HOW-TO: get read/write access to HD?

    One question. How can I setup within Knoppix to read/write to my HD devices? I right-click on my HD and selected "change to read/write". But this doesn't seem to work or do anything. I still only get read-only access to my HDs.

    Cheers
    Kevin

  2. #2
    Junior Member
    Join Date
    Mar 2004
    Posts
    9
    as a root you mount the HD.
    look in the /etc/fstab, normally knoppix creates /mnt/hdX as a mount point for /dev/hdX
    put as default the mount like this

    /dev/hda5 /home ext3 defaults 0 0


    you can use now
    mount /home for example
    best regards

  3. #3
    Senior Member registered user
    Join Date
    May 2003
    Posts
    981
    If your desktop HD icons are not working you can mount the drive manually.
    'sudo mount -rw /dev/hdaX' should mount /dev/hdaX to the default location as specified in /etc/fstab. Usually this will be /mnt/hdaX but you can mount it elsewhere with 'sudo mount/-rw /dev/hdaX /home/knoppix/hdaX' for example. You will have to mkdir /home/knoppix/hdaX first.

  4. #4
    Junior Member registered user
    Join Date
    Nov 2004
    Posts
    25
    Thanks you guys. This is very useful.

  5. #5
    Quote Originally Posted by CrashedAgain
    If your desktop HD icons are not working you can mount the drive manually.
    'sudo mount -rw /dev/hdaX' should mount /dev/hdaX to the default location as specified in /etc/fstab. Usually this will be /mnt/hdaX but you can mount it elsewhere with 'sudo mount/-rw /dev/hdaX /home/knoppix/hdaX' for example. You will have to mkdir /home/knoppix/hdaX first.
    Hello,

    I'm trying to get write access to an empty EXT2 formatted drive. The icon for the drive comes up on the desktop as I would expect. I removed the "Read Only" check in the properties for the drive and gave Owner, Group, and Other "Can Read & Write" access. When I try to drag anything to the root of that drive though, I get a "You cannot drag items into a directory that you do not have write permission" message.

    I tried from terminal doing "umount /mnt/hdd1" and then "sudo mount /mnt/hdd1" and that didn't fix anything. There must be a straightforward way to write to a hard drive? Any advice would be greatly appreciated.

    Update: I ran "sudo mount -o remount,rw /mnt/hdd1" from the terminal and still could not write anything to the drive. I then tried a "mkdir test" from the terminal and got rejected. Finally, I did a "sudo mkdir test" and that worked! So apparently I have to run every write operation as root? Is there a way to become root in the GUI so I don't have to perform write operations from the terminal?

    Thanks!

Similar Threads

  1. HDD read only, cannot access
    By greygooseplz in forum Hdd Install / Debian / Apt
    Replies: 4
    Last Post: 11-17-2004, 12:17 AM
  2. Change OS read only file to read/write after "poor man'
    By Needtoknow in forum Hdd Install / Debian / Apt
    Replies: 10
    Last Post: 10-22-2004, 02:27 AM
  3. Read/Write Access to Windows NTFS parition?
    By blt975 in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 01-13-2004, 10:39 PM
  4. How to get enable read/write access (Hd Based)
    By buxus in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 06-26-2003, 05:45 AM
  5. need read AND write access to some files in /var/lib
    By redrat in forum Customising & Remastering
    Replies: 3
    Last Post: 03-12-2003, 03:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •