Results 1 to 5 of 5

Thread: HD install different to when running CD ?

  1. #1

    HD install different to when running CD ?

    I'd got everything running fine on the CD (including sound at last!). I'd used the following cheat codes
    Code:
    knoppix26 pnpbios=off lang=us wheelmouse
    I then installed everything onto the hard drive using
    Code:
    knoppix-installer
    Now when I log in I get an error saying it doesn't recognise /dev/dsp and hence I get no sound. Problem was everything worked fine using the CD. I used to get this problem on the CD if I didn't specify knoppix26 and I found I needed pnpbios=off if I used knoppix26.

    Help.

    Mike Robinson

  2. #2
    Senior Member registered user
    Join Date
    May 2003
    Posts
    981

    Re: HD install different to when running CD ?

    Quote Originally Posted by mike_the_bike
    I'd got everything running fine on the CD (including sound at last!). I'd used the following cheat codes
    Code:
    knoppix26 pnpbios=off lang=us wheelmouse
    I then installed everything onto the hard drive using
    Code:
    knoppix-installer
    Now when I log in I get an error saying it doesn't recognise /dev/dsp and hence I get no sound. Problem was everything worked fine using the CD. I used to get this problem on the CD if I didn't specify knoppix26 and I found I needed pnpbios=off if I used knoppix26.

    Help.

    Mike Robinson
    Check the file /etc/lilo.conf. There should be a line 'append="ramdisk=xxxx....etc"' . This is the equivalent of booting with these cheatcodes. If your pnpbios=off is not in this list, add it in; then run lilo to implement your changes. You won't have to add the knoppix26, you should have that option on your boot menu.
    Both the edit and the run lilo must be done as root.
    This may get your sound working, if it doesn't, post again, there are some other setups often needed for sound.

  3. #3
    First time I've looked at the /etc/lilo.conf file but it seems fine (though none mention knoppix26). It would surprise me if this was wrong as this would imply every hard disk installation would go wrong.
    Code:
    default="Linux"
    
    image=/boot/vmlinuz
       label="Linux"
       initrd=/boot/initrd.img
       append="ramdisk_size=100000 init=/etc/init lang=us apm=power-off nomce pnpbios=off lang=us wheelmouse"
       read-only
    
    image=/boot/vmlinuz-2.4.27
       label="Linux(2.4)-1"
       initrd=/boot/initrd.img-2.4.27
       append="ramdisk_size=100000 init=/etc/init lang=us apm=power-off nomce pnpbios=off lang=us wheelmouse"
       read-only
    
    image=/boot/vmlinuz-2.6.7
       label="Linux(2.6)-2"
       initrd=/boot/initrd.img-2.6.7
       append="ramdisk_size=100000 init=/etc/init lang=us apm=power-off nomce pnpbios=off lang=us wheelmouse"
       read-only
    If I run dmesg then it implies I'm using kernel 2.6.7
    Code:
    Linux version 2.6.7 (root@Knoppix) (gcc-Version 3.3.4 (Debian 1:3.3.4-3)) #2 SMP Wed Jul 28 04:25:36 CEST 2004
    But I get the following types of errors
    Code:
       Sound server informational message:
       Error while initializing the sound driver:
       device /dev/dsp can't be opened (No such device)
       The sound server will continue, using the null output device.
    
    and
    
    # play /usr/share/sounds/startup.ogg
    sox: Can't open output file '/dev/dsp': No such device
    and of course no sound !

    Mike Robinson

  4. #4
    Member registered user
    Join Date
    Aug 2004
    Location
    San Antonio, TX
    Posts
    61
    I wonder if the problem you are seeing is similar to the problem reported in the following thread:
    http://www.knoppix.net/forum/viewtop...446&highlight=

    Might be worth a shot...

  5. #5
    Senior Member registered user
    Join Date
    May 2003
    Posts
    981
    Try running /etc/init.d/alsa-config. You may have to be root so 'sudo /etc/init.d/alsa-config'.

    To add your cheatcode, add to the 'append=' line of the boot entry you are using. (or just add it to all of them).

    Here is an excerpt from a previous post concerning no sound; you may have to go though these steps also.
    Code:
    To get your sounds working, enable sounds in kde control center (which you hav already done), then enable all system notification sounds. Then you have to edit the hidden file /home/(username)/.kde/share/config/knotifyrc & change all three settings to 'yes'. Why kde doesn't do this automatically is a mystery to me since the user is obviously trying to enable system sounds but it doesn't.

Similar Threads

  1. Replies: 3
    Last Post: 12-09-2005, 05:46 PM
  2. hdd install (keeps freezing while running off hd)
    By oh_jason in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 05-23-2005, 10:26 AM
  3. Replies: 29
    Last Post: 01-10-2005, 06:01 PM
  4. Replies: 45
    Last Post: 05-18-2004, 02:10 AM
  5. disks automount running from CD; why not after HDD install?
    By timothy in forum Hdd Install / Debian / Apt
    Replies: 3
    Last Post: 10-05-2003, 07:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •