Results 1 to 6 of 6

Thread: Knoppix for kids boot problems

  1. #1

    Knoppix for kids boot problems

    I am a first time knoppix user. I got an iso of knoppix for kids, and it won't boot.

    On my regular desktop, it won't start X, complaining about not being able to load agpgart and mga modules, but it correctly autodetects my Matrox G550 card, and dumps me into the root prompt. I guess that tells me the CD is OK.

    On the target machine, it hangs after Autodetecting devices ||||||||| done. The cursor is at the left screen border, blinking. At that point, the machine is dead for all intents, but I guess the kernel is still running, as the screen blanks after a few minutes. I've tried failsafe and knopppix 2, both with the same result.

    I have no experience with knoppix or live CD distros at all, so I'm a bit stuck.... Both machines run Fedora core just fine. My desktop runs FC1, and the target machine runs FC2.... The target machine is an old IBM Intellistation Z-Pro - an SMP P-Pro box running at 200 MHz.

    Any suggestions, hints, etc?

    Thanks,

    --Yan

  2. #2
    Member registered user
    Join Date
    Oct 2004
    Posts
    52
    Try cheat code at boot prompt:
    knoppix testcd

    This will test the cd to see if it is correct.

    What is the hardware of your pc? Like amount of ram, etc.

  3. #3
    I can only reply, DUH!

    Bad CD.... The downloaded iso checksum is bad as well, so a new download is on the way.

    --Yan

  4. #4
    OK, new download, verified MD5sum, everything is OK....

    But, the CD boot still hangs at Autoconfiguring devices.

    The CD boots fine on a Pentium Celeron 1400, but hangs on this SMP P-Pro 200 MHz box.

    The exact hardware is an SMP P-pro, 200 MHz, 298 MB RAM. The box is an old IBM Intellistation Z-Pro.

    Any suggestions? Any way to turn on debugging to find out exactly where it's hanging?

    --Yan

  5. #5
    Administrator Site Admin-
    Join Date
    Apr 2003
    Location
    USA
    Posts
    5,441
    Quote Originally Posted by cptdondo
    But, the CD boot still hangs at Autoconfiguring devices......
    This is (IMHO unfortunately) pretty common since about Knoppix 3.4. Knoppix used to boot pretty safely and would boot on most systems. Now it boots "agressively", with more advanced features on by default, and unfortunately this causes lot of problems for new (and experienced) users. What you likely will need to resolve this is one or more "cheat codes" at boot time.

    Unfortunately, I know of nothing but trial and error to find what cheat codes you might need to help you boot. And also unfortunately many systems (lke mine) have needed a combination of cheat codes to get past hanging, so it may take a little trial and error to get started. In my case I found that I needed two cheat codes together to get booted, so at the boot prompt I type knoppix noscsi acpi=off. This might be as good of a place as any to start, as well as each of these codes individually. Also a very common code needed is nodma.

    If that doesn't resolve the issue you might try typing f2 and f3 at the boot prompt to review the cheat codes (but I don't believe all of them are listed there). Hopefully others will ad to this thread with codes that they need to boot.

  6. #6
    Well, faillsafe booted OK, but the regular boot failed.

    I disabled the (very strange) mobo sound card in the bios, and lo and behold, the machine booted up just fine.

    The performance is perfectly acceptable, by the way. Even with a very slow machine, my kid is happily drawing and doing math.... The machine is too slow to watch movies on, but that's part of the reason why I gave it to my kid... She wants to learn about computers, and she won't do that by watching movies on it...

    Now, any way to do a hard disk install so I can add my own software? I really want to add gcompris and multiple languages (japanese and czech, in addition to the default english.)



    --Yan

Similar Threads

  1. Councilmen Propose Citywide Curfew For Kids Under 18
    By david7035 1 in forum The Lounge
    Replies: 14
    Last Post: 03-24-2007, 11:33 AM
  2. Boot problems with Knoppix
    By phen in forum General Support
    Replies: 5
    Last Post: 12-17-2004, 04:51 PM
  3. knoppix for kids mounted something incorrectly?
    By DoubleL in forum General Support
    Replies: 7
    Last Post: 05-07-2004, 06:31 AM
  4. Knoppix boot problems
    By grob in forum General Support
    Replies: 5
    Last Post: 01-06-2004, 10:02 PM
  5. Replies: 0
    Last Post: 02-07-2003, 06:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •