Results 1 to 3 of 3

Thread: KDM Start Error In Chroot Knoppix 3.7 HELP!

  1. #1
    Junior Member
    Join Date
    Dec 2004

    KDM Start Error In Chroot Knoppix 3.7 HELP!

    Hi All,
    Could anyone shed light on the following (pls ) ??
    I currently have a chroot enviroment Knoppix3.7 sitting on my hdd as a WIP remaster. Now, 3.4 didn't have this problem, but when installing kdm via apt all goes well (it will start in X with login screen) until I attempt to login.
    Yes I have set new passwords and have editted /etc/kde3/kdm/kdmrc to "allow root login=true".
    Kdm attempts to start a session but oddly, resets back to the login greeter screen
    FYI, I also "mount -t proc /proc proc". Console login works fine. Can you Help??
    BTW, my aim is to have a remastered Knoppix that boots to Graphical Greeter (run level 5). Currently my remaster is ' bristling with niceness ' and would love to get this sorted.
    Thanks in advance

  2. #2
    Senior Member
    Join Date
    Nov 2003
    Washington State
    It looks like a buggy package; I had the same problem on debian with the latest version kdm from unstable.

    currenlty your choices are to downgrade kdm, download and compile the latest kdm from source, or install gdm.

  3. #3
    Junior Member
    Join Date
    Dec 2004
    Thanks for your sugestion,

    However, I tried downgrading to "testing" version of KDM. It Just simply crashed when used.
    Also "stable" was now too obsolete and caused dependency errors from APT when attempting to downgrade further.

    As a side point, I have in addition to my chroot Knoppix, a standard HDD install of Knoppix too. KDM works fine in this instance. Also my chroot version of Knoppix is now KDE-3.3.2 "experimental" and still the problem persists with KDM

    I Tried copying KDM folder from booted live cd over to chroot enviroment still no joy.

    I feel that maybe a path or symlink kind of problem with latest Knoppix(3.7) maybe be the cause, or wether booting to kernel 2.6.9 in preference to 2.4.27 on the live cd makes a difference before attempting/copying to '.../knx/source/KNOPPIX' on hdd(?) .

    The wiki 'HowTo' document site is continually down so I can't check for possible changes to remaster guide for Knoppix3.7 (if any..).

    Hmm maybe Knoppix3.8 is the solution

Similar Threads

  1. CD Boot fails: Syntax error near start.
    By Getnikar in forum Hardware & Booting
    Replies: 8
    Last Post: 06-18-2006, 05:13 AM
  2. knoppix remastering error - kde won't start
    By cinematography in forum Customising & Remastering
    Replies: 1
    Last Post: 09-05-2005, 12:50 AM
  3. Error: Couldnt Start kdeinit....
    By -=NTL=- in forum General Support
    Replies: 1
    Last Post: 06-21-2003, 09:01 PM
  4. chroot error:no such file or directory
    By bongski55 in forum Customising & Remastering
    Replies: 3
    Last Post: 06-21-2003, 11:16 AM
  5. chown error at start
    By Zhila in forum General Support
    Replies: 0
    Last Post: 04-19-2003, 01:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts