Ok, so my hard drive crapped out the other day, and it seems like the boot sector and the table indicies are toast. Windows simply won't recognize the hard drive at all. So I figured I'd use my Knoppix STD v0.1 Live CD and see if i could mine the data using that.

I'm able to mount the drive Ok and I'm able to sift through all the files just fine. I have an FTP server at home running Gentoo (I believe the most recent version), so i figured I'd just ship the files off to my FTP server. I got a little fustrated trying to transfer files through a text based FTP, I kept getting a "Not a normal file" error.

So I tried booting up knoppix with a GUI. I used gFTP 2.0.15rc2 as my FTP client, and I was able to connect to the FTP server just fine. When I tried to change the local directory to my mounted hard drive, I got the message "Could not change local directory to /mnt/windows :Permission Denied" So I tried temporarily copying a couple of files I needed off the disk on to my ramdisk. I was able to set the ramdisk as my local directory just fine, but whenever I tried transfering files to the FTP it would say that it skips the file, the log would read:

Received URL file///ramdisk/var/file1.txt
Error: Cannon open local file /ramdisk/var/file1.txt :Permission Denied
227 Entering Passive Mode (172,17,1,1,252,250) *note: server IP is
LIST -aL []
150 Here comes the directory listing
226 Directory send OK

Now, I'm able to preview the files from the harddrive just fine, and I tried sending a random file off of the Knoppix CD to the FTP server, and that went through just fine. And yes, I did mount the hard drive with the correct file system (ntfs). I've tried transfering files to the FTP server with root access only in the text mode, and I still got the "Not a normal file error". I personally don't have root access, so I didn't get a chance to try transfering files with root access in the GUI.

I don't believe that its a firewall issue, because I can transfer files to the FTP server that don't originate from the hard drive just fine. I'm a little confused why I get permission denied when I try to transfer files from the hard drive to the FTP server, but I can copy them to the ramdisk and view them without any problems. One possible alternative I was thinking was throwing in another hard drive and trying to transfer the files from the shot hard drive to the second one.

Thoughts? Alternatives? Solutions?

If you need more info just let me know, I think I got everything of relevance tho.

**edit - Ok, I read into this a little more and it seems that drives are mounted by default as read-only, and I would need to remount it with read-write access after mounting it the first time. This will probibily fix my problem.