Results 1 to 2 of 2

Thread: ped_disk_next error creating partitions ?

  1. #1
    Junior Member registered user
    Join Date
    Dec 2004
    Location
    USA
    Posts
    19

    ped_disk_next error creating partitions ?

    I am trying to install a quad boot with Windows ME, 2000, and Fedora. ME and W2K are up, and Knoppix is next, the first thing to go on the second hard disk. It doesn't matter if I make the partiions with W2K, System Commander 7, or qtParted under Knoppix 3.6 or 3.7, but I wind up with variants of the following:

    knoppix@ttyp0[knoppix]$ sudo knoppix-installer
    Disk /dev/hdc doesn't contain a valid partition table
    Disk /dev/hda doesn't contain a valid partition table
    Disk /dev/hdc doesn't contain a valid partition table
    Disk /dev/hda doesn't contain a valid partition table
    Disk /dev/hdc doesn't contain a valid partition table
    Disk /dev/hda doesn't contain a valid partition table
    Error: Unable to open /dev/hdc - unrecognised disk label.
    A bug has been detected in GNU parted. Please email a bug report to bug-parted@gnu.org containing the version (1.6.9) and the following message:Assertion (disk != NULL) at ../../libparted/disk.c:1037 in function ped_disk_next_partition() failed.
    knoppix@ttyp0[knoppix]$

    If I recreate the target disk from scratch in qtParted I also get the "ped_disk_next" error in a pop-up window. Any clue where I am going wrong ?

    Thanks,
    rcs

  2. #2
    Junior Member registered user
    Join Date
    Dec 2004
    Location
    USA
    Posts
    19

    BIOS upgrade seems to have solved issue

    This was an MSI MS-5169 motherboard that I recently replaced in this machine. The board was a "pull" from a liquidator, and I had neglected to update its BIOS. I flashed from BIOS revision A5169AS6 V1.0 B1 to A5169MS V3.7, and after getting the settings right, it seems to be installing fine.

    I am CD booted into 3.7 now, and it is pretty cool to be surfing the web on the same computer you're installing the O/S to.

    rcs

Similar Threads

  1. Knoppix and creating partitions not recogniozed by XP CD
    By zillah in forum Hardware & Booting
    Replies: 14
    Last Post: 01-14-2006, 10:54 PM
  2. Creating Linux and Swap partitions on a blank drive
    By pezz453 in forum Hardware & Booting
    Replies: 7
    Last Post: 08-11-2005, 10:07 PM
  3. Error message when creating md5sums
    By CrashOver in forum General Support
    Replies: 2
    Last Post: 08-08-2005, 09:00 AM
  4. error while creating the final image of knoppix
    By pankajgadhari in forum Customising & Remastering
    Replies: 1
    Last Post: 08-06-2003, 11:15 AM
  5. Mounting and creating shortcuts for partitions
    By xolstis in forum General Support
    Replies: 7
    Last Post: 06-29-2003, 06:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •