Results 1 to 7 of 7

Thread: Desktop

  1. #1
    Junior Member
    Join Date
    Jan 2005
    Posts
    7

    Desktop

    I was screwing around with a Knoppix HD installation on my PC, and i changed the desktop, now it only boots up in text mode, how can i get it to boot back into KDE?

  2. #2
    Junior Member registered user
    Join Date
    Jan 2005
    Posts
    13
    I'm new to this but, when yo'ure at text mode type....

    startx

    And it should go to graphical mode (i think)
    worth a try

  3. #3
    Junior Member
    Join Date
    Jan 2005
    Posts
    7

    i tried that

    i received errors when i did that, reguardless of whether i was Root user or not. error is as follows:
    fatal server error
    no screens found

    XIO: fatal IO erro 1104 connection reset by peer.

  4. #4
    Member registered user
    Join Date
    Jan 2005
    Posts
    42
    Try 'init 5' or 'kdm' as root.

    If this doesn't work your /etc/X11/XF86Config-4 is probably broken.

  5. #5
    Junior Member
    Join Date
    Jan 2005
    Posts
    7

    no good

    when i use kdm the screen goes blank and then comes back to a command line again, same when i do init 5.
    heres what i did originally, i was in KDE, and i selected the menu option to "change/configure desktop environment" or window manager, something to that effect, well, i changed it and restarted i cant remember what i set it to, but when i boot up, it just comes to a login in text mode.

  6. #6
    Member registered user
    Join Date
    Jan 2005
    Posts
    42

    Re: no good

    I have two more ideas:

    1) In '/etc/inittab' should be a line saying something like (I'm currently at a SuSE-Linux system):
    # The default runlevel is defined here
    id:5:initdefault:
    Check if this is set to runlevel 5.

    2) In your homedirectory should be a file named '.xinitrc' or '.xsession' (it depends on the distro which file is used). It should contain the following line:
    exec startkde
    But I'm not really sure if this will work. What does your /etc/X11/XF86Config-4 "Device" Section say?

  7. #7
    Junior Member
    Join Date
    Jan 2005
    Location
    Australia
    Posts
    4
    I probably can't help, I'm rather new to linux and very new to debian

    Are you getting a graphical login screen that won't login?

    I had a problem where the (default) login option (desktop/windowManager choice)
    wouldn't work, It just flickered straight back to the login screen, yet I could start a session textwise.
    Also 'startX' 'kdm' ,would not work for me - errors, or the flicker.
    However, when I changed the default choice, to any of the WindowManagers, it would login perfect!
    I havn't looked to see where/what the problem is, I just make sure that the WM is set to kde3 and all is graphic!
    As I said, hope it helps, it sounds as though you arn't even getting a graphic login.

    have a nice day


Similar Threads

  1. cant see the desktop
    By jader2toesbumpy in forum General Support
    Replies: 15
    Last Post: 07-27-2006, 12:43 AM
  2. no desktop gui?
    By UnLISTEDxX in forum MS Windows & New to Linux
    Replies: 2
    Last Post: 03-20-2006, 03:30 PM
  3. Want KDE desktop
    By fred0843 in forum General Support
    Replies: 2
    Last Post: 09-12-2005, 10:48 PM
  4. no kde desktop
    By jon267 in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 12-12-2004, 09:44 PM
  5. No desktop
    By Kevin in forum General Support
    Replies: 14
    Last Post: 08-14-2004, 07:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •