Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Woes Using CDs

  1. #1
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY, USA
    Posts
    1,256

    Woes Using CDs

    OK, I'm using KNOPPIX 3.7 on an hdinstall (via knoppix-installer). I've done so since KNOPPIX 3.3 without a hitch - until now.

    For example, in KNOPPIX 3.4 and 3.6 I could fire up K3B or KsCD without creating or mounting a device. K3B would just find my burner and work perfectly. KsCD would find my audio cd and play it fine. Now in KNOPPIX 3.7, K3B doesn't do this automagically and KsCD is MIA! So I tried creating cd devices and I never get the right format or some other kind of error.

    I never before had problems with CDs in KNOPPIX like this. What gives? Am I missing something? What can I do about this?

    Please help!

    Regards,
    AJG

    PS: I'm relegated to CLI cdrecord and no music....

  2. #2
    Senior Member registered user
    Join Date
    Feb 2005
    Location
    Colorado, USA
    Posts
    205
    Well, you might be getting old (I am ) but there's a seriously annoying bug with CDs in Knoppix 3.7's HD install. Ironic, isn't it? You can install from CD, but you can never use it again...!

    See these threads:

    http://www.knoppix.net/forum/viewtopic.php?t=13601 (no, it hasn't been fixed)

    http://www.knoppix.net/forum/viewtopic.php?t=17048

    The gist of it is, I believe, horribly hosed name assignments for the drive in both the device and mount-point areas.

    If the bug was fixed in 3.6, then it has come back, possibly due to trying to support both 3.4 and 3.6 kernels. (Kernel 3.6 is supposed to be free now of the need to use SCSI emulation for CD drives on an IDE bus, but I don't think Knoppix has implemented this. Not fully, anyhow.)

    If you can track down your problem with just these hints, good goin'! If not, post back and we'll work on it. (By the way, if you type

    $ dmesg

    you might see your drive called sr0, a naming convention that I believe confirms SCSI emulation. When I put sr0 in my /etc/fstab, it fixed my problem. Another guy's install looks like it's hosed worse than mine, though.

    -- Ed

  3. #3
    Senior Member registered user
    Join Date
    Feb 2005
    Location
    Colorado, USA
    Posts
    205
    3.4 and 3.6 kernels
    That is, 2.4 and 2.6. I don't think I'll live the 100 more years it'll take Debian to get to releasing 3.6!

    -- Ed

  4. #4
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY, USA
    Posts
    1,256
    Well, yes, but its not Debian's release, its the Linux Kernel 2.4 or 2.6!

    BTW, I did all that was suggested in those threads and MAKEDEV didn't do anything....

    Regards,
    AJG

  5. #5
    Senior Member registered user
    Join Date
    Feb 2005
    Location
    Colorado, USA
    Posts
    205
    Hello again!

    No, you don't need MAKEDEV (which uses mknod); Linux has already created plenty of devices for you in /dev. You just need to gather four pieces of setup information and then make three changes.

    Step 1

    The first thing you want to know is what Linux called your CD-ROM drive while it was booting up:

    $ dmesg | grep CD

    This plays back the startup messages and then sends them through grep, looking for lines that contain "CD". The line you're interested in reads something like this:

    Attached scsi CD-ROM sr0 at scsi0 ... etc.

    So the first piece of information is sr0, or whatever you got.

    Step 2

    Now you want to know what Linux did with that name, so find its entry in the device directory using the list command, long format:

    $ ls -l /dev/sr0

    (Not just sr0, but /dev/sr0)

    You'll get one of two kinds of responses, either

    lrwxrwxrwx ...etc. ... /dev/sr0

    or else

    lrwxrwxrwx ... etc. ... /dev/sr0 -> scd0

    The first kind of result says /dev/sr0 is a device in itself; the second says that Linux recognizes the name /dev/sr0, but it's an alias for the real device /dev/scd0. (But don't call it an alias, say that it's symlinked - symbolically linked - to scd0.)

    Linux sometimes uses the sr* naming convention when SCSI emulation is used for consumer CD-ROM drives that are attached to the computer the same way an IDE hard drive is. The scd* is for SCSI drives.

    So the second piece of information is whatever is at the far right end of that line, either /dev/sr0 or /dev/scsd0. (Notice that the result you got may only say scd0, but you have to use the full reference /dev/scd0.)

    Now that you have this, you can toss out the first bit of info.

    Step 3

    For the third piece of the puzzle you want to know what KDE calls your CD drive. Go to the desktop and hover your mouse over the CD-ROM icon. In the pop-up box the last line will say something like

    Link To: /mnt/cdrom

    It's common to use mount points in the /mnt directory, but Debian has a tendency to put them up in the root directory, where you'll see /cdrom, /floppy, /vmlinuz....

    Step 4

    Now you're ready to make some changes using your favorite text editor. You need to edit /etc/fstab as root, so either su and then edit, or type sudo and the edit command on one line.

    There's a lilne near the top that reads something like

    /dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0

    There are three problems here. In the first field, /dev/cdrom won't match what you found in Step 2. In the second field, /cdrom won't match what you found in Step 3. And then the option noauto means the CD drive isn't mounted when you boot, so nothing happens when you click on the desktop icon until you manually mount the drive.

    You are absolutely free to resolve these issues however you like. I want the drive automatically mounted, and I think that all of the symlinks strewn about that refer to the same drive are a mess.

    (As a matter of fact, when Knoppix set up my system, the mount point /mnt/cdrom was symlinked to /mnt/auto/cdrom, which doesn't even exist. It was quite a merry chase digging to the bottom of all this.)

    To make the three needed changes all in one place, I could edit /etc/fstab like this:

    /dev/scd0 /mnt/cdrom iso9660 defaults,ro,user,noexec 0 0

    The first entry could be sr0 or scd0 - either will work since they're already linked. But to avoid symlink hell, I made it the actual device.

    The second entry could be /cdrom (that is, no change from what Knoppix gave me), and then I'd edit the desktop icon (see Step 6).

    The third change was to delete ,noauto. But of course it's not required.

    Step 5

    When you're done editing, mount the CD drive to make sure it works. If you've removed noauto you can just type (still as root, or sudo):

    # mount -a

    The -a option goes through /etc/fstab and mounts what can be automatically mounted. Otherwise this should do it:

    # mount /dev/scd0 /mnt/cdrom

    Linux should autodetect the file type for the drive. If not, the answer is:

    # mount -t iso9660 /dev/scd0 /mnt/cdrom

    An error saying there's no media in the drive counts as success.

    If you made three changes to /etc/fstab, you should be done at this point. Clicking on the desktop icon should show you the contents of a CD in the drive. If you made only the first and third changes, there's one more thing to do.

    Step 6

    If you didn't change the /etc/fstab entry from /cdrom to /mnt/cdrom (or whatever the mount points are that you've uncovered), then make one final change - this time to the desktop icon.

    Right click on the icon and choose Properties. Click on the URL tab, and change what's there to match what's in your /etc/fstab.

    This should do it. If not, write back!

    -- Ed

  6. #6
    Senior Member registered user
    Join Date
    Feb 2005
    Location
    Colorado, USA
    Posts
    205
    Well, yes, but its not Debian's release, its the Linux Kernel 2.4 or 2.6!
    True ... and then again, not true.

    To your computer, there are three kinds of kernels: those that Mr. Torvalds and friends work on so tirelessly for our benefit, those that ship with your favorite distro, and whatever's running on your machine after you've (optionally) tweaked and tuned it.

    I'm not talking about just version numbers, but the fact that often the distro's kernel has already been poked and prodded before it's packaged for you.

    Sometimes they'll flag that in the name. Looking around on my machines just now I find:
    • vmlinuz-ide-2.4.28 - Slackware
      vmlinuz-2.6.9 - Knoppix & Morphix
      vmlinuz-2.6.8-1-386 - Debian sarge
      vmlinuz-2.6.9-1.667asp - ASPLinux
      vmlinuz-2.4.22-1.2188-nptl - Fedora Core
    Some distros emphasize that they've been tuned for modern processors (i686 architecture). I think Debian will still be supporting i386 long past the time that we all have implants under our skulls running the i1086 dekiums!

    Okay, I made that up.

    For sure you don't want to just plop a new kernel from kernel.org into a distro-based system. What they have are Type 1 kernels, clean and pure.

    It's best to get your kernel upgrades from the distributor of what you're running, and then re-tune as much as you like. Unless you've built, say, Linux From Scratch. Then you won't need my lame-o, fuddy-duddy advice.

    -- Ed

  7. #7
    Member registered user
    Join Date
    May 2004
    Posts
    45
    Excellent tutorial Mr Ed

    I do have one question for anyone out there that can help.

    I did find my CDROM is called "hdc". That seems curious. But, once mounted, I was able to correctly view a CD I plopped in there.
    Unfortunately, this didn't work for a music CD. I put in a music CD, mounted it and came out with this error:

    Code:
    mount: wrong fs type, bad option, bad superblock on /dev/hdc,
           missing codepage or other error
           In some cases useful info is found in syslog - try
           dmesg | tail  or so
    I take out the music CD and try to remount, successfully.

    Any ideas about playing music CD's?
    Oh!, I have Knoppix 3.9 installed on the hard drvie.

  8. #8
    Senior Member registered user
    Join Date
    May 2003
    Posts
    981
    Quote Originally Posted by ibrewale
    Excellent tutorial Mr Ed

    I do have one question for anyone out there that can help.

    I did find my CDROM is called "hdc". That seems curious. But, once mounted, I was able to correctly view a CD I plopped in there.
    Unfortunately, this didn't work for a music CD.

    ......(edited for brevity)

    Any ideas about playing music CD's?
    Oh!, I have Knoppix 3.9 installed on the hard drvie.
    You can only read music CD's using a media player. Try it with xmms.

    There is a built in media player for konqueror provided the proper plugins are installed; not sure if Knx 3.9 has them. It is called 'audio cd broowser', located under the services tab (bottom tab) on the navigation panel. Since you are hd installed, you can install the plugins if they are not already present.

  9. #9
    Junior Member
    Join Date
    Jun 2005
    Posts
    4
    To experiment with Linux I'm using a beginner install of the Knoppix CD 3.8.2 (kernel 2.6.11) to a reiserfs partition (/dev/uba4) on an external USBHD (non-bootable from my old BIOS). I use the pivot_root switch from the boot cdrom to the uba4 and I get the fully operational Debian-Knoppix OS. Problems come with recognizing and accessing the cdrom and a cdrw. I've ready many threads on the forum refer cdrom, in particular http://www.knoppix.net/forum/viewtopic.php?t=17177 and http://www.knoppix.net/forum/viewtop...t=17348.<br />
    Both drives are IDE on the second channel and now have the correct associations (as in fstab):
    /dev/hdc -> /mnt/cdrom /dev/hdd -> /mnt/cdrom1
    Following the referenced forum advice the cdrom1 now works as advertised.

    The physical eject button on cdrom is locked but the boot KnoppixCD can be removed using from root # eject (accompanied by some complaints). But if another CD is loaded into cdrom the physical eject button is again locked.

    With both drives empty from the root prompt I try:
    # umount /mnt/cdrom reports drive is busy
    # fuser -v /mnt/cdrom reports a mount /mnt/old_root/cdrom is active from the kernel
    # fuser -k mount /mnt/old_root/cdrom reports the process can not automatically be killed so use umount (back to above)
    # kill -9 mount /mnt/old_root/cdrom reports the process can not automatically be killed so use umount (back to above)

    It seems the pivot_root switch does not cleanly unmount the old Knoppix boot CD device and thus leaves a busy cdrom and associated difficulties with auto mount/unmount access and locks the drives eject button. Any suggestions on how to kill this 'mount /mnt/old_root/cdrom' process?

  10. #10
    Member registered user
    Join Date
    May 2004
    Posts
    45
    Quote Originally Posted by CrashedAgain

    You can only read music CD's using a media player. Try it with xmms.

    There is a built in media player for konqueror provided the proper plugins are installed; not sure if Knx 3.9 has them. It is called 'audio cd broowser', located under the services tab (bottom tab) on the navigation panel. Since you are hd installed, you can install the plugins if they are not already present.

    I have tried xmms, Kscd and K3b. I don't see audio cd browser in my 3.9 hdd install though.

    K3b 'sees' my cdrom if a data cd is in it, but does not recognize the cdrom if there is a music cd in it.

    xmms does not see /mnt/cdrom with a music cd in it, but does 'see' /mnt/cdrom with a data disc (but of course, no music on it).

    kscd errors out on startup up with cannot read cdrom drive / or no cdrom in drive.

    Also, i did see what I belive to be a symbolic link on the cdrom /mnt/cdrom --> /mnt/auto/cdrom

    I do find the data cd in K3b under /mnt/auto/cdrom (but no music cd)..

    Any hints, or pointers?

    Thanks

Page 1 of 2 12 LastLast

Similar Threads

  1. Wireless woes
    By marinebro0306 in forum Networking
    Replies: 1
    Last Post: 09-03-2006, 10:50 AM
  2. Wireless Woes...
    By jm47048 in forum Networking
    Replies: 6
    Last Post: 02-03-2006, 06:27 AM
  3. Installation Woes
    By fused in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 11-07-2005, 03:55 AM
  4. Apt-get woes
    By Shadda in forum Networking
    Replies: 1
    Last Post: 02-12-2005, 04:45 PM
  5. ssh woes!!!
    By A. Jorge Garcia in forum General Support
    Replies: 4
    Last Post: 11-22-2003, 01:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •