Results 1 to 3 of 3

Thread: fstab noauto --> auto??

  1. #1
    Junior Member
    Join Date
    Mar 2003
    Posts
    4

    fstab noauto --> auto??

    I installed Knoppix without using hdinstall but instead copied all CD's /KNOPPIX folders into one of my pre-made partitions. In this way when booting my HDD it boots same as the CD (starting with knoppix-autoconfig) and I get new hardwares auto installed.

    A new /ect/fstab file is created each time. How to change the fstab generated script to get an "auto" option instead of "noauto" for the partitions what are found?
    Code:
    # Added by KNOPPIX
    /dev/hda3 /mnt/hda3 ext3 noauto,users,exec 0 0
    It should be like this:
    /dev/hda3 /mnt/hda3 ext3 auto,users,exec 0 0

    The purpose is to get partition (hda3) auto mounted. I tried edit /etc/init.d/knoppix-autoconfig but didn't work. How about /etc/auto.mnt or auto.master?

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Posts
    872
    none of them can be changed. They are symbolic link to the compressed image which is read only. One possible way is you copy the file into the initroot.gz file system and modify the linuxrc on it to copy them back to /etc/rcS.d/S**(of course you have to remove the link in linuxrc first).

  3. #3
    Junior Member
    Join Date
    Mar 2003
    Posts
    4

    Re: fstab noauto --> auto??

    Quote Originally Posted by rasat
    I tried edit /etc/init.d/knoppix-autoconfig but didn't work.
    I took a second look at the knoppix-autoconfig and found the script installing "noauto" config.
    Code:
    # Normal partition
     if [ -z "$fnew" ]; then
     fnew="$p $d  auto   noauto,$options 0 0"
     anew="$d	-fstype=auto,$options	:$p"
     stringinfile "$fnew" "/etc/fstab" || echo "$fnew" >> /etc/fstab
    Changed the line to:
    Code:
    fnew="$p $d  auto   auto,$options 0 0"

Similar Threads

  1. Problem when moving New Fstab to the Old Fstab to fix Suse
    By cheetahman in forum General Support
    Replies: 19
    Last Post: 03-21-2005, 11:58 AM
  2. Why Knoppix is auto create the /etc/fstab in every boot ???
    By fowlertrainer in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 08-31-2004, 09:10 PM
  3. help me fix my fstab
    By DimGR in forum Hardware & Booting
    Replies: 8
    Last Post: 05-29-2004, 04:48 AM
  4. etc/fstab: what should be in it?
    By digiSal in forum Hdd Install / Debian / Apt
    Replies: 3
    Last Post: 12-19-2003, 04:41 PM
  5. auto: auto: no such file or directory
    By maddany in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 04-16-2003, 02:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •