Laptop: Presario 2500
Boot loader: GRUB on USB Lexar 128mb Jumpdrive
OS:Knoppix 2.4.27 on USB connected 4gig ipod mini (green in colour )
Knowledge: Newbie to Can do some basic stuff

Ok my problems is that i can't see my ipod when grub boots up

my device.map in grub is
(hd0) /dev/sda

my menu.lst looks like this

title=Knoppix 3.7 (kernel 2.4.27)
root (hd0,0)
kernel /boot/vmlinuz-2.4.27 root=/dev/sda
initrd /boot/initrd.img-2.4.27

Ok now grub loads up npz runs it's mary way then i get

VFS:Mounted root (ext2 file system).
attempt to access beyond end of device
01:00: rw=0, want=16388, limit=4096
Ext2-fs error (device ramdisk (1,0)) : ext2_read_inode: unable to read inode block
-inode=2786, block=16387
attempt to access beyond end of device
01:00 : rw=0, want=8198, limit=4096
kmod failed to exec /sbin/modprobe -s -k block-major-8, errno=2
VFS: Cannot open root device "sda" or 08:00
please append a correct "root=" boot option
Kernel panic : VFS : unable to mount root fs on 08:00

Ok so now i'm stuck ...What have done wrong ....is there something i'm missing
I have tried a few root=/dev/sdb, sda1, sdb1 etc with no success i have even tried root=/mnt/sda etc (not really sure if i was allowed to hehehe)
I know the usb drives are in the 2.4.27 kernel ( please correct me if i'm wrong ) and are loaded up from the grub loader ?!
so i'm a little lost

Any help would be great