Results 1 to 3 of 3

Thread: HDD Install won´t boot (Grub in root partition:-( )

  1. #1
    Junior Member
    Join Date
    Jun 2005
    Location
    Germany
    Posts
    2

    HDD Install won´t boot (Grub in root partition:-( )

    Hi,

    I installed Knoppix 3.9 on hda3 in the "Beginner"-Mode (i think). I decided not to install Grub in the mbr, because i was afraid of losing my Win XP-Installation. "Grub-MBR-Install" sounds really dangerous...

    Is there any way to install Grub to the mbr yet? Or do i have to run the whole install-script again?




    weirdjd

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY USA
    Posts
    1,510
    A HD install of Knoppix is not recommended as it is not easy to support if you are not an expert or do not want to become an expert. See http://www.knoppix.net/wiki/Hd_Install_HowTo

    I assume that your C: drive is partition hda1 & your Linux install partition is hda2 is using the ext3fs filesystem.
    Boot the Knoppix 3.9 CD. In a konsole window, at the command prompt, mount the hda2 partition.
    sudo mount -t ext3 /dev/hda2 /mnt/hda2
    Then you must check to see if the grub boot menu exists.
    sudo kate /mnt/hda2/boot/grub/menu.lst

    If it doesn't, well it is probably easier to run through the whole install again. If it does exist then you can proceed. You will chroot into the /mnt/hda2.
    sudo chroot /mnt/hda2/ /bin/bash

    If that is successful then then run grub-install & apply grub to the MBR.
    grub-installer /dev/hda

    If that is successful, type exit:
    exit

    Then unmount the /mnt/hda2.
    sudo umount /mnt/hda2

    Then reboot knoppix via the GUI or with the command:
    sudo init 6

    if you have any problems with this, then please leave detailed info & questions.
    I hope this helps.
    James

  3. #3
    Junior Member
    Join Date
    Jun 2005
    Location
    Germany
    Posts
    2

    thanx

    I know, I know... it's a live-cd. I thought i could speed it up a little.
    I tried the persitent-image-thing - and it works. Thats enough for the moment. I will try to install a real Debian during the semester break.

    Thanks anyway.

    weirdjd

Similar Threads

  1. partition number changed grub install problem
    By ramaswamyps in forum Hdd Install / Debian / Apt
    Replies: 8
    Last Post: 03-15-2006, 07:40 PM
  2. grub boot loader read the boot file from a windows partition
    By cli168 in forum Hdd Install / Debian / Apt
    Replies: 3
    Last Post: 06-20-2005, 03:57 AM
  3. V3.6 fails to install into root partition
    By markb in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 09-19-2004, 03:37 AM
  4. Master boot record or Root partition?
    By xaviers2002 in forum Hdd Install / Debian / Apt
    Replies: 5
    Last Post: 07-04-2004, 08:13 PM
  5. Using Grub in multi-OS with /boot partition
    By nuke in forum Hdd Install / Debian / Apt
    Replies: 7
    Last Post: 10-09-2003, 03:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •