Results 1 to 6 of 6

Thread: MESS

  1. #1
    Junior Member
    Join Date
    Jul 2005
    Posts
    8

    MESS

    Im not sure if this is the place to post. I had knoppix 3.8 live cd and was trying to install it onto my hard drive. I made a linux-swap partition using the qtparted v0.4.4. The linux-swap partition is about 500mb and the rest is windows NTFS partition. Theres no more space on my drive to creat a second root partition for linux. When I try to delete the linux-swap partition I get the error "The partition is mounted", so I tryd to boot back into windows and get a blue screen with the error 0X000000ED (0X8172D030, 0X000014F, 0X00000000, 0X00000000) . So.... I put the windows installation disk in tryd to run chkdsk /r and fixboot in the command prompt and it wont let me it states another error wich I cant remember. Back in qtparted it says that the linux-swap partition is busy?!

    Any one have any suggestions at all???

    Any help would be appretiated, thank you. Razta

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY USA
    Posts
    1,510
    Knoppix boots with a splash screen. At that splash screen you can enter codes which will force Knoppix to do certain things. Theses codes are known as Cheat Codes. You will need to use:
    knoppix noswap
    It will disable swap partition so you can remove it.

  3. #3
    Junior Member
    Join Date
    Jul 2005
    Posts
    8

    Thank you!

    Ive read the link to the cheat codes found it very usefull. Just posting this to say thank you and to let others know my progress incase any one ells is as dumb as me.

    I havent tried the codes yet because im still at work but here they are:

    knoppix noswap (if you get an error try)

    knoppix mem128M (capitol M)

    Ive also been told to try

    umount/mntswap


    Thanks again will keep you all posted.

  4. #4
    Junior Member
    Join Date
    Jul 2005
    Posts
    8

    umount/mnt/swap

    the last code is

    umount/mnt/swap

    not

    umount/mntswap

  5. #5
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY USA
    Posts
    1,510
    that umount/mntswap
    might not work

    To disable swap from a currently running system, the command:
    sudo swapoff -a

  6. #6
    Junior Member
    Join Date
    Jul 2005
    Posts
    8

    Thank you!!!

    Got home run knoopix.

    Typed "knoppix noswap" on the splash screen

    Run qtparted by typing "knx2hd"

    Deleted the linux-swap partition.

    Comitted it.

    Rebooted.

    Tadaaa..... WINDOWS!!!

    Thank you for your help!

    I ow you one!

Similar Threads

  1. nvidia driver mess up display at logout
    By parj in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 08-23-2006, 08:57 PM
  2. Wireless mess! help please :(
    By cheti12 in forum Networking
    Replies: 0
    Last Post: 03-20-2006, 07:22 PM
  3. why does hard drive install mess up tomsrtbt floppy?
    By db109 in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 05-27-2005, 04:03 AM
  4. Trying to fix Win XP Home mess w/NTFS write access (long)
    By frugalyankee in forum MS Windows & New to Linux
    Replies: 2
    Last Post: 02-09-2005, 03:48 AM
  5. NVIDIA installer mess with gcc
    By athlonthunder in forum General Support
    Replies: 1
    Last Post: 04-03-2003, 05:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •