Page 1 of 7 123 ... LastLast
Results 1 to 10 of 63

Thread: Knoppix using NatSemi DP83815 stopped working

  1. #1
    Harry Kuhman
    Guest

    Knoppix using NatSemi DP83815 stopped working

    I'm running Knoppix on an HP Ze4240 notebook that uses the Nat. Semi. DP83815 chip for it's internal nic. For several weeks I used Version 3.1 of Knoppix and it worked fine, total connections to the rest of my local network through a Linksys DSl router and on to the Internet. However, something has happened and Knoppix no longer works. I can't connect with Knoppix 3.2 and I can't even connect any more with the 3.1 CD! However WinXP uses the same hardware and connects just fine if I boot from hard drive rather than the Knoppix CD.

    Knoppix isn't getting a DHCP setup. If I manually configure the card I can see it in ifconfig, but I see a TX error and a "carrier" error for every packet sent. I have also been able to determine that the nic is receiving packets just fine, but it is not really sending anything (confirmed by adding a hub and sniffing the wire with another system). I've changed the obvious things like cables and remote systems, and am 100% convinved that something in the notebook has changed in a way that is affecting Knoppix.

    Clearly the Knoppix CD didn't change and the hardware still works with WinXP, but something is wrong. Maybe I'm on a wrong path here, but I learned that the DP83815 chip has EEPROM configuration memory and suspect that something has made a change to it that is breaking the Linux driver (actually, I suspect that it was a Windows "security update" that broke the system for Linux but so far can't confirm that).

    HP has been useless on this. Their "support" people will not try to track down the original configuration settings for the DP83815 chip and simply respond that that information is "not available".

    Which leads me here. I'm hoping that someone might have more insight into this problem, that someone might know something about the DP83815 driver in Linux and can help determine what needs to be done to get Linux talking through the nic again (I'm guessing it's as simple as a setting that is assumed to be right but could be set in software initalization), and how we can progress to get that done, tested and put back into the distribution.

    I've technical, but very green to Linux and Knoppix (just starting using Knoppix as a way to get comfortable with Linux before I take windows off the hard drive or restrict it to a small partition). Any suggestions to next steps to take, or the right usenet group(s) to take this to would be extremely welcome.

    Also, if anyone can determine what a working EEPROM configuration for a DP83815 eeprom is under knoppix, I would be extremely interested in those eeprom values.
    Or if anyone has a contact in HP that might lead to someone in notebook engineering that could locate the configuration information, this would be extremely helpful.

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    Posts
    1,353

    Re: Knoppix using NatSemi DP83815 stopped working

    Quote Originally Posted by Harry Kuhman
    I can't even connect any more with the 3.1 CD!
    This is quite strange. Are you using the sam 3.1 CD that worked previously for you? And it still doesn't work? Since XP works fine and since you checked all your cables and connections, it surely does look like a hardware problem. I'm not sure how a XP update could cause anything like this, but I sure would be interested in hearing more about what you find out.

    Another chanel of support you might try is irc.

    irc.knoppix.net
    /join #knoppix

    Frankly I'm miffed. Do you have another NIC you could try?

  3. #3
    Harry K
    Guest

    yes, same CD that used to work now fails

    Yup, I thought I made it clear, the same Knoppix CD that used to work now fails to transmit on the network on that computer that did work, even though WinXP can talk to the network just fine on that computer. CD works fine on other computers with different NIC chips. Knoppix 3.2 also fails, but I don't know for sure if that version ever did talk on the network OK. I'm pretty sure it did, but not 100% certain.

    Since the National Semiconductor chip has EEPROM configuration info on it, a WinXP update (or perhaps something else) could indeed change the default configuration of this chip. If WinXp then over rides the default configuration at start-up but the Linux driver trusts the settings and does not override them, then WinXP works and Linux fails. Not that Micro$oft would ever do something like this deliberately, they are to nice and decent and honest of people for that .......

    The NIC is built into the notebook, so can't just pop in a different one. Thought I had a D-link usb to ethernet adapter that I could use (although it would be slower). I plugged it in and Knoppix does indeed recognize it and use it, but it's apparently flakey, it dies after a few minutes. It also behaves this way under WinXP. I still need to confirm it fails on another computer, but it's not going to be an option. Have lots of normal nic cards around, but that's not going to help with a notebook.

    I'm not an IRC user; don't think this is the right time to pick up a new vice. Is it really likely to get me to the right technical people that might help with this?

  4. #4
    Senior Member registered user
    Join Date
    Nov 2002
    Posts
    1,353
    Harry,

    What you are describing is really quite disturbing. If this is indeed the case then MS can just hang on to their trustworthy computing. I want nothing of it.

    The more important question is how do you get help. I'm sorry I didn't notice that you are dealing with a notebook. Clearly slaping in another pci nic card isn't an option. I can also understand why you are not too excited about the usb option. Since your diagnosis of the problem indicates that that the ROM on the card itself has been updated, I'm not sure whether an XP reinstall (painful!) would help though perhaps it would put things back the way they were.

    I found this page listing your card: http://www.national.com/pf/DP/DP83815.html

    And then this page listing NS tech support:
    http://www.national.com/support/dir.html

    My suggestion is to try contacting their tech support and see if they know anything about this. The give a phone number and also give e-mail as a support option.

    Man I really feel for you brother this is just plain wrong!

  5. #5
    Harry J. Kuhman
    Guest

    Thanks for the feedback.

    Yes, it is pretty disturbing. I'm certainly not sure that it has anything to do with the M "security updates", but it happened about the same time I finally was willing to download then in the new WinXP machine (which had run Knoppix fine for about 3-4 weeks without them), That's far from a cause and effct proof, but it would not be the first case of M$ doing things to their software to hurt other software writers that they took a dislike to, and Linux is high on their emeny list now. I'm still trying to gather information, thus the post.

    I already had the pdf manual for the chip you pointed me to; it's quite extensive, but I'm making very slow progress with it. Don't know if it will be enough to solve the puzzle though. I hadn't thought of asking N.S. support about the configuration, but it's certainly an idea. I only went to HP support when I had figured out exactly the information that I needed, but their "technical support" people as taking a strong stance that it's completely imposiable for them to get the information that must exist within HP on how this nic is factory configured. I'm also working with other tools, including mii-diag, and will see what else I can come up with over the weekend. Maybe if I get a little more background over the weekend on the chip but still can't resolve anything I'll give NS a call next week. But honestly, I have the full specs for the chip in front of me. They are not likely to be able to tell me what options HP used in configuribg it, and the current configuration does work under WinXP, so they are not likely to find something extremely wrong with it. I don;t have high hopes that they will even want to help me, or if they do they will be able to do much.

    All feedback on this issue is still requested from this forum.

  6. #6
    Senior Member registered user
    Join Date
    Nov 2002
    Posts
    1,353

    Re: Thanks for the feedback.

    Quote Originally Posted by Harry J. Kuhman
    I don;t have high hopes that they will even want to help me, or if they do they will be able to do much.
    Sad but true. Don't let this discouage you from your move toward linux. I haven't really heard of anything like this before (at least on this list) so let's hope it's an isolated incident. Keep us posted.

  7. #7
    Senior Member registered user
    Join Date
    Nov 2002
    Posts
    1,353
    One more thing...per previous irc advice... don't be afraid to visit the irc channel. I've learned a lot there. People in there are pretty curteous. It's a very good place to get help even if it's not on this issue.

  8. #8
    guest
    Guest

    dsl router/modem might be caching IP

    You might just try turning everything off for 5 minutes - router, modem, laptop, etc. then start you router/modem then laptop. The router might be caching IP info.

  9. #9
    Administrator Site Admin-
    Join Date
    Apr 2003
    Location
    USA
    Posts
    5,441
    You might just try turning everything off for 5 minutes
    From what I previously posted I would have thought no one could come up with as lame of a "suggestion" as this. Sorry if that's insulting, but please reread all of the details that I first posted.

    I do have new information, which greatly reinforces what I previously suspected. I've downloaded, compiler and run mii-diag and it reports some very strange configuration information: mii-diag reports that the card is currently set for 100baseTX in one line, and that it is set at 10BaseT in another! It also says Autro-negotiation is disabled. I know it was enabled before and negoiated properly both 100 megabit and 10 megabit connection, depending on if I connected directly into my Linksys at 100 or into a 3com hub at 10, so my theory that the configuration information for the DS83815 chip has changed is reinforced. mii-diag also reports "Internal Collision-Test enabled!" (exclaimation mark theirs), which I haven't figured out the meaning of.

    However, I now can make the system work! I need to use 2 commands that I did not have to use previously: I need to do a "sudo mii-tool -r" to restart autonegotiation, and then I need to do a netcardconfig, and I'm able to talk to the network and Internet again.

    So I believe this confirms that something has changed the default settings for the DP83815, and I strongly suspect that this is an organization out to harm Linux and promoting their own "Trusted Computing", which just happens to do things to your system when you load the security updates that keeps Linux from connection to the network.

    I don't yet know how I can prove this until I can determine what to reset the eeprom to, once I do that I can revert to the recovery disks and then monitor the chip closely as I accept the security updates again. Any help getting these original settings (or finding someone at HP that is actually helpful and cares about their customers) would be very welcome.

    Alternately, any feedback from others seeing this problem, particularly if they use both WinXP and Linux on the same computer, would be helpful. And suggestions of other forums, particularly the correct usenet forumn to take what I know so far, would be welcome.

  10. #10
    Junior Member registered user
    Join Date
    Apr 2003
    Posts
    15
    Hi,
    I'm not at all technical. But there are a lot of echoes for me in your experience. I read your post after posting to this forum myself. But to recap - last week, I downloaded Knoppix 3.2 on a Windows XP system, was pleasantly surprised that it all just worked, and I connected to the internet fine via an ethernet card and cable modem. Since then, I have accepted Windows XP security updates (not had XP on here long). And on Saturday the same knoppix cd booted but would not connect to the net. For a non technical person, can you spell out how you got connected again (or point me to a forum where I could learn)? Also, if there is any information I can give that would help you prove your hypothesis, let me know.

    Steve.

Page 1 of 7 123 ... LastLast

Similar Threads

  1. Mouse stopped working in kernel 2.4, still works in 2.6
    By Leander in forum Hardware & Booting
    Replies: 5
    Last Post: 01-23-2005, 02:50 PM
  2. Autoconfig stopped working on HDD install.
    By rbivins in forum Hardware & Booting
    Replies: 10
    Last Post: 11-10-2004, 07:43 PM
  3. Replies: 1
    Last Post: 10-01-2004, 11:20 AM
  4. Printing stopped working
    By rec9140 in forum General Support
    Replies: 0
    Last Post: 11-12-2003, 06:59 PM
  5. Internet connection stopped working
    By jimk in forum Networking
    Replies: 7
    Last Post: 10-21-2003, 11:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •