Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Preempt kernel, anyone?

  1. #11
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272

    Re: Preempt kernel, anyone?

    Quote Originally Posted by seskanda
    Yes, i want to install realtime preemption to my Knoppix Debian-based HD installation. How would i install the preempt patched kernel and have the option of choosing BOTH the original kernel and preemptive one at the grub boot loader? Although, as i posted above, i might already have a realtime preempt kernel, since 'uname -a' says PREEMPT. How can i confirm if the kernel has realtime preemption applied to it?
    Your GRUB should add new kernels automatically to /boot/grub/menu.lst file. If not, you can add new kernel by editing file yourself.

    Realtime preemption is not included in the vanilla kernel. If you have CONFIG_PREEMPT=y in your .config file (what you see with 'uname -a'), that don't mean you have realtime preempt kernel. There's many changes in configuration if using -rt patch e.g. CONFIG_PREEMPT_RT=y which option you don't even have in vanilla kernel. But anyhow, CONFIG_PREEMPT=y is better than CONFIG_PREEMPT_VOLUNTARY=y in kernel configuration.


    -tapsa-

  2. #12
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272
    Perhaps you like my new kernel http://linux.ilmainen.net/suomiknopp...ux-2.6.23-rt1/.

    -tapsa-

  3. #13
    Junior Member registered user
    Join Date
    Mar 2007
    Posts
    11

    Re: Preempt kernel, anyone?

    Quote Originally Posted by tr
    Your GRUB should add new kernels automatically to /boot/grub/menu.lst file. If not, you can add new kernel by editing file yourself.
    That's good to know.


    Quote Originally Posted by tr
    Realtime preemption is not included in the vanilla kernel. If you have CONFIG_PREEMPT=y in your .config file (what you see with 'uname -a'), that don't mean you have realtime preempt kernel. There's many changes in configuration if using -rt patch e.g. CONFIG_PREEMPT_RT=y which option you don't even have in vanilla kernel. But anyhow, CONFIG_PREEMPT=y is better than CONFIG_PREEMPT_VOLUNTARY=y in kernel configuration.
    Where is .config file? I can only find a .config folder. I think your right, though. I ran Rosegarden and get "System resolution is too low." So, that must mean my kernel is NOT real-time preemptive. Now, all i need to know is HOW to re-compile it....I found a couple of guides, but they differ a bit. Here is the first one, and this is the second one. Which is easier to follow? Or do you know of a better link? Does yours or another realtime preempt kernel solve the 'System Timer' problem in Rosegarden, too?

  4. #14
    Junior Member registered user
    Join Date
    Mar 2007
    Posts
    11
    I decided to use a pre-compiled kernel, and installed 2.6.19-1-multimedia from this FTP site of Musix, a multimedia Linux distro based on Knoppix. Now, i have two serious problems when i boot from the new kernel. First, i can NOT open a shell as root or a user, Konsole gives me this error:

    "Konsole is unable to open a PTY (pseudo teletype). This is likely due to an incorrect configuration of the PTY devices. Konsole needs to have read/write access to the PTY devices."

    What does this mean and how do i fix it? Second, i can NOT get root access as a user, after i enter the root password, i get this error:

    "The program 'su' is not found; make sure your PATH is set correctly."

    What's wrong? I even installed two other kernels, one from the FTP site of Musix and one from your site, BOTH were version 2.6.21.5-rt18, but i STILL had the above two problems. I noticed whenever any of three kernels installed, i received this error:

    "Hmm. There is a symbolic link /lib/modules/(version of kernel)
    However, i can't read it: No such file or directory
    Therefore, i am deleting /lib.modules/(version of kernel)"

    Could this be the cause? Also, during bootup, instead of '...done' appearing when 'Waiting for /dev to be fully populated' comes up i get 'iTCO_wdt: Failed to reset NO_REBOOT flag, reboot disabled by hardware' followed by 'intel_rng: FWH not detected.' Is there anything i can do?

  5. #15
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272
    Quote Originally Posted by seskanda
    I decided to use a pre-compiled kernel, and installed 2.6.19-1-multimedia from this FTP site of Musix, a multimedia Linux distro based on Knoppix. Now, i have two serious problems when i boot from the new kernel. First, i can NOT open a shell as root or a user, Konsole gives me this error:

    "Konsole is unable to open a PTY (pseudo teletype). This is likely due to an incorrect configuration of the PTY devices. Konsole needs to have read/write access to the PTY devices."
    I think something has gone wrong with your kernel installation. Did you install it by 'dpkg -i linux-image*'? To correct your pty problem. add following line to /etc/fstab (it exists on Knoppix live CD but sometimes not after hd installation):
    Code:
    /dev/pts   /dev/pts    devpts mode=0622           0 0
    I know Musix because they use my kernels on live CD, see http://www.musix.org.ar/wordpress/?p=70
    They are just testing http://linux.ilmainen.net/suomiknopp...ux-2.6.23-rt1/ kernel. I think you can use it safely.

    -tapsa-

  6. #16
    Junior Member registered user
    Join Date
    Mar 2007
    Posts
    11
    I did use dpkg -i to install the kernel, but, NO, i didn't use linux-image in the name, because i simply renamed the long filename to 'linux.deb.' Next time i install it again, i'll just type the whole, long title itself. Thanks a lot. I just copied what you wrote to the end of the etc/fstab file, rebooted, and that was all; it fixed everything. Oddly, though, i still receive the same error messages during bootup. And I still have a minor problem. Boot time with the new 2.6.19-1-multimedia is slightly slower than the default. This is due to the fact of some additional errors (they were here before, too) which pop up. They actually come up twice. First, after the previous errors, and then again, toward the end, followed by "System is setting clock again." Strangely, i seem to have NO problems with clock settings, at all. Here, are the error messages:

    locale: cannot set LC_CTYPE to default locale: No such file or directory
    locale: cannot set LC_MESSAGES to default locale: No such file or directory
    locale: cannot set LC_ALL to default locale: No such file or directory

    Any idea what these mean? Do you think i'm better off installing the kernel, again? (of course, with 'linux-image' in the title).

  7. #17
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272
    Quote Originally Posted by seskanda
    locale: cannot set LC_CTYPE to default locale: No such file or directory
    locale: cannot set LC_MESSAGES to default locale: No such file or directory
    locale: cannot set LC_ALL to default locale: No such file or directory

    Any idea what these mean? Do you think i'm better off installing the kernel, again? (of course, with 'linux-image' in the title).
    Try to configure locales by
    Code:
    dpkg-reconfigure locales
    Try this
    Code:
    dpkg -l | grep linux-image
    if it shows 'ii' (not 'hi' = half installed) and you see your kernel there in the list, kernel is installed ok. Of course you can install it safely again if you want. It works after rebooting system.

    But take a look at your /boot/grub/menu.lst file. Sometimes Grub makes an error if using hd installed Knoppix by using 'rw' instead of 'ro'. Change that if it is the case.

    Btw, that multimedia kernel is not my kernel. But kernel that boots Musix is what I have compiled. I think new Musix-DVD is going to boot with 2.6.23.1 kernel and have also that 2.6.23.1-rt1 realtime preempt kernel

    Cheers

    -tapsa-

  8. #18
    Junior Member registered user
    Join Date
    Mar 2007
    Posts
    11
    Quote Originally Posted by tr
    Try to configure locales by
    Code:
    dpkg-reconfigure locales
    I don't understand the first screen that comes up. Am i supposed to select ONLY English/US languages? Those would start with "en" and/or "us", right?

    Try this
    Code:
    dpkg -l | grep linux-image
    if it shows 'ii' (not 'hi' = half installed) and you see your kernel there in the list, kernel is installed ok. Of course you can install it safely again if you want. It works after rebooting system.
    Everything looks fine. Here's the output (for the 2.6.19-1 multimedia kernel only):

    ii linux-image-2.6.19-multimedia-486 2.6.19-1 experimental.1 Linux 2.6.19 image on486 class

    But take a look at your /boot/grub/menu.lst file. Sometimes Grub makes an error if using hd installed Knoppix by using 'rw' instead of 'ro'. Change that if it is the case.
    Where inside that file should i look?

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Errors and kernel panic during boot (2.6 Kernel)
    By gitarzysta in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 06-03-2004, 08:36 PM
  2. Kernel Source 2.4.23-xfs and Kernel install for wlan-ng
    By Nils_ in forum Hardware & Booting
    Replies: 0
    Last Post: 03-08-2004, 10:50 AM
  3. Kernel Build with kernel-source-2.4.20-xfs:
    By TheCyberDude in forum Tips and Tricks
    Replies: 3
    Last Post: 09-03-2003, 03:10 PM
  4. kernel panic with custom kernel
    By cYmen in forum Customising & Remastering
    Replies: 0
    Last Post: 07-14-2003, 10:17 AM
  5. Modified kernel results in Kernel Panic - No init found.
    By tji in forum Customising & Remastering
    Replies: 4
    Last Post: 06-12-2003, 06:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •