Results 1 to 3 of 3

Thread: Modem problems

  1. #1
    Junior Member
    Join Date
    Nov 2002
    Posts
    3

    Modem problems

    Hey everyone, I got Knoppix installed on my HD and everything looks great with one exception, I can't use my modem. Have to go back to Bill Gates to get online, ycccck. The modem that I have is an internal ActionTec on com 2, it is a winmodem but it is supported. I got the driver ltmodem-2.4.18_8.00a3_i386.deb. I ran uname -r in a terminal to get the kernal version of my Knoppix install and it shows me 2.4.19 and have been unable to locate a driver for that version. The modem show busy everytime I run KPPP to try and log on. I was wondering if this is caused by the driver not being the correct version? Or is there another issue that I am overlooking. I am still a newbie when it comes to Linux and don't really have the time to devote to a full blown study to learn this system right now. Guess it will take me a while. I am very pleased with it I must admit if I could just get past this modem problem, or should I say my problem, mental blackout. I tried DemoLinux 3.00 and I can access my modem with it, the kernal version of that, i.e. Demolinux is 2.4.18 which is why I wonder if this is caused by the kernal version. Would it help if I recompiled the kernal? (another learning experience) I am willing to try if necessary. I will say that I feel Knoppix is a better demo than demolinux and that is why I used it to install to my HD. I greatly appreciate any help I can get with this. Thanks before hand.

    Here is additional information that may be helpful

    logged in as root, ran "lspci -vv" result for Comm controller below

    00:09.0 Communication controller: Lucent Microelectronics 56k WinModem (rev 01)
    Subsystem: Lucent Microelectronics LT WinModem 56k Data+Fax+Voice+Dsvd
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Step
    ping- SERR- FastB2B-
    Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort
    - <MAbort- >SERR- <PERR-
    Latency: 0 (63000ns min, 3500ns max)
    Interrupt: pin A routed to IRQ 11
    Region 0: Memory at d7009000 (32-bit, non-prefetchable) [size=256]
    Region 1: I/O ports at e800 [size=8]
    Region 2: I/O ports at ec00 [size=256]
    Capabilities: [f8] Power Management version 2
    Flags: PMEClk- DSI+ D1- D2+ AuxCurrent=0mA PME(D0-,D1-,D2+,D3hot
    +,D3cold+)
    Status: D0 PME-Enable- DSel=0 DScale=0 PME-

    Could it be a problem with the Interrupt, pin A routed to IRQ 11, shouldn't it be using IRQ 3? If so will I have to remove board and change jumpers?
    It puzzles me though as I stated above Demolinux 3.0 has no problem using this modem as it is.

  2. #2
    Guest

    similar

    I have a similar LT modem, which I had working under a SuSE distro so it is supported.

    I don't want to install KNOPPIX, I want it to boot it on a CD. If I do, I can't use the modem. Anyone solved this problem?

  3. #3
    Junior Member
    Join Date
    Nov 2002
    Posts
    3

    Re: similar

    Quote Originally Posted by Anonymous
    I have a similar LT modem, which I had working under a SuSE distro so it is supported.
    Yes I had the same deal, the modem wouldn't work when running from the CD either. I thought I could correct it after installing. Hmmm, I like Knoppix, but if I can't get this problem resolved I will use a different distro that I can get to work.

Similar Threads

  1. Modem Configuration Problems
    By Kowood in forum General Support
    Replies: 2
    Last Post: 07-30-2004, 01:18 PM
  2. Serial Modem Problems
    By raysr in forum Networking
    Replies: 2
    Last Post: 04-18-2004, 02:44 PM
  3. problems with modem
    By coastie in forum Hardware & Booting
    Replies: 12
    Last Post: 04-16-2004, 09:06 PM
  4. Newbie Modem problems...
    By Rorypyro in forum Hardware & Booting
    Replies: 1
    Last Post: 07-16-2003, 10:53 PM
  5. problems with 56k modem
    By starsoldier in forum Hardware & Booting
    Replies: 1
    Last Post: 03-06-2003, 05:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •