Results 1 to 9 of 9

Thread: how to make my Mouse Systems mouse work with knoppix?

  1. #1
    Junior Member
    Join Date
    Apr 2003
    Location
    USA
    Posts
    4

    how to make my Mouse Systems mouse work with knoppix?

    how to make my Mouse Systems mouse work with knoppix?

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933
    You could start by explaining how your mouse connects since there is at least one person in the world who has never heard of a Mouse System Mouse. Always post with details about your hardware.

  3. #3
    Junior Member
    Join Date
    Apr 2003
    Location
    USA
    Posts
    4

    how to make my Mouse Systems mouse work with knoppix?

    from XF86Config

    Protocol "MouseSystems"
    Device "/dev/mouse"

    also

    [clfest@localhost clfest]$ ls -l /dev/mouse
    lrwxrwxrwx 1 root root 5 Jun 9 2001 /dev/mouse -> ttyS0
    [clfest@localhost clfest]$
    [clfest@localhost clfest]$ ls -l /dev/ttyS0
    crw------- 1 root tty 4, 64 Apr 29 10:26 /dev/ttyS0

    hope this helps

  4. #4
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933
    Your XF86Config looks right to me but I have never had a serial mouse so I'm not absolutely positive.

    OK just to make sure your serial mouse IS connected to ttyS0 (COM1 in DOS) and not ttyS1 (COM2 in DOS) right? ttyS0 is the 9 pin socket, ttyS1 the 25 pin socket.

    You have not installed Knoppix to your hard drive right?

    You could open a root terminal and do kxconfig and try to change your XF86Config to Device "/dev/ttyS0"

    Let us know if it works. Maybe someone else here has a serial mouse and could provide some insight.

  5. #5
    Senior Member registered user
    Join Date
    Jan 2003
    Location
    Podunk, Idaho, USA
    Posts
    470
    I have a P-200 with a mouse system serial mouse and it works fine in knoppix. I would suspect that you are using the wrong serial port.

    rock

  6. #6
    Junior Member
    Join Date
    Apr 2003
    Location
    USA
    Posts
    4

    how to make my Mouse Systems mouse work with knoppix?

    my mouse works fine with the RedHat system. If I just do the default knoppix setup, the mouse
    sends some kind of signals which effect the pointer on the screen, but I responds erratically
    (wrong protocol). Is the 'kxconfig' command a GUI tool. If it is I can't use it 'cause I can't
    use the mouse (chicken + egg). I'll try it in text mode anyhow...

  7. #7
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479
    You might want to check if gpm is installed if this is a HD install see post here.

  8. #8
    Junior Member
    Join Date
    Apr 2003
    Location
    USA
    Posts
    4
    kxconfig, as I suspected only works with X, hence the chicken+egg problem I alluded to
    below. gpm is not on on knoppix, (no gpm.pid file, no gpm process). I think, I need someway
    to insert the proper protocol somewhere in the XF86Config-4 file, but I don't know how
    to make sense out of that file. Of course, I may be wrong...

  9. #9
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933
    Quote Originally Posted by clfest
    kxconfig, as I suspected only works with X, hence the chicken+egg problem I alluded to
    below.
    Uh..............oops- sorry. Sometimes I don't pay very close attention do I?

    Moving right along.......... I'm unsure of whether you're booting the cd or have Knoppix installed. At any rate, what protocol does your Redhat install use? I would put that in your XF86Config and smoke it.

    If you're booting the cd then just boot Knoppix 2 and run /usr/X11R6/bin/XFree86 -configure
    (I have not attempted this feat myself but I think it's legit )

    -OR-

    Maybe edit your XF86Config to read like this:

    Option "Protocol" "Auto"

    That's pretty self explainatory eh?

    I'm outta guesses for now.

Similar Threads

  1. Mouse doesn't work after Knoppix upgrade
    By ezuk in forum Hardware & Booting
    Replies: 1
    Last Post: 04-26-2004, 09:26 PM
  2. USB mouse doesn't work
    By MDesigner in forum Hardware & Booting
    Replies: 6
    Last Post: 04-24-2004, 10:42 AM
  3. How to get a USB mouse to work
    By ghank in forum Hardware & Booting
    Replies: 0
    Last Post: 03-22-2004, 07:40 PM
  4. My Mouse Doesn't Work at all........
    By TecLvR23 in forum General Support
    Replies: 1
    Last Post: 02-02-2004, 07:05 PM
  5. Replies: 6
    Last Post: 07-07-2003, 07:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •