Results 1 to 3 of 3

Thread: resetting root password on a SuSE 9.3 system

  1. #1
    Junior Member
    Join Date
    Jun 2005
    Posts
    2

    resetting root password on a SuSE 9.3 system

    I lost the root password on a SuSE 9.3 system. The failsafe mode
    was also password protected. I tried to use Knoppix 3.7 to reset
    and unset the passwords.....it has not worked.

    I booted Knoppix 3.7, and attempted the procedure in the
    "Knoppix Hacks" book, #66. A problem (I think) is that the /etc files
    are on partition /dev/hda6 (passwd and shadow files), while the
    system executable that changes the password is on /dev/hda7.
    So I mounted both mount -o rw ..../ same for hda7,
    then tried

    sudo chroot /mnt/hda6 passwd It could not find the file.

    also I tried a hard path to the passwd binary, and that still
    did not work. The program to change the passwd would never
    execute.

    So then I tried the following, with /mnt/hda6 mounted rw,
    where passwd and shadow are located.....
    I edited those files, and replaced the characters between the
    first set of colons with ::
    This should have resulted in no root password for the system
    upon reboot.
    Not the case.
    When I reboot, and login as a regular user, and then issue the
    su command, the password prompt never shows, but in a few
    seconds the message "incorrect password" is shown....so the
    password can never be entered. Single user mode and failsafe
    provide the same behavior.
    Help please!

  2. #2
    Senior Member
    Join Date
    Nov 2003
    Posts
    1,323
    Try adding to /mnt/hda6/etc/sudoers this: your_username ALL=NOPASSWD: ALL
    Then boot suse and do as user: sudo passwd

  3. #3
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY USA
    Posts
    1,510
    I would mount the root / & then mount the /etc in the /.
    Assuming /dev/hda7 is your root and /dev/hda6 is /etc.
    Boot knoppix.

    become root user in knoppix.
    su -

    Then mount the /root, but first create a mount point.
    mkdir /mnt/suse-root
    mount -t reiserfs /dev/hda7 /mnt/suse-root
    mount -t reiserfs /dev/hda6 /mnt/suse-root/etc

    Then chroot into that environment
    chroot /mnt/suse-root /bin/bash

    Then change the password.
    passwd

    Then exit
    exit

    Then unmount the partitions
    umount /mnt/suse-root/etc /mnt/suse-root

    Then reboot
    init 6

    The above steps have always worked for me.

Similar Threads

  1. How can I set a root password????
    By oganika in forum Customising & Remastering
    Replies: 6
    Last Post: 11-26-2006, 07:12 PM
  2. Resetting Windows XP password with Knoppix 5.0
    By askme in forum General Support
    Replies: 5
    Last Post: 06-20-2006, 06:44 AM
  3. root password
    By luagh45 in forum General Support
    Replies: 1
    Last Post: 10-27-2005, 11:06 PM
  4. Root password?
    By CyberShadow in forum General Support
    Replies: 1
    Last Post: 04-05-2004, 06:49 AM
  5. No root file system (but system works)
    By freyley in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 01-31-2003, 09:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •