Results 1 to 3 of 3

Thread: No .cmg files run anymore.

  1. #1
    Junior Member
    Join Date
    Nov 2005

    No .cmg files run anymore.

    All .cmg files stopped running; result was dialog about adding lines to /tmp/app. Found no /tmp/app; created one and added prescribed lines. Same result. Reinstalled klik. Downloads are OK, but nothing runs. Nice quiet failure - no dialogs or errors. Tried running from a terminal; got error: "/tmp/app/ exosts but is not a directory". All a bit disappointing, especially since I can install directly from a Debian repository.
    Best regards;
    hotrodg (Hal)

    After the complaint, figured I owe you an update. Created a /tmp/app directory and put app file in it. Tried to run a .cmg file. Result: complaint that /tmp/app was not writable. Changed permissions and tried again. Some apps now run. How did this happen? I did not change the klik installation, at least not intentionally. What the **** is going on? Is there a clear explanation of how this all works somewhere? As a programmer, I'm used to guesses and trial&error, but I'm getting weary...


  2. #2
    Junior Member registered user
    Join Date
    Nov 2005
    hmmm... I don't really understand what could happen on your system, but the only reason I see why cmgs might stop working is when you run too many (more than 7 actually) at the same time.

    Do mount command to see how much klik images are mounted. (and possibly kill some unneeded klik processes)

  3. #3
    Junior Member
    Join Date
    Nov 2005
    mount command looks ok - no cramfs line if no .cmg file is running; cramfs line present in a .cmg file is running. also, /etc/fstab contains the cramfs descriptor lines. Hope you saw my update. The .cmg files run now. The problem was apparently a missing writable /tmp/app directory. How it went missing I have no idea. One observation: Isn't this a weakness - having a (quasi) system directory that can be written (or possibly deleted) by a user process? In any case, everything looks ok now. Thanks & best regards. --hotrodg

Similar Threads

  1. X doesn't start anymore
    By arno. in forum Hdd Install / Debian / Apt
    Replies: 3
    Last Post: 11-26-2005, 10:46 AM
  2. Help! I can't run Firefox anymore
    By GadgetMan in forum General Support
    Replies: 2
    Last Post: 11-18-2004, 11:04 PM
  3. No DSL connection anymore
    By Delbor in forum Networking
    Replies: 0
    Last Post: 12-19-2003, 12:41 AM
  4. Can't diallup anymore
    By fingers99 in forum Hdd Install / Debian / Apt
    Replies: 6
    Last Post: 10-25-2003, 12:36 AM
  5. DSL doesn't work anymore
    By Fleshgolem in forum Hdd Install / Debian / Apt
    Replies: 4
    Last Post: 07-27-2003, 08:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts