Results 1 to 5 of 5

Thread: Rosegarden gives error regarding libssl.so.0.9.7

  1. #1
    Junior Member
    Join Date
    Dec 2005
    Posts
    8

    Rosegarden gives error regarding libssl.so.0.9.7

    Hi all,

    I thought I'd give Rosegarden a go. I'm looking at installing either Open Suse or Mandriva on a friends laptop (both have Rosegarden - I gather - as part of their package; however even then I gather it's a real PITA to get running). I then saw it here (whoo hoo) and thought I'd give it a go in my FC3 box.

    When I try to run it I get the following error:

    /tmp/app/1/usr/bin/rosegarden4: error while loading shared libraries: libssl.so.0.9.7: cannot open shared object file: No such file or directory

    I've searched for the file:

    libssl.so.0.9.7

    and the closest I've come up with is:

    /lib/libssl.so.0.9.7a
    /usr/lib/AdobeReader/Reader/intellinux/lib/libssl.so.0.9.6

    I'm assuming that it neither of these are satisfactory

    Can anyone advise as to a work around?

    Any assistance provided would be most appreciated.

  2. #2
    Junior Member
    Join Date
    Sep 2003
    Posts
    6
    How about just simply making a symbolic link from /lib/libssl.so.0.9.7a to /lib/libssl.so.0.9.7 and then trying to run? I guess 0.9.7 and 0.9.7a don't differ that much to cause problems. Ugly hack, but should get you one step forward at least.

  3. #3
    Junior Member
    Join Date
    Dec 2005
    Posts
    8
    Quote Originally Posted by nbd
    How about just simply making a symbolic link from /lib/libssl.so.0.9.7a to /lib/libssl.so.0.9.7 and then trying to run? I guess 0.9.7 and 0.9.7a don't differ that much to cause problems. Ugly hack, but should get you one step forward at least.
    Hi nbd,

    I'm afraid I'm not quite sure what you mean.

    How do I create a symbolic link between files? I know how to make a symlink between a file in one directory to another directory, but not from an existing file to a non-existing file in the same directory... or am I misunderstanding your directions?

  4. #4
    Junior Member
    Join Date
    Sep 2003
    Posts
    6
    From commandline:

    ln -s /lib/libssl.so.0.9.7a /lib/libssl.so.0.9.7


    I know how to make a symlink between a file in one directory to another directory
    that is essentially just the same what I did above, there is no difference whether the destination is in the same directory. About the existence of the target: if it does not exist, it will be created, if it exists, ln will fail and report that the file already exists.

    If you want to override the possibly existing file, the syntax is:

    ln -sf <source> <target>

    which forces (-f) the symlink to be created even if the target file exists. This is dangerous since you might override some important files if you are not really sure what you are doing. So I suggest you don't use -f.

    Symlinks are deleted like normal files, with rm. To see what files are symlinks:

    ls -la

    should show the symlinks like libssl.so.0.9.7 -> libssl.so.0.9.7a

  5. #5
    Junior Member
    Join Date
    Dec 2005
    Posts
    8
    Hi ndb,

    Learn something new in Linux everyday

    'fraid it didn't work though

    I'm not that distrurbed as I'm trying it out only because my friend is interested in Rosegarden. I'm not going to use it, I'm more interested in graphics and the only sound editing I do is either in video editing or using Audacity.

    Look, thanks for your help all the same. Klik is still great. I was able to download and run gcompris, (one of my children is just old enough to use the pc, so she gets to play, draw, paint etc in Linux) and it was far simpler than what I was faced with in FC3, I can tell you now:

    download
    double-click
    play

    How easy is that?

    Again, thanks.

Similar Threads

  1. Is Rosegarden (music notation s/w) in Knoppix 4.0.2 ?
    By markh1289 in forum General Support
    Replies: 1
    Last Post: 01-12-2006, 05:03 AM
  2. anyone get midi or rosegarden working?
    By redss in forum General Support
    Replies: 0
    Last Post: 12-21-2004, 06:22 AM
  3. Xine error after doing a Upgrade, error posted. (resolved)
    By Cuddles in forum Hdd Install / Debian / Apt
    Replies: 17
    Last Post: 01-20-2004, 04:30 PM
  4. mkisofs error: end request: I/O error, dev 02:00 (floppy...
    By labrador in forum Customising & Remastering
    Replies: 0
    Last Post: 07-18-2003, 01:54 AM
  5. Partition-error (Table written but error while reading!!!)
    By Mad_Max_FX in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 06-22-2003, 03:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •