Results 1 to 4 of 4

Thread: kdebluetooth depends on xmms

  1. #1
    Junior Member
    Join Date
    Dec 2005
    Posts
    3

    kdebluetooth depends on xmms

    I was trying to remove xmms...
    Code:
    root@not a tty[/]# apt-get remove --purge xmms
    Reading Package Lists... Done
    Building Dependency Tree... Done
    The following packages will be REMOVED:
      kdebluetooth* smpeg-xmms* xmms* xmms-cdread* xmms-goom* xmms-volnorm*
    0 upgraded, 0 newly installed, 6 to remove and 723 not upgraded.
    Need to get 0B of archives.
    After unpacking 11.5MB disk space will be freed.
    Do you want to continue? [Y/n] Y
    (Reading database ... 86811 files and directories currently installed.)
    Removing kdebluetooth ...
    dpkg-divert: mismatch on divert-to
      when removing `diversion of /usr/bin/kdesktop_lock to /usr/bin/kdesktop_lock_nobt by kdebluetooth'
      found `diversion of /usr/bin/kdesktop_lock to /usr/bin/kdesktop_lock.orig by kdelock-knoppix'
    dpkg: error processing kdebluetooth (--purge):
     subprocess post-removal script returned error exit status 2
    Removing smpeg-xmms ...
    Purging configuration files for smpeg-xmms ...
    Removing xmms-volnorm ...
    Removing xmms-cdread ...
    Removing xmms-goom ...
    dpkg: xmms: dependency problems, but removing anyway as you request:
     kdebluetooth depends on xmms.
    Removing xmms ...
    Purging configuration files for xmms ...
    Errors were encountered while processing:
     kdebluetooth
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    root@not a tty[/]# apt-get remove --purge xmms-modplug 
    Reading Package Lists... Done
    Building Dependency Tree... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      kdebluetooth: Depends: xmms but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    However xmms seems to be desappeared:
    Code:
    root@not a tty[/]# xm
    xmag        xman        xmessage    xminicom    xmkmf       xmlcatalog  xmllint     xmodmap     xmonisdn
    So does anyone know what does it means ?
    Ehm, by the way, there's a way to know the size of the iso file before using mkisofs ?

  2. #2
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272

    Re: kdebluetooth depends on xmms

    Quote Originally Posted by under
    I was trying to remove xmms...
    Code:
    root@not a tty[/]# apt-get remove --purge xmms
    Reading Package Lists... Done
    Building Dependency Tree... Done
    The following packages will be REMOVED:
      kdebluetooth* smpeg-xmms* xmms* xmms-cdread* xmms-goom* xmms-volnorm*
    This is normal because there might be some libraries common to both packages. This is what I get if I try to remove xmms:
    Code:
    root@1[~]# apt-get --purge remove  xmms
    Luetaan pakettiluetteloita... Valmis
    Muodostetaan riippuvuussuhteiden puu... Valmis
    Seuraavat paketit POISTETAAN:
      gdancer* gjay* ipodder* kde* kdeutils* python-xmms* python2.3-xmms* superkaramba* xmms*
      xmms-alarm* xmms-arts* xmms-blursk* xmms-bumpscope* xmms-cdread* xmms-coverviewer* xmms-crossfade*
      xmms-dbmix* xmms-festalon* xmms-find* xmms-finespectrum* xmms-flac* xmms-fmradio* xmms-goodnight*
      xmms-goom* xmms-infinity* xmms-infopipe* xmms-iris* xmms-jess* xmms-kde* xmms-kjofol*
      xmms-kjofol-skins* xmms-lirc* xmms-liveice* xmms-mp4* xmms-msa* xmms-qbble* xmms-rplay*
      xmms-shell* xmms-sid* xmms-singit* xmms-skins* xmms-stats* xmms-synaesthesia* xmms-volnorm*
      xmms-wmdiscotux* xmms-xf86audio*
    As you can see, kdebluetooth is not removed in my case but many other packages. Perhaps I have a newer package of kdebluetooth. You can check your version by:
    Code:
    root@1[~]# dpkg -l | grep kdeblue
    ii  kdebluetooth                       0.99+1.0beta1-6+b1            KDE Bluetooth Framework
    You can also check available versions and dependencies by apt-cache show kdebluetooth:
    Code:
    root@1[~]# apt-cache show kdebluetooth
    Package: kdebluetooth
    Priority: optional
    Section: kde
    Installed-Size: 3564
    Maintainer: Michael Meskes <meskes@debian.org>
    Architecture: i386
    Version: 0.99+1.0beta1-6+b1
    Depends: kdelibs4c2a (>= 4:3.4.3-1), libart-2.0-2 (>= 2.3.16), libaudio2, libbluetooth1 (>= 2.19), libc6 (>= 2.3.5-1), libfam0, libfontconfig1 (>= 2.3.0), libfreetype6 (>= 2.1.5-1), libgcc1 (>= 1:4.0.2), libice6, libidn11 (>= 0.5.18), libjpeg62, libopenobex-1.0-0 (>= 1.0.0-rel), libpng12-0 (>= 1.2.8rel), libqt3-mt (>= 3:3.3.5), libsm6, libstdc++6 (>= 4.0.2-4), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxft2 (>> 2.1.1), libxi6, libxinerama1, libxrandr2, libxrender1 (>> 1:0.9.0-1), libxt6, qobex, zlib1g (>= 1:1.2.1)
    Suggests: python
    Filename: pool/main/k/kdebluetooth/kdebluetooth_0.99+1.0beta1-6+b1_i386.deb
    Size: 1213392
    MD5sum: 9fbdf0e52daa00e7e460b1fda1a84f8d
    Description: KDE Bluetooth Framework
     The KDE Bluetooth Framework provides several easy to use
     tools to be used with Bluetooth devices.
    
    Package: kdebluetooth
    Priority: optional
    Section: kde
    Installed-Size: 4512
    Maintainer: Michael Meskes <meskes@debian.org>
    Architecture: i386
    Version: 0.99+1.0beta1-5
    Depends: kdelibs4c2 (>= 4:3.4.2-1), libart-2.0-2 (>= 2.3.16), libaudio2, libbluetooth1 (>= 2.19), libc6 (>= 2.3.5-1), libfam0, libfontconfig1 (>= 2.3.0), libfreetype6 (>= 2.1.5-1), libgcc1 (>= 1:4.0.1), libice6 | xlibs (>> 4.1.0), libidn11 (>= 0.5.18), libjpeg62, libopenobex-1.0-0 (>= 1.0.0-rel), libpng12-0 (>= 1.2.8rel), libqt3-mt (>= 3:3.3.4), libsm6 | xlibs (>> 4.1.0), libstdc++6 (>= 4.0.1), libx11-6 | xlibs (>> 4.1.0), libxcursor1 (>> 1.1.2), libxext6 | xlibs (>> 4.1.0), libxft2 (>> 2.1.1), libxi6 | xlibs (>> 4.1.0), libxinerama1, libxrandr2 | xlibs (>> 4.3.0), libxrender1 (>> 1:0.9.0-1), libxt6 | xlibs (>> 4.1.0), qobex, zlib1g (>= 1:1.2.1)
    Suggests: python
    Filename: pool/main/k/kdebluetooth/kdebluetooth_0.99+1.0beta1-5_i386.deb
    Size: 1352364
    MD5sum: 91ccdf2584084ffa849011b3a4f0e8f8
    Description: KDE Bluetooth Framework
     The KDE Bluetooth Framework provides several easy to use
     tools to be used with Bluetooth devices.
    Checking can also be done from Debian's web site http://www.debian.org/distrib/packages

    Installing kdebluetooth afresh from unstable could solve your problem:
    Code:
    apt-get install -t unstable kdebluetooth
    You must have unstable source in /etc/apt/sources.list.

    -tapsa-

  3. #3
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    Cleveland, OH
    Posts
    228
    You could try removing kdebluetooth prior to removing xmms to get that error out of the equation. Please refer to tapsa's post below on how to do this.

    http://www.knoppix.net/forum/viewtopic.php?p=97957

    basically you want to run these steps:

    #rm /usr/bin/kdesktop_lock

    # dpkg-divert --rename --remove /usr/bin/kdesktop_lock

    you will see the following error:

    Removing kdebluetooth ...
    No diversion `diversion of /usr/bin/kdesktop_lock to /usr/bin/kdesktop_lock_nobt by kdebluetooth', none removed

    but an apt-get remove kdebluetooth will tell you that it is no longer installed.

  4. #4
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272
    Quote Originally Posted by pau1knopp
    I think that the inability to remove kdebluetooth is a bug in 4.0.2. To the best of my knowlege and research (whilst attempting to upgrade to kde 3.5) this is not possible.
    Ok, now I undestand what was your problem - dpkg-divert. It is not a bug but a possibility to install multiple similar packages and you can choose which one to use.

    I have previously answered in topic kdebluetooth how to get this fixed.


    -tapsa-

Similar Threads

  1. disable kdebluetooth?
    By Mr.Digimon in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 04-25-2006, 01:07 PM
  2. Apt-get und kdebluetooth entfernen
    By knorpelix in forum German Forum
    Replies: 1
    Last Post: 03-12-2006, 09:35 AM
  3. kdebluetooth
    By Kevins27 in forum Hdd Install / Debian / Apt
    Replies: 5
    Last Post: 12-12-2005, 09:08 PM
  4. Apt-Get Tells me i am missing depends but I have them...
    By MattM in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 04-08-2004, 09:33 PM
  5. 1 or 2 processors? Depends upon which CD I boot
    By BillS in forum Hardware & Booting
    Replies: 4
    Last Post: 01-22-2004, 07:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •