Results 1 to 7 of 7

Thread: Soundcard not working - VIA 8233 AC97

  1. #1
    Junior Member
    Join Date
    May 2003
    Location
    Krakow, Poland
    Posts
    4

    Soundcard not working - VIA 8233 AC97

    Hello,
    My Knoppix 3.1 (I haven't tried 3.2 yet, I'm currently downloading it) does not support the onboard AC97 audio controller on VIA VT8233 chip. During bootup, Knoppix identifies the device (correctly) as "VT8233 AC97 audio controller", but the module via82cxxx.o responds with "No such device" message and the sound is not working. I tried to find some support on linux newsgroups and I was told that via82cxxx.o module does not support this chip and I have to find a newer driver. Can anybody point me to the correct file?

  2. #2
    Member registered user
    Join Date
    Feb 2003
    Posts
    84
    I have a similar sound system. The alsa drives found on Knoppix 3.2 will fix your problem. I never found a solution for this chip that wasn't alsa.

    Good luck

  3. #3
    Junior Member
    Join Date
    May 2003
    Location
    Krakow, Poland
    Posts
    4

    (deleted)

    (deleted)

  4. #4
    Junior Member
    Join Date
    May 2003
    Location
    Krakow, Poland
    Posts
    4

    Info from VIA website

    Just now I found the following information on the VIA website. I think this explains all questions related to this chip.
    I only regret that I can't use the VIA's drivers available on mainboard installation CD... . The highest kernel version they are available for is 2.4.0, and the kernel in knoppix is 2.4.19...
    No other way, I have to look for ALSA... Could you tell me in brief, how to enable the ALSA drivers instead of default ones?

    ============ information form VIA website: ===========

    VIA provides drivers for VIA AC97 sound specifically written for major Linux distribution packages. They can be found here.


    In addition, the Audio category of the Linux Application notes provides useful information and instructions for installation:

    Mandrake Linux Audio driver notes
    Red Flag Linux Audio driver notes
    Red Hat Linux Audio driver notes
    SuSE Linux Audio driver notes

    The following is a summary of Linux audio support at this time. There are four drivers available from different vendors.

    1. Linux kernel built-in: VIA's driver team has been working with kernel developers to integrate the audio driver into official kernel releases. The developers receive VIA's source and revise it before checking itinto the kernel. Built-in drivers, however, didn't support the VT8233/ 8233A/ 8235 southbridges until the kernel version 2.4.20. The source code is available in the kernel source tree.

    2. VIA's driver: VIA's driver supports the more popular distributions only. The source code is not released to the public.

    3. ALSA's driver: This driver can be found at ALSA's website. SuSE 8.1 and Mandrake 9.0 has adopted it as the default audio driver. It's also source available and free for all VIA southbridge parts. VIA's driver team works with ALSA.

    4. OSS's driver: A fee is charged to use this driver once the evalution period is expired. It supports all of VIA's southbridge parts.

    If you are not using one of the more common Linux distributions, we suggest that you use the ALSA driver. It's free, the quality is very good and the source is available without any charge.

  5. #5
    Senior Member registered user
    Join Date
    Nov 2002
    Posts
    1,353
    It's pretty easy to enable ALSA. When you boot up type: "knoppix alsa" (without the quotation marks of course). Hope this works.

  6. #6
    Senior Member registered user
    Join Date
    Nov 2002
    Posts
    1,353
    Don't get upset if you decide to do a hd install and find that ALSA is no longer working.

    Just do this (as root)

    /etc/init.d/alsa-autoconfig

  7. #7
    Junior Member registered user
    Join Date
    Feb 2004
    Posts
    17
    sjupier!!!! danke!

Similar Threads

  1. How to get sound working (VIA VT82C686 [Apollo Super AC97])
    By XemonerdX in forum Hardware & Booting
    Replies: 1
    Last Post: 03-27-2005, 04:13 PM
  2. VIA VT8233 AC97 onboard audio controller not working :[
    By psychopath in forum Hardware & Booting
    Replies: 0
    Last Post: 03-10-2005, 09:27 PM
  3. Intel 810 AC'97 soundcard only partially working
    By JNeuhoff in forum Hardware & Booting
    Replies: 2
    Last Post: 02-27-2005, 09:52 PM
  4. Soundcard trouble ac97 of course
    By lace99 in forum Hardware & Booting
    Replies: 2
    Last Post: 06-01-2004, 07:08 AM
  5. I seem to be unable to get my soundcard working.
    By MagicianCamille in forum Hardware & Booting
    Replies: 6
    Last Post: 05-06-2004, 05:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •