Hi folks,

Have a newly partitioned HD with following config;

root@ttyp0[knoppix]# fdisk -l
Disk /dev/hda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          13      104391   83  Linux
/dev/hda2              14          77      514080   82  Linux swap
/dev/hda3              78        1415    10747485   83  Linux
/dev/hda4            1416        4865    27712125    5  Extended
/dev/hda5            1416        2510     8795556   83  Linux
/dev/hda6            2511        3485     7831656   83  Linux
/dev/hda7            3486        4216     5871726   83  Linux
/dev/hda8            4217        4865     5213061   83  Linux
without OS installed.

/dev/hda5, /hda6/, hda7 and /hda8 all have data files. All partitions can be mouted previously on running Knoppix 4.0 LiveCD.
with "mount /dev/hdax /mnt/hdax" as Root and mounting on deskop on their icons as User.

An hour before ran Knoppix 4.0 to browse Internets and have some files saved on /dev/hda8. Those files were not download on Internet. Just copied some text/information from Internet on existing files on /dev/hda8. The PC/Knoppix LiveCD worked without problem and was turned off later.

Now after turning on the PC and starting Knoppix LiveCD it was found /dev/hda8 could not be mounted.

root@ttyp0[knoppix]# mount /dev/hda8 /mnt/hda8
mount: wrong fs type, bad option, bad superblock on /dev/hda8,
       or too many mounted file systems
Other partitions can be mouted without problem. The data/files on them can be read.

root@0[knoppix]# e2fsck -f /dev/hda8
e2fsck 1.38 (30-Jun-2005)
e2fsck: Filesystem revision too high while trying to open /dev/hda8
The filesystem revision is apparently too high for this version of e2fsck.
(Or the filesystem superblock is corrupt)

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
Whether to run "e2fsck -b 8193 /dev/hda8" to clean it.

I think the problem was caused by adding some information to a file on /dev/hda8. I opened the file as USER. After adding some information to it I tried saving it back to /dev/hda8 but not allowed. Then I saved it to /home/knoppix/tmp/new_file_name. Started a console, "su" Root and moved to file to /dev/hda8. I tried this trick before without problem.

Is it possible to backup the files on /dev/hda8? I have 3~4 important files on this partition which I expect to reserve if possible.

Please advise how to fix this problem.