Results 1 to 5 of 5

Thread: LAN card not detected

  1. #1
    Junior Member
    Join Date
    Feb 2006
    Posts
    2

    LAN card not detected

    Hi
    I am a newbie to computers and linux. I am using asrock k8nf4g-sata2 motherboard with realtek phyrtl8201cl LAn card. when boot using the knoppx live on CD it fails to recognise LAN card . I am unable to connet to internet. Presently I am using windows XP, which is installed on the same computer

    Help will be greatly appreciated
    regards

  2. #2
    Senior Member registered user
    Join Date
    Jul 2004
    Location
    Southern Maine, US
    Posts
    274
    I believe Knoppix has a LAN card setup utility.

  3. #3
    Junior Member
    Join Date
    Feb 2006
    Posts
    2

    LAN card not detected

    Dear Kowood
    Thanks for the reply. I am unable to find such a utility. Configuration wizard just close after citing no network card found.

    Your help will be greatly appreciated

    regards
    [/quote]

  4. #4
    Senior Member registered user
    Join Date
    Jul 2004
    Location
    Southern Maine, US
    Posts
    274
    I have a k8n mobo as well. I built support for my integrated NIC into the kernel, but the module forcedeth can also be used.
    Code:
    # modprobe forcedeth
    may help with loading the driver. Then issue
    Code:
    # dhclient eth0
    to use DHCP (almost all home routers use this). And if this doesn't work, please post the output of
    Code:
    # lspci -v
    .

  5. #5
    Senior Member registered user
    Join Date
    Apr 2005
    Location
    italy
    Posts
    245
    It's look like knoppix doesn't recognize your card. The livecd should auto-recognize it at boot. AFAIK the only circumstance where is necessary 'explicitly' run the appropriate netcardconfig command is after a regular hdinstall.

Similar Threads

  1. Ethernet card not detected
    By Steven2ic in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 04-08-2006, 10:04 PM
  2. video card not detected
    By guyofgames in forum Hardware & Booting
    Replies: 2
    Last Post: 04-13-2005, 05:08 PM
  3. Sound card not detected
    By DarkAeons in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 12-21-2004, 06:05 PM
  4. Network Card NOt Detected
    By BlackmageIX in forum Networking
    Replies: 1
    Last Post: 07-24-2004, 11:57 PM
  5. second nic card detected?
    By ldp in forum Hardware & Booting
    Replies: 9
    Last Post: 04-15-2004, 02:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •