Results 1 to 2 of 2

Thread: laptop Broadcom wlan in Knoppix 4.0.2. no wlan in winXP.HELP

  1. #1
    Junior Member
    Join Date
    Jun 2006

    laptop Broadcom wlan in Knoppix 4.0.2. no wlan in winXP.HELP

    Yesterday I ran Knoppix 4.0.2 for the first time on a Presario v2000 AMD 64 w/ XP sp2.

    In my attempt to connect to my wireless network I did this.

    downloaded the drivers for my waln adapter from compaq to a folder on my windows desktop. deleted the filed I didn't need and was left with a folder with these files:

    then rebooted to knoppix 4.0.2

    i then copied all of these files to the /home/tmp directory.

    then ran ndiswrapper and tried bcmwl5.inf(didn't work) then bcmwl5a.inf which finally got me a little closer.

    then at the command line:

    bash# su-
    bash# /usr/sbin/ndiswrapper -i/home/tmp/bcmwl5.inf
    bash# /usr/sbin/ndswrapper -l
    -this was all usefull...then

    after that i was told to do these next:
    bash# /usr/sbin/ndswrapper -m (nothing)
    bash# modprobe wlan0 (nothing)

    what did work though to get it up was:
    bash# iwlist wlan0 scan

    from there everything was good. after a few minutes i restarted in windows and discovered my wlan no longer works in windows xp. the button to activate the internal lan is lit by led when on. it no longer goes on but when you press the button the system tray toggles from on to disabled. even with it on(according to the tray) i can't get online and in my device manager it has the yellow exclamation mark.

    i've uninstalled and installed the drivers. i've tried using a belkin 7050 adapter with belkin drivers and the same thing with that. windows sees the devices but they won't start (code 10 in the device manager)

    someone...PLEASE help

  2. #2
    Junior Member
    Join Date
    Jun 2006
    i finally got it working. i fugured since windows was originally using the bcmwl5.sys driver and i tinkered around in knoppix and had to use the bcmwl5a.inf driver that that was where the mix up was going on.

    after going over what i had post i then remembered that i didn't get ndiswrapper working with the bcmwl5.inf driver but the substitute bcmwl5a.inf.

    sorry for the waste of a thread

Similar Threads

  1. knoppix and WLAN
    By NAOWNER in forum Laptops
    Replies: 2
    Last Post: 11-27-2009, 03:15 AM
  2. Broadcom 802.11b/g WLAN Driver
    By FletchLives in forum Hardware & Booting
    Replies: 3
    Last Post: 04-18-2007, 07:07 PM
  3. KNX 5.1.1 wont boot with Broadcom 4306 WLAN...
    By posmanet in forum Networking
    Replies: 3
    Last Post: 02-26-2007, 03:28 PM
  4. Replies: 1
    Last Post: 01-30-2005, 03:11 AM
  5. Knoppix 3.3 wlan-ng
    By efflandt in forum Laptops
    Replies: 0
    Last Post: 12-14-2003, 03:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts