Results 1 to 3 of 3

Thread: Can't apt-get the newest relase of a package

  1. #1
    Member registered user
    Join Date
    Oct 2005
    Location
    manchester, uk
    Posts
    35

    Can't apt-get the newest relase of a package

    Hi,

    I am currently using Knoppix 5.0.1, HD install.

    I am trying to install Krita 1.5.1, but when I apt-get it, I can only install version 1.4.2. I apt-get updated my list, but there is no way I can get 1.5.1 version.

    I am quite new to linux, and I am still studying how the apt-get works. I have read the apt-get/dpkg tutorial on this forum, and also man apt-get, and I still don't understand what I am supposed to do in order to install the version I want of a package.

    this is my apt-cache policy krita

    Code:
    mmanu@scatoletta:~$ apt-cache policy krita
    krita:
      Installed: 1:1.4.2-7
      Candidate: 1:1.4.2-7
      Version table:
         1:1.5.1-1 0
            500 http://ftp.de.debian.org unstable/main Packages
     *** 1:1.4.2-7 0
            990 http://ftp.de.debian.org testing/main Packages
            100 /var/lib/dpkg/status
    As far as I understand, version 1.5.1 is already in the repositories, but the only package suitable for my system is the 1.4.2.

    Now, what am I supposed to do in order to install the 1.5.1? Do I have to run an apt-get upgrade?

    Thanks for your time.

  2. #2
    Senior Member registered user
    Join Date
    Oct 2003
    Location
    N42.41 W73 and change
    Posts
    401
    In your apt-cache output you see: 500 http://ftp.de.debian.org unstable/main Packages , which suggests that the version you want is in the unstable branch. You can specify which branch to download from like this :

    Code:
    apt-get -t unstable install <package>
    where the -t option selects the branch, testing unstable etc. For more info type: man apt-get in a terminal.

  3. #3
    Member registered user
    Join Date
    Oct 2005
    Location
    manchester, uk
    Posts
    35
    Ok, it worked, I realise I was completely ignoring the branches, something to be aware of in the future.

    Thanks a lot for your help!

Similar Threads

  1. Build a package from the source package (samba 3.2.3-3)
    By johnrw in forum Tips and Tricks
    Replies: 0
    Last Post: 10-17-2008, 03:19 AM
  2. USB Mouse and the Newest version of Knoppix
    By ang31-0f-d347h in forum General Support
    Replies: 0
    Last Post: 03-03-2004, 11:39 PM
  3. hwsetup newest
    By PrOCesSkIlL in forum Hardware & Booting
    Replies: 0
    Last Post: 11-16-2003, 08:58 PM
  4. The newest of newbies...
    By Tortoise in forum Hdd Install / Debian / Apt
    Replies: 10
    Last Post: 05-23-2003, 02:31 AM
  5. Add newest NTFS support (more stability)
    By ktheking in forum Ideas
    Replies: 3
    Last Post: 05-22-2003, 08:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •