hi all, i'm new.
first of all excuse me, i'm not too skilled with english language.
trying to do the best i can.

i'm trying to navigate with knoppix live cd and a usb modem... and i'm almost doing it.

the problem is that i can only navigate with the shell.

i now describe all the steps i've done.

1) start knoppix
2) sudo su
3) eciadsl-config-tk
4) i insert the right dns, select my ericsson hm120dp modem, cancel dabusb, save and exit
5) plug the modem
6) eciadsl-start

so, it doesn't connect to the provider.

i stop it with ctrl-c, then restart: eciadsl-start and it works fine.
• Setting up USB support
• Uploading firmware
• Synchronization
• Connecting to provider
ok them all.
the only alert i receive is:

[EciAdsl 5/5] Setting up route table...

Waiting for ppp0...
Adding default route... SIOCADDRT: Il file esiste
failed to set default route to ppp0
ok. now i can ping google, nslookup my site, ecc.
netstat is ok.
eciadsl-doctor is ok.

but if i start firefox it doesn't work.

so i tried to edit the /etc/resolv.conf (sudo nano /etc/resolv.conf) inserting nameserver and my ip: it doesn't works.
ifconfig: i haven't two ppp.
sudo firefox from shell: it doesn't works.
i tried to stop iptables. nothing.
disabled the firewall: nothing.
disabled every usepeerdns i've found: nothing.
i've searched the gateway with route -n: tried to remove it with route del default gw... nothing.

well, now i try to immerge the pc in lourdes water, stay tuned.