Results 1 to 3 of 3

Thread: Root level passwd no longer valid from desktop

  1. #1
    Junior Member
    Join Date
    Oct 2006
    Location
    Berlin
    Posts
    3

    Root level passwd no longer valid from desktop

    Hi,
    I know this is a Knoppix forum (and although I started with Knoppix and therefore read this forum avidly) my current problem is with a different distro: Kanotix. I hope it is not inappropriate to post this here (IF IT IS... I AM HAPPY TO HAVE IT WITHDRAWN). Here goes:

    I am using Kanotix (2006-01-RC4) and ran the following command (as part of a process to try an resolve a driver issue for WLAN card):
    "su -c /usr/share/bcm43xx-fwcutter/install_bcm43xx_firmware.sh"
    After running this, I no longer have a valid root password. I think the problem is that I ran the command as root (instead of "user_name", but not sure) which then locked out my access to some areas. I can open a console and type:
    "su" then "my_root_passwd" and it switches me to root. But when I try to enter a configuration screen from the desktop, I get prompted for "my_root_passwd", and enter it, but response is "invalid". I am not familar enough YET with issuing complex instructions from the console (or, I suspect, I could resolve the problem). Can someone give me advice about how to fix this. I know the way of issuing root commands in ubuntu is different from other debian based distros, but I am still hoping someone can help. I can't do much because my privileges are locked out on the desktop and I don't know how to do things from the console. Dumb noob situation... I know, but we all have to start somewhere. Thanks
    coady

  2. #2
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    England
    Posts
    177
    It's not only Kanotix; having also just tried Kanotix-2006-1-RC4 and found the same problem, I now tried Knoppix 5.0.1. It was OK to start with, but after installing some additional software, which updated some KDE libraries amongst others, it now has a similar problem.

    It seems to affect those administration tools that ask for superuser privilege via kdesu, whereas the Terminal Program - Super User Mode (Root Shell - Konsole) and X -Terminal-as-Root (GKsu), which manage the password directly, are OK.

    Poking around for kdesu files or directories ... locate and find tell different stories ... seems as if the KDE libraries are in a mixed state - some updated, some not updated.

    I then rationalised the KDE status by updating kdebase
    (enter apt-get update
    then apt-get install kdebase
    if you are working in a root console)

    Eureka! kdesu functionality is back in Knoppix 5.0.1.

    I hope this helps you with Kanotix as well; I will look at this when I get a chance.

  3. #3
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    England
    Posts
    177
    Update: yes, I've confirmed that doing

    apt-get install kdebase

    also restored kdesu functionality in my Kanotix 2006-1-RC4.

Similar Threads

  1. Hard drive no longer shows on desktop
    By Kirk-out in forum Hardware & Booting
    Replies: 2
    Last Post: 08-06-2008, 07:25 PM
  2. forgot root passwd?
    By pureone in forum Tips and Tricks
    Replies: 2
    Last Post: 02-24-2006, 04:02 AM
  3. Replies: 1
    Last Post: 10-31-2005, 09:09 PM
  4. Need Help Accessing Root Desktop On A Knoppix HD Install!!
    By Phillykid162 in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 01-09-2005, 01:50 AM
  5. knoppix 3.3 'default' root passwd???
    By Cerebrus in forum General Support
    Replies: 4
    Last Post: 06-21-2004, 01:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •